CelicaTech Main Page  CelicaTech Member List CelicaTech Image Gallery CelicaTech Data Garage Chatroom CelicaTech Forums Search CelicaTech Forums Contact CelicaTech
+ Reply to Thread
Results 1 to 11 of 11
  1. #1

    Default ST185 won't start

    Hey guys, I'm looking for advice.

    My ST185 won't start. It was working perfectly fine and then about an hour later it wouldn't start. When I turn the key there is nothing. I hot wired directly from the positive on the battery to the starter and the starter turns over, however it wouldn't start. So it seems like my problem is somewhere in between.

    Looking for your thoughts. Is there a specific relay or fuse that I should be looking at next to solve the problem?

    Thanks.
    David Walker
    ------------------

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

  2. #2
    Sorry... I got distracted... MCcelica has a brilliant future MCcelica has a brilliant future MCcelica has a brilliant future MCcelica has a brilliant future MCcelica has a brilliant future MCcelica has a brilliant future MCcelica has a brilliant future MCcelica has a brilliant future MCcelica has a brilliant future MCcelica has a brilliant future MCcelica has a brilliant future MCcelica's Avatar
    MCcelica has been to an annual Dragon Meet! MCcelica helped get Play's clutch job done. MCcelica helped bring Chaos back to the Dragon

    Join Date
    May 2006
    Location
    Castle Rock, CO
    Posts
    3,992
    Images
    232

    Default

    I'd be looking at wiring. I find it hard to believe that the starter signal cut out at the same time as what the car requires to actually fire/keep running without the wiring coming into play. Unless your fuse box is just gone or something. Seems like there's a lot going on all at once.
    Poena Hodie Vires Cras y Semper Fidelis Maximus

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
    Originally Posted by surfergravity
    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
    My coffee, without me, is useless. Without my coffee, I am useless. I must drink my coffee true.
    Shadows Army: Commanding Officer: Yoda Combat Regiment

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
    <-- If it ain't rainin', we ain't trainin'.

  3. #3

    Default

    This is gonna sound odd, but check your ground on the battery. Ive seen this before, where it seems everything is ok, but the ground isnt good enough.
    2000 Absolute Red Celica GTS 6-Spd
    1991 Crimson Red MR2 Turbo


    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


    - Shadow's Army - Commander In Chief


    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
    Originally Posted by surfergravity
    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
    This thread is gayer than Richard Simmons singing a duet with Elton John in a bath house.

  4. #4

    Default

    Or the park/neutral safety switch if its an auto. try snugging the stick up to be sure it's all the way into park, or just shift to neutral.

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

    I'm not a Jackass whisperer.

  5. #5

    Default

    ^It's a ST185, an All Trac. No automatic there.
    Mike
    92 All Trac-Daily Driver


    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

  6. #6

    Default

    Quote Originally Posted by Luni View Post
    This is gonna sound odd, but check your ground on the battery. Ive seen this before, where it seems everything is ok, but the ground isnt good enough.
    Yeah you saw it on my car last year before I replaced the cable ends.
    - Mario
    - Shadow's Army - 5 star General -

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

    Questions?

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
    .


    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


    "We are what we repeatedly do. Excellence, then, is not an act, but a Habit."

  7. #7

    Default

    Quote Originally Posted by Nitro_Alltrac View Post
    ^It's a ST185, an All Trac. No automatic there.
    O I thought it was the old one he's got pics of in his gallery. If its a manual you still have a clutch switch in series with the whole starter circuit, if that thing is not closing you won't even here a click or a buzz.
    But I'll agree to check the battery terminals and grounds too.

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

    I'm not a Jackass whisperer.

  8. #8

    Default

    Thanks guys for the tips. I've been super busy with work lately and haven't had much time to look at the car.

    I did take the dash apart and start looking at wiring, and was unhappy to see the previous owner had done some butchering of the wires. There are so many wires that were spliced in and just hanging there with bare ends. I don't even know all the things that must have been tied in. There is even spliced wires under the door sills that lead to nowhere.

    I'm guessing that this is where my problem is. I might be needing to do an extensive rewiring project on this one. I guess that is why it is my project car, unfortunately it takes time away from working on my 205.
    David Walker
    ------------------

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

  9. #9

    Default

    I have also had my all trac magically start after adding a engine ground strap. It was after I first got the car and was working out various issues.

    If not does the CEL come on when you turn the key? If not check this thread, happend to me in like March or May this year. http://www.celicatech.com/forums/sho...=#post30237113
    69 Mustang coupe 351W edelbrock performer top end, 89 Mustang GT TF top end BBK SSI intake, 90 All Trac JDM 92 swap! "Fiery the angels rose...Deep thunder rolld' around their shores. Indignant, burning with the fires of Orc."


    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

  10. #10
    Ultimo Miembro Fantástico Gigantesco ChrisD has much to be proud of ChrisD has much to be proud of ChrisD has much to be proud of ChrisD has much to be proud of ChrisD has much to be proud of ChrisD has much to be proud of ChrisD has much to be proud of ChrisD has much to be proud of ChrisD has much to be proud of ChrisD has much to be proud of ChrisD's Avatar
    ChrisD has been to an official Ogopogo Meet! ChrisD has donated to the forums! ChrisD helped get Luni's MR2 back on the road! ChrisD helped bring Chaos back to the Dragon ChrisD helped KM replace his 5-year-old clutch.

    Join Date
    Nov 2004
    Location
    Calgary AB Canada
    Posts
    6,469
    Images
    913

    Default

    Check your efi fuse. So it's cranking just won't fire?
    1988 ST165 2.2L @ 370awhp
    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

    1994 ST205 WRC
    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

  11. #11

    Default

    while the car may need a lot of wiring attention, I wouldn't go rooting around in all that until you've solved this current issue. you are opening up a can of worms that might make finding this issue even harder. I doubt the hack job under the hood is related unless something grounded out and shorted a fuse, in which case Id be checking all the main fuses. Start with the simple stuff, efi fuse, main alternator fuse, etc. Then use a multimeter to start tracing power from the battery through the fuse block and ultimately through the ignition switch.
    “It's amazing how once the mind is free of emotional pollution, logic and clarity emerge...
    Yet, it's our emotions and imperfections that makes us human.”
    ― Clyde DeSouza,

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Top Member List Chat Forum Search Contact Top