CelicaTech Main Page  CelicaTech Member List CelicaTech Image Gallery CelicaTech Data Garage Chatroom CelicaTech Forums Search CelicaTech Forums Contact CelicaTech
+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 25 of 33
  1. #1

    Default Turbo not boosting till about 5000RPM

    The Ogopogo pics inspired me. Took a look on the RC today, removed intake and spun the compressor wheel of the turbo freely with no shaft play whatsoever. So why am I not getting any boost until about 5000rpm? and the boost max is like 10 where normally it should boost 16psi with no effort.

    Some info on the turbo and when it happened, Its a CT26 with an MBC from twosRus. I was boosting for a long period of time, then It happened suddenly and not over time, the boost point changed from 2800-ish to 5000-ish, and the boost would reach 10psi max.

    I suspect it would be something to do with the wastegate, an exhaust leak before the turbo (but that would have to be major, wouldnt it?), or something with the MBC (that would explain the boost peak, but not the RPM range).

    Any opinions would help.

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

    94 JDM ST205
    94 JDM SW20
    91 JDM ST185 RC

  2. #2

    Default

    When I had an exhaust leak after the turbo. It still spooled but surged horribly. I would guess mbc. Try turning it all the way down and see what happens.

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

  3. #3

    Default

    I would have to agree with something being off with MBC. I'd start there anyway. I was doing some maintenance on mine recently and found that I had a nut missing off of the stud holding the turbo to the manifold and then found that the other 3 nuts were loose as well. I had to have an exhaust leak there but I didn't have any noticeable boost issues.

    Can you replumb the stock system to the wastegate? If you took the MBC out of the picture completely that would answer the question anyway.
    Mike
    2017 Toyota 86


    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

  4. #4

    Default

    I was thinking of putting it back to stock boost control also. I think that will be the next step to take. I think I might put her together after that and go for a quick spin. If that doesn't solve it, I'll look for an exhaust leak.

    I just had another thought..., it might be the wastegate, or actuator, so I'm thinking of putting pressure with a hand pump and check that. What do you guys think, waste of time? or possible cause?

    Thanks guys! all input is appreciated.

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

    94 JDM ST205
    94 JDM SW20
    91 JDM ST185 RC

  5. #5

    Default

    Hoses are put back to stock, and the mbc has been removed completely, however, boost has been unchanged. Very very laggy and low boost.

    Im done working on it for today, I need to get out and get me some...

    Cheers!

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

    94 JDM ST205
    94 JDM SW20
    91 JDM ST185 RC

  6. #6

    Default

    The only other thing I can think is that your waste gate is cracked open and won't seal tight. That would case all your boost to flow out until your moving enough air to actually build boost.

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

  7. #7

    Default

    If you have access to an air compressor and a vacuum pump, you can test the function of the waste gate.
    - Mario
    - Shadow's Army - 5 star General -

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

    Questions?

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
    .


    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


    "We are what we repeatedly do. Excellence, then, is not an act, but a Habit."

  8. #8

    Default

    Quote Originally Posted by Shadowlife25 View Post
    If you have access to an air compressor and a vacuum pump, you can test the function of the waste gate.
    I have both, thanks, I'll check that tomorrow after work.

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

    94 JDM ST205
    94 JDM SW20
    91 JDM ST185 RC

  9. #9

    Default

    Good deal. That will make your life much easier since you can actually test things without having to take it all apart and just guess or hope to see something obviously broken.
    Should take you about half an hour to test and verify results.

    Fingers crossed that it's something small.
    - Mario
    - Shadow's Army - 5 star General -

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

    Questions?

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
    .


    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


    "We are what we repeatedly do. Excellence, then, is not an act, but a Habit."

  10. #10
    Ultimo Miembro Fantįstico Gigantesco MrWOT has much to be proud of MrWOT has much to be proud of MrWOT has much to be proud of MrWOT has much to be proud of MrWOT has much to be proud of MrWOT has much to be proud of MrWOT has much to be proud of MrWOT has much to be proud of MrWOT has much to be proud of MrWOT has much to be proud of
    MrWOT has donated to the forums! MrWOT helped get Luni's MR2 back on the road!

    Join Date
    Dec 2004
    Location
    Boulder Creek, California
    Posts
    2,837
    Images
    52

    Default

    A blown diaphragm causes overboost, because it doesn't actuate the flapper. You need to pull the downpipe and inspect the hot side.
    I really like the way aaawelder put it: "do not include yourself in this circuit"

  11. #11

    Default

    Sounds like symptom of the WG arm disconnected from flapper (possibly - although usually your boost is MUCH lower with that) OR, more likely, clogged cat.

    What kind of exhaust system do you have on that thing? Do you even have cats?
    2000 Absolute Red Celica GTS 6-Spd
    1991 Crimson Red MR2 Turbo


    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


    - Shadow's Army - Commander In Chief


    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
    Originally Posted by surfergravity
    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
    This thread is gayer than Richard Simmons singing a duet with Elton John in a bath house.

  12. #12

    Default

    Shouldn't clogged cat spool really quick but have no power?

    It sounds more like the arm being off [like you said], or the WG broken open or something.

    Blown up hot side should be no boost at all. And if it's an RC turbo it's a steel wheel anyways.

    And FYI, the MBC would either cause stock boost or too much boost.
    If the MBC broke and allowed boost to pass early it would just go to the WG actuator and you would get stock boost.
    If the MBC broke closed you would get boost until you hit boost cut.

    Did you do any work on the car before it did that?
    Does it run hot at all?
    How's the timing?

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

  13. #13

    Default

    Jeremy, when the cat was clogged in my MR2, it spooled slow as fuck. It only got 4 PSI and it took FOREVER to get there.
    2000 Absolute Red Celica GTS 6-Spd
    1991 Crimson Red MR2 Turbo


    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


    - Shadow's Army - Commander In Chief


    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
    Originally Posted by surfergravity
    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
    This thread is gayer than Richard Simmons singing a duet with Elton John in a bath house.

  14. #14

    Default

    Yeah, I'm not sure on that [which is why I question marked it ].
    I know that exhaust gas slow down would gives you quicker spool and more torque at a lower RPM.
    I wasn't sure about something that extreme though, and I've never dealt with it with a turbo.

    Too bad you live in the miggle of the goddamn mountains, I think it would be good to have a beer together.
    Or 20.

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

  15. #15

    Default

    Well, my company has a datacenter in Andover. If I ever get sent out there. Im calling you up.
    2000 Absolute Red Celica GTS 6-Spd
    1991 Crimson Red MR2 Turbo


    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


    - Shadow's Army - Commander In Chief


    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
    Originally Posted by surfergravity
    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
    This thread is gayer than Richard Simmons singing a duet with Elton John in a bath house.

  16. #16

    Default

    When my cat clogged on the Supra, it gradually was able to build less and less boost, then finally no boost, then unable to rev well, and finally unable to rev high enough to even maintain highway speed. Exhaust issue is one of the first things I thought of when I read the original post. On mine it was really simple to test, because it was just one vband clamp and the exhaust was completely out of the loop. On a stock 3sgte system that's a lot more annoying to test, obviously..
    ra·tion·al·ize /ˈręʃənlˌaɪz, ˈręʃnlˌaɪz/ Show Spelled [rash-uh-nl-ahyz, rash-nl-ahyz] Show IPA verb, -ized, -iz·ing.
    –verb (used with object)
    1. to ascribe (one's acts, opinions, etc.) to causes that superficially seem reasonable and valid but that actually are unrelated to the true, possibly unconscious and often less creditable or agreeable causes.

  17. #17

    Default

    Andover, huh?
    Stay away from Lawrence.

    Yeah, give me a call.
    Just give me at least a few days heads up. I work nights and have 2 little wild animals at home.
    So it's hard to escape without making plans.

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

  18. #18
    Senior Member underscore is a jewel in the rough underscore is a jewel in the rough underscore is a jewel in the rough
    underscore has been to an official Ogopogo Meet! underscore has donated to the forums!

    Join Date
    Apr 2011
    Location
    Kelowna, BC, Canada
    Posts
    905

    Default

    Have you checked for an intake/boost leak?
    1992 GT-S // 1991 GTFour RC // 2007 Jeep Grand Cherokee CRD

  19. #19
    I'll be the little spoon KoreanJoey has a reputation beyond repute KoreanJoey has a reputation beyond repute KoreanJoey has a reputation beyond repute KoreanJoey has a reputation beyond repute KoreanJoey has a reputation beyond repute KoreanJoey has a reputation beyond repute KoreanJoey has a reputation beyond repute KoreanJoey has a reputation beyond repute KoreanJoey has a reputation beyond repute KoreanJoey has a reputation beyond repute KoreanJoey has a reputation beyond repute KoreanJoey's Avatar
    KoreanJoey has been to an annual Dragon Meet! KoreanJoey has donated to the forums! KoreanJoey helped get Play's clutch job done. KoreanJoey helped Azzy get to The Dragon in 2009. KoreanJoey helped bring Chaos back to the Dragon

    Join Date
    Dec 2004
    Location
    Gig Harbor, WA
    Posts
    7,504
    Images
    85

    Default

    Could also be cam timing as well.

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

    OR Call: 1-877-810-7067
    -Part of the Mod Team-
    Joey; Turning Ricers into Racers, one convert at a time.



    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
    Originally Posted by MCcelica
    Joey wins this thread.

  20. #20

    Default

    Could be your FACE Joey!
    2000 Absolute Red Celica GTS 6-Spd
    1991 Crimson Red MR2 Turbo


    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


    - Shadow's Army - Commander In Chief


    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
    Originally Posted by surfergravity
    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
    This thread is gayer than Richard Simmons singing a duet with Elton John in a bath house.

  21. #21

    Default

    No cat. I think it has an ebay dowpipe but it works. Im going to take it off, Inspect dp and turbo as soon as I can. Its my RC, but not sure about the impeller being ceramic or steel. I have replaced the motor with another RC motor, and it seems to runs warm to the touch (compared to my mr2 and 205) but the temp gauge shows normal.

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

    94 JDM ST205
    94 JDM SW20
    91 JDM ST185 RC

  22. #22

    Default

    Quote Originally Posted by KoreanJoey View Post
    Could also be cam timing as well.

    It runs strong with no boost...still might be worth a quick check before ripping off the turbo and dp .

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

    94 JDM ST205
    94 JDM SW20
    91 JDM ST185 RC

  23. #23

    Default

    Also. I removed the mbc and its still driving exactly the same. Compressor wheel spins smooth with no play.

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

    94 JDM ST205
    94 JDM SW20
    91 JDM ST185 RC

  24. #24

    Default

    Taking the downpipe off today, to inspect the wastegate and dp I found the o2 sensor wire cut and disconnected. Could this effect my boost? I picked up a replacement (ct26)turbo in case I need it. I ran out of time to complete the disassembly of the turbo.

    More to come tomorrow.

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

    94 JDM ST205
    94 JDM SW20
    91 JDM ST185 RC

  25. #25

    Default

    Sounds like your wastegate may be stuck open...

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
    Originally Posted by Murgatroy
    I was deaf, sore and majorly pissed off

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Top Member List Chat Forum Search Contact Top