CelicaTech Main Page  CelicaTech Member List CelicaTech Image Gallery CelicaTech Data Garage Chatroom CelicaTech Forums Search CelicaTech Forums Contact CelicaTech
+ Reply to Thread
Results 1 to 10 of 10
  1. #1
    Lifetime Member shreddr69 is on a distinguished road
    shreddr69 has donated to the forums!

    Join Date
    May 2010
    Location
    north California
    Posts
    148

    Default I removed my air conditioning now the check engine light is on. How do I eliminate it??

    I have an 88 st165. I removed the AC and a check engine code came up. Does anyone know what to do to bypass the AC plug that run to the ECU? It's code #51, which is said to be TP sensor, AC switch, accelerator cable, or any combo of the 3 as far as I can tell and since I pulled the AC, that is my first logical choice. Any ideas would be most appreciated. Thanks!

  2. #2
    I'll be the little spoon KoreanJoey has a reputation beyond repute KoreanJoey has a reputation beyond repute KoreanJoey has a reputation beyond repute KoreanJoey has a reputation beyond repute KoreanJoey has a reputation beyond repute KoreanJoey has a reputation beyond repute KoreanJoey has a reputation beyond repute KoreanJoey has a reputation beyond repute KoreanJoey has a reputation beyond repute KoreanJoey has a reputation beyond repute KoreanJoey has a reputation beyond repute KoreanJoey's Avatar
    KoreanJoey has been to an annual Dragon Meet! KoreanJoey has donated to the forums! KoreanJoey helped get Play's clutch job done. KoreanJoey helped Azzy get to The Dragon in 2009. KoreanJoey helped bring Chaos back to the Dragon

    Join Date
    Dec 2004
    Location
    Gig Harbor, WA
    Posts
    7,496
    Images
    85

    Default

    Plug back in the AC switch? It's located on the one of the pipes on the right side.

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

    OR Call: 1-877-810-7067
    -Part of the Mod Team-
    Joey; Turning Ricers into Racers, one convert at a time.



    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
    Originally Posted by MCcelica
    Joey wins this thread.

  3. #3
    Lifetime Member shreddr69 is on a distinguished road
    shreddr69 has donated to the forums!

    Join Date
    May 2010
    Location
    north California
    Posts
    148

    Default

    I removed the pipes. They were in the way of what was going on in the engine compartment. Any other ideas? Can I short them out or use resistors to cancel the engine code?

  4. #4
    I'll be the little spoon KoreanJoey has a reputation beyond repute KoreanJoey has a reputation beyond repute KoreanJoey has a reputation beyond repute KoreanJoey has a reputation beyond repute KoreanJoey has a reputation beyond repute KoreanJoey has a reputation beyond repute KoreanJoey has a reputation beyond repute KoreanJoey has a reputation beyond repute KoreanJoey has a reputation beyond repute KoreanJoey has a reputation beyond repute KoreanJoey has a reputation beyond repute KoreanJoey's Avatar
    KoreanJoey has been to an annual Dragon Meet! KoreanJoey has donated to the forums! KoreanJoey helped get Play's clutch job done. KoreanJoey helped Azzy get to The Dragon in 2009. KoreanJoey helped bring Chaos back to the Dragon

    Join Date
    Dec 2004
    Location
    Gig Harbor, WA
    Posts
    7,496
    Images
    85

    Default

    Um... probably but you'll have to get a BGB to find the resistive value of the switch.

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

    OR Call: 1-877-810-7067
    -Part of the Mod Team-
    Joey; Turning Ricers into Racers, one convert at a time.



    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
    Originally Posted by MCcelica
    Joey wins this thread.

  5. #5

    Default

    Just jumper it and see what happens. I do this to charge a system.

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
    Originally Posted by Murgatroy
    I was deaf, sore and majorly pissed off

  6. #6

    Default

    Quote Originally Posted by KoreanJoey View Post
    Plug back in the AC switch? It's located on the one of the pipes on the right side.
    You should know better. The pressure switch has nothing to to with engine codes. And nothing to to with the IDLE circuit.


    Normally Code 51shouldn't come up. It's not a diagnostic code, shouldn't turn the MIL on, and should only show up when TE1 and E1 are connected and either the ECU isn't getting an IDL signal or the ECU is getting an AC on signal.

    If it turned on your MIL you may have a bad ECU.
    But I would check your ILD and AC signals first.
    With the key on and throttle closed you should have zero volts at the ECU [pin 13? in the middle connector, pink? wire].
    If you have 12V [or 5V, I can't remember which for that] make sure your throttle cable isn't pulling the throttle open at all [you should have a very small bit of play in the cable].
    If that's ok you may need to readjust your TPS, you may have a bad wire, or your TPS is bad.

    You should have zero volts at pin 20 on the largest? connector. Black/white wire. That's the AC on signal. 12V means the AC is on [or the ECU thinks it is], 0V means it's off.

    If both those check out most likely you have a bad ECU.

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

  7. #7
    Lifetime Member shreddr69 is on a distinguished road
    shreddr69 has donated to the forums!

    Join Date
    May 2010
    Location
    north California
    Posts
    148

    Default

    What is the MIL?

  8. #8

    Default

    Malfuction Indicator Light/Lamp.

    It's just a different name for the CEL, I'm used to using it from work.

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

  9. #9
    I'll be the little spoon KoreanJoey has a reputation beyond repute KoreanJoey has a reputation beyond repute KoreanJoey has a reputation beyond repute KoreanJoey has a reputation beyond repute KoreanJoey has a reputation beyond repute KoreanJoey has a reputation beyond repute KoreanJoey has a reputation beyond repute KoreanJoey has a reputation beyond repute KoreanJoey has a reputation beyond repute KoreanJoey has a reputation beyond repute KoreanJoey has a reputation beyond repute KoreanJoey's Avatar
    KoreanJoey has been to an annual Dragon Meet! KoreanJoey has donated to the forums! KoreanJoey helped get Play's clutch job done. KoreanJoey helped Azzy get to The Dragon in 2009. KoreanJoey helped bring Chaos back to the Dragon

    Join Date
    Dec 2004
    Location
    Gig Harbor, WA
    Posts
    7,496
    Images
    85

    Default

    Quote Originally Posted by alltracman78 View Post
    You should know better. The pressure switch has nothing to to with engine codes. And nothing to to with the IDLE circuit.
    *shrug*

    But I did not. But now I do.

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

    OR Call: 1-877-810-7067
    -Part of the Mod Team-
    Joey; Turning Ricers into Racers, one convert at a time.



    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
    Originally Posted by MCcelica
    Joey wins this thread.

  10. #10
    Lifetime Member shreddr69 is on a distinguished road
    shreddr69 has donated to the forums!

    Join Date
    May 2010
    Location
    north California
    Posts
    148

    Default

    Yeah it was the TPS. I replaced it and adjusted it and all is well thanks!!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Top Member List Chat Forum Search Contact Top