CelicaTech Main Page  CelicaTech Member List CelicaTech Image Gallery CelicaTech Data Garage Chatroom CelicaTech Forums Search CelicaTech Forums Contact CelicaTech
+ Reply to Thread
Results 1 to 16 of 16
  1. #1

    Unhappy Rear Window Demist

    Hi all, my first post here, I have a UK Celica ('98 reg) and have a problem with the rear screen demist. When I press the button next to the heater controlls I can hear a relay click but get no power to the contacts. I have put a multimeter across the contacts when the screen is on and off - reads 0v both times. I can feel (and hear) a relay clicking but cant seem to get it out of the 'tray' it is in. the relay I can feel is in the drivers footwell (right hand side as its a UK RHS car). I've checked as many fuses as I can find (drivers footwell, passenger footwell, under the bonnet) but can't fathom where to go next. Any clues please?

  2. #2

    Default

    The relays do come out, however, they are ALOT more fiddly than the fuses, since they dont generally go wrong (if at all) are you sure the connectors on the rear window are still intact and not burnt out/scratched?? Ill help how i can, but im by no means a guru

  3. #3
    Resident Japexican Ninjaneer
    bloodMoney is just really nice bloodMoney is just really nice bloodMoney is just really nice bloodMoney is just really nice bloodMoney is just really nice bloodMoney's Avatar
    bloodMoney has been to an annual Dragon Meet! bloodMoney has donated to the forums! bloodMoney helped bring Chaos back to the Dragon

    Join Date
    Nov 2007
    Location
    Chicagoland
    Posts
    1,159

    Default

    alltacNyx is working on this exact problem with my 96 GT.....
    -Shadow's Army- Ninjaneer/Resident 6g Killer-

    '88 Alltrac "Patty"
    '90 Alltrac "Ellie"
    '96 GT "Abby" ~ RIP 11/17/2013
    '96 GT 'vert "Lily" ~ RIP 08/22/2015
    '04 LS430 "Alice"
    '98 GS400


    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
    Originally Posted by Hookecho
    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
    I told him that he shouldn't be ashamed of being gay. He should be ashamed of stealing that ladies dick.

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

  4. #4

    Default

    Quote Originally Posted by rmpinky View Post
    The relays do come out, however, they are ALOT more fiddly than the fuses, since they dont generally go wrong (if at all) are you sure the connectors on the rear window are still intact and not burnt out/scratched?? Ill help how i can, but im by no means a guru
    I've connected my voltmeter to the actual wires which connect to the screen, as well as to the heavy metal contacts on the screen - 0v both times. I've checked all of the fuses that I can find (drivers footwell, passenger footwell (I think???) under the bonnet in 2 places (it was a while ago and I can't remember if there was one or two boxes). I can feel an object the size of a relay clicking in the drivers footwell area but cant seem to pull or gently lever it out. I don't want to force it in case it is fixed and I end up in even more trouble!

  5. #5

    Default

    Quote Originally Posted by bloodMoney View Post
    alltacNyx is working on this exact problem with my 96 GT.....
    Fingers crossed he finds a solution and the same works on my car! Please keep me posted!

  6. #6
    The Audio Sorcerer's Apprentice... alltracNyx is a splendid one to behold alltracNyx is a splendid one to behold alltracNyx is a splendid one to behold alltracNyx is a splendid one to behold alltracNyx is a splendid one to behold alltracNyx is a splendid one to behold alltracNyx is a splendid one to behold alltracNyx's Avatar
    alltracNyx has been to an annual Dragon Meet! alltracNyx helped bring Chaos back to the Dragon

    Join Date
    May 2010
    Location
    Chicago
    Posts
    1,004

    Default

    Quote Originally Posted by bloodMoney View Post
    alltacNyx is working on this exact problem with my 96 GT.....
    The problem is I haven't gotten around to fully checking this out since we live in different states BloodMoney's contacts are fine, but just the same, no voltage to the contacts. I have yet to have a chance to get to the relays.

    BTW fffil, not that it matters much, but I'm a girl
    ~alltracNyx
    - Shadow's Army - General's Technical Advisor -

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

  7. #7
    Resident Japexican Ninjaneer
    bloodMoney is just really nice bloodMoney is just really nice bloodMoney is just really nice bloodMoney is just really nice bloodMoney is just really nice bloodMoney's Avatar
    bloodMoney has been to an annual Dragon Meet! bloodMoney has donated to the forums! bloodMoney helped bring Chaos back to the Dragon

    Join Date
    Nov 2007
    Location
    Chicagoland
    Posts
    1,159

    Default

    lmao
    -Shadow's Army- Ninjaneer/Resident 6g Killer-

    '88 Alltrac "Patty"
    '90 Alltrac "Ellie"
    '96 GT "Abby" ~ RIP 11/17/2013
    '96 GT 'vert "Lily" ~ RIP 08/22/2015
    '04 LS430 "Alice"
    '98 GS400


    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
    Originally Posted by Hookecho
    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
    I told him that he shouldn't be ashamed of being gay. He should be ashamed of stealing that ladies dick.

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

  8. #8

    Default

    Ill have a look at my relays when i get home, have a look at how fiddly they are to get out. I know the fuses are a bitch on mine so relays most likely the same. Yeh theres two boxes under the bonnet, one long and one square like. I believe i accidently took a relay out once thinking it was a fuse, but no idea. Will check and get back to you in about 4-5 hours (at work)

  9. #9

    Talking Whoops!

    Quote Originally Posted by alltracNyx View Post
    BTW fffil, not that it matters much, but I'm a girl

    Oops! Hi Stacey!

  10. #10

    Default

    I checked my relays, they do come out albeit very stuborn. Might be worth checking?

  11. #11
    The Audio Sorcerer's Apprentice... alltracNyx is a splendid one to behold alltracNyx is a splendid one to behold alltracNyx is a splendid one to behold alltracNyx is a splendid one to behold alltracNyx is a splendid one to behold alltracNyx is a splendid one to behold alltracNyx is a splendid one to behold alltracNyx's Avatar
    alltracNyx has been to an annual Dragon Meet! alltracNyx helped bring Chaos back to the Dragon

    Join Date
    May 2010
    Location
    Chicago
    Posts
    1,004

    Default

    Hi!

    Definitely check the relays.
    ~alltracNyx
    - Shadow's Army - General's Technical Advisor -

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

  12. #12

    Default

    Quote Originally Posted by rmpinky View Post
    I checked my relays, they do come out albeit very stuborn. Might be worth checking?
    Any clues as to which is the rear window demist one? Any photos you can upload or link? I can feel one clicking but it seems to be in the most awful position to get to, kind of behind the fuse panel, around the back. Did the relay just pull out or did you have to lever it out?

  13. #13

    Default

    Quote Originally Posted by rmpinky View Post
    I checked my relays, they do come out albeit very stuborn. Might be worth checking?
    Any clues as to which is the rear window demist one? Any photos you can upload or link? I can feel one clicking but it seems to be in the most awful position to get to, kind of behind the fuse panel, around the back. Did the relay just pull out or did you have to lever it out?

  14. #14

    Default

    Quote Originally Posted by fffil View Post
    Any clues as to which is the rear window demist one? Any photos you can upload or link? I can feel one clicking but it seems to be in the most awful position to get to, kind of behind the fuse panel, around the back. Did the relay just pull out or did you have to lever it out?
    Ill see what i can muster up, find out and work out... I didn't "lever" them out per say, more wiggled back and forth whilst pulling up.

  15. #15

    Default

    Quote Originally Posted by fffil View Post
    Any clues as to which is the rear window demist one? Any photos you can upload or link? I can feel one clicking but it seems to be in the most awful position to get to, kind of behind the fuse panel, around the back. Did the relay just pull out or did you have to lever it out?
    Ill see what i can muster up, find out and work out... I didn't "lever" them out per say, more wiggled back and forth whilst pulling up.

  16. #16

    Default

    Sorry it's been a while, haven't managed to find out anything really... did check, and couldn't find out one that made it just stop working...
    Just thought i'd post and see if your still having the trouble?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Top Member List Chat Forum Search Contact Top