CelicaTech Main Page  CelicaTech Member List CelicaTech Image Gallery CelicaTech Data Garage Chatroom CelicaTech Forums Search CelicaTech Forums Contact CelicaTech
+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 25 of 26
  1. #1
    The Notorious P.I.G.
    Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho's Avatar
    Hookecho has been to an annual Dragon Meet! Hookecho has donated to the forums! Hookecho helped get Play's clutch job done. Hookecho helped bring Chaos back to the Dragon

    Join Date
    Jun 2006
    Location
    Rankin Co. Mississippi
    Posts
    4,904
    Images
    874

    Default Hitting 6 psi then sputtering occurs

    for those that don't know. i have a 2nd gen 3sgte with an electronic boost controller that i hooked up yesterday and tvsv is disabled. no other mods.

    Last night i let the car warm up and then left the house. i drove for 4 miles then tried to boost. when the engine hit 6psi it just started sputtering. i also noticed that the temp gauge was reading as though the coolant temp was really low. the needle was only half way to its normal position. i drove back home and noticed that the upper radiator hose was a bit swollen and had a small leak. i had noticed the hose swelling before and figured it was just weak.

    so this morning i replaced the hose and let the car idle for awhile before driving it. i then test drove the car and it still sputtered at 6psi. it will hit 6psi, sputter for a few seconds, boost up to 8psi, then drop back to 6psi and sputter.

    the temp gauge is still giving a low temp reading as well. as soon as i got home i dropped a thermometer in the radiator and got a reading of 192 degrees.

    i have gotten no engine codes before, during, or after this problem.

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


    "Pain and despair, damage and beatings, they don't end the world. The world ends when you're dead. You've got more punishment in store. Until then, stand it like a man and give some back".

  2. #2

    Default

    Check the sensors/wires on the front of the water neck. Also check the sensor at the bottom of the radiator near the AC.

    I know when the wires go sheared on one of the sensors on my water neck it had similar behavoir.

    -Terracar

  3. #3
    Junior Member karl has a spectacular aura about karl has a spectacular aura about karl has a spectacular aura about

    Join Date
    Jul 2008
    Location
    minneapolis
    Posts
    96

    Default

    boost leak test? a massive boost leak will only allow the turbo to hold low boost in the manifold but run so rich it will misfire.

    the temp gauge could just be the temp gauge sender. it uses a separate sensor from the ECU's temp sender.

    another possibility for the misfire would be a corroded ground on the igniter/coil bracket, or an igniter that's on its way out. the igniter gets ground through the bracket mount to the firewall. corrosion or a bad connection there severely limits coil current resulting in a weak spark. i ran a dedicated ground wire on mine.

    trying to think of stuff to check first that doesn't cost $$...

    edit: the car would hold boost fine before the boost controller install? or has this been happening before you added that?

  4. #4
    Ultimo Miembro Fantástico Gigantesco ChrisD has much to be proud of ChrisD has much to be proud of ChrisD has much to be proud of ChrisD has much to be proud of ChrisD has much to be proud of ChrisD has much to be proud of ChrisD has much to be proud of ChrisD has much to be proud of ChrisD has much to be proud of ChrisD has much to be proud of ChrisD's Avatar
    ChrisD has been to an official Ogopogo Meet! ChrisD has donated to the forums! ChrisD helped get Luni's MR2 back on the road! ChrisD helped bring Chaos back to the Dragon ChrisD helped KM replace his 5-year-old clutch.

    Join Date
    Nov 2004
    Location
    Calgary AB Canada
    Posts
    6,473
    Images
    913

    Default

    You're on new plugs? Using the 3s coil?
    1988 ST165 2.2L @ 370awhp
    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

    1994 ST205 WRC
    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

  5. #5

    Default

    This problem sounds almost familiar if by 'sputtering" you mean "jerky". When i first got my car everything worked great. One day at a light I took off, as soon as I hit boost the car jerked. If i pushed it it would make boost but still jerky. As long as I drove the car below boost it was fine. Purred like a kitten. I changed a ton of stuff but in the end it was the plug wires. Worked fine ever since (knock on wood)

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
    I play well with others....
    Others, Not you.

  6. #6

    Default

    Sounds like ignition related or a boost leak.
    2000 Absolute Red Celica GTS 6-Spd
    1991 Crimson Red MR2 Turbo


    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


    - Shadow's Army - Commander In Chief


    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
    Originally Posted by surfergravity
    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
    This thread is gayer than Richard Simmons singing a duet with Elton John in a bath house.

  7. #7
    The Notorious P.I.G.
    Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho's Avatar
    Hookecho has been to an annual Dragon Meet! Hookecho has donated to the forums! Hookecho helped get Play's clutch job done. Hookecho helped bring Chaos back to the Dragon

    Join Date
    Jun 2006
    Location
    Rankin Co. Mississippi
    Posts
    4,904
    Images
    874

    Default

    so i did a boost leak test just now. i pressurized the intake to only 10 psi and found a big ass leak. i had air blowing out the back of the ebc stepping motor. there is a little pinhole back there that i guess is part of a bleeder for a failsafe or something, idk. so i'm guessing the stepping motor is shit.

    the plugs are new. the cap and rotor are new. i also installed a new fuel filter.

    i rechecked the gap on my plugs earlier and they were pregapped at .035. i gapped them to .031.

    i am using the 3s coil.

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


    "Pain and despair, damage and beatings, they don't end the world. The world ends when you're dead. You've got more punishment in store. Until then, stand it like a man and give some back".

  8. #8
    Made It! burnyd is a glorious beacon of light burnyd is a glorious beacon of light burnyd is a glorious beacon of light burnyd is a glorious beacon of light burnyd is a glorious beacon of light burnyd's Avatar
    burnyd has been to an annual Dragon Meet! burnyd has donated to the forums!

    Join Date
    Mar 2005
    Location
    in bed with andy and Pittsburgh!
    Posts
    3,932

    Default

    if it is not a boost leak could be AFM related would put the car into limp mode and 6psi would be the absolute most it would allow you to boost... did you cap the tvsv on both ends?
    2012 Jeep Wrangler
    1993 Mr2 Turbo

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
    Originally Posted by vangls14
    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
    just because you want to be "different". Why not just take that mentality a couple steps forward and get yourself a Pontiac Aztek?

  9. #9

    Default

    Im with the others and think its ignition related. But it started after installing the ebc? Did you remove the ebc to test again?

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

    94 JDM ST205
    94 JDM SW20
    91 JDM ST185 RC

  10. #10
    The Notorious P.I.G.
    Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho's Avatar
    Hookecho has been to an annual Dragon Meet! Hookecho has donated to the forums! Hookecho helped get Play's clutch job done. Hookecho helped bring Chaos back to the Dragon

    Join Date
    Jun 2006
    Location
    Rankin Co. Mississippi
    Posts
    4,904
    Images
    874

    Default

    yeah, the tvsv is capped at both ends.

    i'm just going to put everything back to stock.

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


    "Pain and despair, damage and beatings, they don't end the world. The world ends when you're dead. You've got more punishment in store. Until then, stand it like a man and give some back".

  11. #11
    Made It! burnyd is a glorious beacon of light burnyd is a glorious beacon of light burnyd is a glorious beacon of light burnyd is a glorious beacon of light burnyd is a glorious beacon of light burnyd's Avatar
    burnyd has been to an annual Dragon Meet! burnyd has donated to the forums!

    Join Date
    Mar 2005
    Location
    in bed with andy and Pittsburgh!
    Posts
    3,932

    Default

    yah put everything back to stock boost see if it goes to the 8ish PSI level and see what happens..... I could swear I had this happen to me when I installed a boost controller wrong and did not cap the TVSV right.
    2012 Jeep Wrangler
    1993 Mr2 Turbo

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
    Originally Posted by vangls14
    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
    just because you want to be "different". Why not just take that mentality a couple steps forward and get yourself a Pontiac Aztek?

  12. #12
    The Notorious P.I.G.
    Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho's Avatar
    Hookecho has been to an annual Dragon Meet! Hookecho has donated to the forums! Hookecho helped get Play's clutch job done. Hookecho helped bring Chaos back to the Dragon

    Join Date
    Jun 2006
    Location
    Rankin Co. Mississippi
    Posts
    4,904
    Images
    874

    Default

    everything is back to stock and i pull 8-9psi no problem.

    the question i have is why was there air bleeding out of the EBC stepping motor? is supposed to do that being there is a hole back there? i know that it is hose #2 on the diagram that the air is bleeding through. i unhooked the hose from the turbo and blew through it. the air came out of the bleed hole on the back of the stepping motor. so that was my leak.

    this is the diagram i used to install the EBC.




    this is how my tvsv was capped off.

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


    "Pain and despair, damage and beatings, they don't end the world. The world ends when you're dead. You've got more punishment in store. Until then, stand it like a man and give some back".

  13. #13
    The Notorious P.I.G.
    Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho's Avatar
    Hookecho has been to an annual Dragon Meet! Hookecho has donated to the forums! Hookecho helped get Play's clutch job done. Hookecho helped bring Chaos back to the Dragon

    Join Date
    Jun 2006
    Location
    Rankin Co. Mississippi
    Posts
    4,904
    Images
    874

    Default

    I may have hooked the hoses up incorrectly on the EBC stepping motor. The diagram i used above is for a different model. I just assumed it the same one with an extra port.

    I found the correct manual and it shows port 2 connecting to the turbo(also the tvsv port but i'll just cap that off) and port 3 connecting to the wastegate. I had it the other way around as was shown by the above diagram. As soon as i fell like getting off of the couch i'll go hook it up again and see what happens.


    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


    "Pain and despair, damage and beatings, they don't end the world. The world ends when you're dead. You've got more punishment in store. Until then, stand it like a man and give some back".

  14. #14
    The Notorious P.I.G.
    Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho's Avatar
    Hookecho has been to an annual Dragon Meet! Hookecho has donated to the forums! Hookecho helped get Play's clutch job done. Hookecho helped bring Chaos back to the Dragon

    Join Date
    Jun 2006
    Location
    Rankin Co. Mississippi
    Posts
    4,904
    Images
    874

    Default

    it made no difference hooking the EBC up differently. i would get around 9psi before it starting sputtering and jerking. i put everything back to stock and it is still acting the same way. the ecu is not throwing any codes and on the way home from a test drive it wouldn't boost over 5psi.

    i guess i'll try a new set of plug wires.

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


    "Pain and despair, damage and beatings, they don't end the world. The world ends when you're dead. You've got more punishment in store. Until then, stand it like a man and give some back".

  15. #15

    Default

    Bruce, what plugs do you have? How many miles are on them?
    2000 Absolute Red Celica GTS 6-Spd
    1991 Crimson Red MR2 Turbo


    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


    - Shadow's Army - Commander In Chief


    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
    Originally Posted by surfergravity
    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
    This thread is gayer than Richard Simmons singing a duet with Elton John in a bath house.

  16. #16
    Made It! burnyd is a glorious beacon of light burnyd is a glorious beacon of light burnyd is a glorious beacon of light burnyd is a glorious beacon of light burnyd is a glorious beacon of light burnyd's Avatar
    burnyd has been to an annual Dragon Meet! burnyd has donated to the forums!

    Join Date
    Mar 2005
    Location
    in bed with andy and Pittsburgh!
    Posts
    3,932

    Default

    dude you are waaaaaayyy over simplifying things.

    http://www.twosrus.com/Articles/Inst...structions.PDF

    ^^ Just follow that exact instructions... if you brought it back to stock like I said to do before and you hit that 8-9psi then clearly you have something wrong with the setup.

    the tvsv simply needs to be capped at one end and the waste gate on the end that goes to the tvsv..... the side that goes from the wastegate - > turbo needs to have the boost controller on it.

    If you hook things up wrong you will go into a limp mode and the most the car will boost is 6psi with slight hesitation Ive had it happen before!
    2012 Jeep Wrangler
    1993 Mr2 Turbo

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
    Originally Posted by vangls14
    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
    just because you want to be "different". Why not just take that mentality a couple steps forward and get yourself a Pontiac Aztek?

  17. #17
    The Notorious P.I.G.
    Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho's Avatar
    Hookecho has been to an annual Dragon Meet! Hookecho has donated to the forums! Hookecho helped get Play's clutch job done. Hookecho helped bring Chaos back to the Dragon

    Join Date
    Jun 2006
    Location
    Rankin Co. Mississippi
    Posts
    4,904
    Images
    874

    Default

    I have some standard NGK's BKR6ES with about 100 miles on them.

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


    "Pain and despair, damage and beatings, they don't end the world. The world ends when you're dead. You've got more punishment in store. Until then, stand it like a man and give some back".

  18. #18
    The Notorious P.I.G.
    Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho's Avatar
    Hookecho has been to an annual Dragon Meet! Hookecho has donated to the forums! Hookecho helped get Play's clutch job done. Hookecho helped bring Chaos back to the Dragon

    Join Date
    Jun 2006
    Location
    Rankin Co. Mississippi
    Posts
    4,904
    Images
    874

    Default

    i hooked up the EBC exactly as it is supposed to and the tvsv was capped off at the wastegate and the line going to the tvsv.

    when i first hooked the controller up it was driving fine and hitting 13psi. i cut the car off and went for a ride a few hours later and began having problems. the thing that strikes me as being odd is the fact that i haven't even turned the boost controller on and the motor will boost to 13psi. it's supposed only boost to factory set psi when the controller is powered off.

    everything is back to stock now and the problem persists.

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


    "Pain and despair, damage and beatings, they don't end the world. The world ends when you're dead. You've got more punishment in store. Until then, stand it like a man and give some back".

  19. #19
    Rev Over 9000...Safely Now donteatbugs is a glorious beacon of light donteatbugs is a glorious beacon of light donteatbugs is a glorious beacon of light donteatbugs is a glorious beacon of light donteatbugs is a glorious beacon of light donteatbugs is a glorious beacon of light donteatbugs's Avatar
    donteatbugs has been to an annual Dragon Meet! donteatbugs has donated to the forums! donteatbugs helped get Grayscale's Celica towed from The Dragon in 2008. donteatbugs helped Azzy get to The Dragon in 2009. donteatbugs helped bring Chaos back to the Dragon

    Join Date
    Jul 2006
    Location
    monroeville alabama
    Posts
    2,572
    Images
    19

    Default

    i had a coil go bad that wouldnt let me boost past 4 psi once. everywhere else was fine though. btw. the 5s and 3s coils are the same core part number with a different mounting bracket if you wanna try that.

    btw- if the boost controller is broken ill refund your money, i had no way of testing it before i sold it.

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


    Shadow's Minion Army - member #3

  20. #20
    Rev Over 9000...Safely Now donteatbugs is a glorious beacon of light donteatbugs is a glorious beacon of light donteatbugs is a glorious beacon of light donteatbugs is a glorious beacon of light donteatbugs is a glorious beacon of light donteatbugs is a glorious beacon of light donteatbugs's Avatar
    donteatbugs has been to an annual Dragon Meet! donteatbugs has donated to the forums! donteatbugs helped get Grayscale's Celica towed from The Dragon in 2008. donteatbugs helped Azzy get to The Dragon in 2009. donteatbugs helped bring Chaos back to the Dragon

    Join Date
    Jul 2006
    Location
    monroeville alabama
    Posts
    2,572
    Images
    19

    Default

    awesome double post

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


    Shadow's Minion Army - member #3

  21. #21
    The Notorious P.I.G.
    Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho's Avatar
    Hookecho has been to an annual Dragon Meet! Hookecho has donated to the forums! Hookecho helped get Play's clutch job done. Hookecho helped bring Chaos back to the Dragon

    Join Date
    Jun 2006
    Location
    Rankin Co. Mississippi
    Posts
    4,904
    Images
    874

    Default

    the 5s coil i have is different than the 3s. the coil to distributor plug wire for the 3s has a much larger terminal.

    for right now i'm going to run without the EBC and see how it acts. i drove it earlier and it seemed fine. it was boosting at 9psi. the only problem i am having is after i drive for about 20 minutes the timing starts to retard and i'm only boosting at 5psi. i'm guessing it's heatsoak from the tmic. i insulated the bottom of the tmic and am about to go for a 30 minute drive to get a good idea of what's happening. it's getting dark so i'm hoping the cooler temp outside will prove that theory right.

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


    "Pain and despair, damage and beatings, they don't end the world. The world ends when you're dead. You've got more punishment in store. Until then, stand it like a man and give some back".

  22. #22
    The Notorious P.I.G.
    Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho's Avatar
    Hookecho has been to an annual Dragon Meet! Hookecho has donated to the forums! Hookecho helped get Play's clutch job done. Hookecho helped bring Chaos back to the Dragon

    Join Date
    Jun 2006
    Location
    Rankin Co. Mississippi
    Posts
    4,904
    Images
    874

    Default

    i drove the car for 1 hour. mainly on the highways. it drove pretty good and i was boosting at 9psi. the only problem i had was when i would take it up to 4500rpm the ecu would pull timing and restrict the motor to 5psi. after i waited about 1 minute i was able to boost at 9psi again.

    so i'm guessing the problem is heatsoak or ignition. i guess i'll buy some plug wires and colder plugs and try that. i need to ditch the top mount too.

    sometime in the next few days i'll wire up my led's for the knock detection.

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


    "Pain and despair, damage and beatings, they don't end the world. The world ends when you're dead. You've got more punishment in store. Until then, stand it like a man and give some back".

  23. #23
    The Notorious P.I.G.
    Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho has too many green lights. Hookecho's Avatar
    Hookecho has been to an annual Dragon Meet! Hookecho has donated to the forums! Hookecho helped get Play's clutch job done. Hookecho helped bring Chaos back to the Dragon

    Join Date
    Jun 2006
    Location
    Rankin Co. Mississippi
    Posts
    4,904
    Images
    874

    Default

    if the ecu gets a knock signal will it throw a code?

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


    "Pain and despair, damage and beatings, they don't end the world. The world ends when you're dead. You've got more punishment in store. Until then, stand it like a man and give some back".

  24. #24
    Mustang Crew Grot has much to be proud of Grot has much to be proud of Grot has much to be proud of Grot has much to be proud of Grot has much to be proud of Grot has much to be proud of Grot has much to be proud of Grot has much to be proud of
    Grot has been to an annual Dragon Meet! Grot has donated to the forums! Grot helped Azzy get to The Dragon in 2009. Grot helped bring Chaos back to the Dragon

    Join Date
    Oct 2008
    Location
    Under There
    Posts
    2,643

    Default

    I do not believe so. I think it just retards timing to get the knock to go away

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
    Originally Posted by Murgatroy
    And I had a mullet to prove it.

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
    Originally Posted by BabyBear
    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
    Ive decided youre gay.

    Good day.

  25. #25

    Default

    No code if knock is detected. Knock/knock response is only evident if you install a TVSV LED.
    2000 Absolute Red Celica GTS 6-Spd
    1991 Crimson Red MR2 Turbo


    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


    - Shadow's Army - Commander In Chief


    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
    Originally Posted by surfergravity
    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
    This thread is gayer than Richard Simmons singing a duet with Elton John in a bath house.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Top Member List Chat Forum Search Contact Top