CelicaTech Main Page  CelicaTech Member List CelicaTech Image Gallery CelicaTech Data Garage Chatroom CelicaTech Forums Search CelicaTech Forums Contact CelicaTech
+ Reply to Thread
Results 1 to 5 of 5

Thread: mount came lose

  1. #1

    Default mount came lose

    so having all kinds of problems with my 93 gts most of them are my own falt the bigest one to got to light is the passinger engin mount is no longer atached to the engin so its leaning and due to this the passinger cv jion blow

    so my question is whats the best way to reatach the mount with out removing the engin?
    i would post a pic but i am having trubble figgering out how

  2. #2
    Ultimo Miembro Fantástico Gigantesco Galcobar is a splendid one to behold Galcobar is a splendid one to behold Galcobar is a splendid one to behold Galcobar is a splendid one to behold Galcobar is a splendid one to behold Galcobar is a splendid one to behold Galcobar is a splendid one to behold Galcobar is a splendid one to behold Galcobar's Avatar

    Join Date
    Dec 2004
    Location
    Richmond, B.C.
    Posts
    3,483
    Images
    52

    Default

    Photo: host either on an outside website such as photobucket.com, or load it onto Celicatech's gallery and link from there.

    To do anything with the engine mount, you'll have to get the engine at least a little elevated. Easiest, though possibly least convenient for working in the bay, would be to use a jack under the oil pan (with a block of wood or rubber in between, of course). That would take the tension off of the mount...

    But how is it detached? The bolt attaching the mount and the bracket come loose, did the bracket itself break, did the welds holding the bracket to the engine break?
    Men call cars "she" because it gives them at least one female they can claim to understand
    --------------------------
    Mazda Velocity Red paint; Eibach Pro-Kit; KYB GR-2; rear disc brake conversion; Suspension Techniques rear anti-sway bar; sixth-gen suspension arm conversion; Bosch E-code H4 housings

  3. #3

    Default

    im hopping that the hardware just came lose and its nuthing more wich would be the simplest to fix and i will try and put up the photo

  4. #4

    Default

    There are 2 studs that come out the bottom of that mount that go into holes in the mount bracket on the passenger side. There are 2 nuts that thread on from the bottom that hold them. And then theres one main bolt that goes through the middle of the mount to the body.

    Where did it detach? From the bottom or from the body? Most likely youll just need to jack the engine up to the correct elevation and replace the bolt/nuts. Unless theyre stripped. Then you need a new mount.
    2000 Absolute Red Celica GTS 6-Spd
    1991 Crimson Red MR2 Turbo


    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


    - Shadow's Army - Commander In Chief


    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
    Originally Posted by surfergravity
    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
    This thread is gayer than Richard Simmons singing a duet with Elton John in a bath house.

  5. #5

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Top Member List Chat Forum Search Contact Top