View Full Version : 3rd gen swapped st165 problem

06-30-2015, 03:36 AM
Wats up guys, havent posted in a looong time since the celi's been running like a dream. But now shes pissed, like, for real :( so ill get right to it. Btw this all started at around 6pm after replacing my electric mirror switch.
Check engine is on but no codes
Wont start and cranks fast, unless i give alot of throttle
Takes a lot of cranks to start also
Once it runs it idles decent but not quite right
Giving it a little throttle stalls it
Giving it alot of throttle stays on but struggles to climb 3500rpm
Will not rev higher than 3500rpm

Like i said shes been running perfect for the past couple of years with pretty much zero issues, till now.
I feel bad asking for help, feeling like a noob after 12 years of owning/building/restoring sucks! Maybe its because i havent drawn any blood for her in the past 5 years. Maybe i spoiled her or maybe she spoiled me.
But maybe, just maybe, the 3sgte gods will shine down and help me set her straight.

07-02-2015, 04:01 AM
My first guess is maybe the timing belt slipped a tooth?

Just a guess. I would run a compression check and look at the plug condition.

07-02-2015, 06:59 AM
That was one of my first guesses also, luckily its fine.
So anyway, i decided to put some time on her last night and guess what? She started up and ran fine. Boosted good, no check engine, nothing! Once it got up to operating temp it stalled, same behaviour as the night before. But this time code 14 popped up. So its the ignitor, the coil, the wiring or the ecu. I doubt its the wiring, it was done by tweak but ill stil check it i guess. I hope its not the ecu though:(

07-04-2015, 03:15 AM
Ok update time...
Its not the ignitor so at least its been ruled out, also its worth pointing out thAt the ignitor absolutely must be grounded to function. Any doubts about this can be put to rest. I should also mention that when i replaced the electric mirror switch the problems started and now even it wont work. I doubt this caused the problem but if you guys know something about this please let me know. Anyway back to the problem, code 14 is gone but the cel light is still there and not giving me any codes...wtf??? A foul unknown odour was also present for a short period after attempting a test drive. Through the pAst week of research i came across an old post by CJMR2T on mr2.com pretty much describing my symptoms, turned out his problem was his ecu...exactly what i didnt want. Is there anyway to get these tested? Seriously broskies...can anyone chime in??

07-05-2015, 05:20 AM
Ok so final update...it is the ecu...was able to find another 3rd gen swapped 165 that is local to me. Put my ecu in, waited till temps got up and voila!!!same problem. So i need a new ecu. At least i know but still :(

07-08-2015, 08:59 PM
I was going to say sounds exactly like the ECU.

Sorry I didnt chime in before you fixed it yourself.

Guys, these things are, and have been dropping like flies lately. Anytime you see some odd symptom that looks like this, check your ECUs.

JetBlack what did you do with your old ECU? Id consider trying my hand at repairing it. Its just a capacitor that died. If you want to send it to me. Im not saying Ill do it tomorrow, but I WOULD like to try my hand at replacing all the caps on an ECU. I have a Gen3 swapped MR2, so a 205 ECU would start my car and run it, but Id pull the IC CEL.

07-10-2015, 04:02 AM
Im currently using it as an ashtray(not really lol). Still have to find an ecu a a reasonable price, ebay sellers are out of their minds so a 2 hour drive to the Montreal jdm shops seems to be the solution unless i find one locally.

07-12-2015, 02:24 AM
Opened up the ecu, small 10 micron 50 volt cap was blown. Brought it to a friend who does this for a living along with my old 165 ecu. Gonna swap a cap from the 165 ecu, 15$, done! Problem solved