View Full Version : Bad throttle position sensor?

01-21-2015, 01:38 AM
Ok, my day started out sucking ass.

Coming up on the interstate on ramp this morning with a jackass riding my ass. Get to the top and getting ready to merge and all of a sudden I loose power. Press on the accelerate more, nothing. The engine was still running, still had power steering and brakes. Just no power and no response from pressing the accelerator.

I managed to get off the ramp and come to a stop on the berm. The engine then quit. I can restart it. It will run for 30 or 40 seconds and then quit. This morning when it restarted it did not respond to the throttle what so ever. I got it towed home and it's in the driveway now. Same thing, it starts rights up and idles of for 30 seconds or so and then stalls. It did respond some to the throttle here at home but not much and was kind of rough.

I had no noises at all and this morning when it did what ever it did, the engine was still running smooth.

My first thought was something to do with the throttle position sensor since I had no throttle response. Not really sure though.

So what do you guys think?

01-21-2015, 02:29 AM
Sounds more like a major vac leak to me.

01-21-2015, 02:35 AM
Sounds more like a major vac leak to me.

Same thing happened to me when one of my intake couplers had a crack (big one) in it.
Those things are not cheap from Toyota either. $68 for the accordion elbow pre-turbo. :(

01-21-2015, 03:23 AM
Thanks guys. I'll take a look at the intake path. I think the elbows are OK. I bought them from Jeremy a while back and they looked good with I put them on and they were still pretty supple. I could have something going on with the pipe I put in the intake path in place of the airflow meter when I did the 3rd gen conversion. Could be something going on with the connections on either end or with the grommet I put in for the intake temp sensor.

It was just weird how it happened. Fine one second, the next engine running put the accelerator does nothing.

Always a freaking adventure.:bananachair:

01-21-2015, 03:58 PM
Best of luck Mike *fingers crossed*

01-22-2015, 10:02 PM
If you ever suspect your TPS of not working, unplug the fucker. Your engine will run fine without it. You just wont get your performance and mileage.

But you can run all day without one.

01-23-2015, 01:30 AM
Thank Rob. I didn't know that. I'll give that a try too.

01-24-2015, 09:22 PM
Weather is kind of crappy here today so I couldn't do a whole lot.

I did find out that it isn't anything under the hood. It's in the wiring going to the ECU. I didn't really think about it when it happened Tuesday but I had worked on getting the wiring back under the carpet and the console. After I moved it the car started and idled fine.

While I was piddling with the car a few minutes ago, reached down and jiggled the wiring a little. Car fired right up and ran fine. I didn't take it out but it sat there and idled fine. Just as an experiment, I reached down and jiggled the wiring and it stalled. Right back to the same thing, starts and idles for about 30 seconds or less and then quits.

So, the first decent weather day I get I'm going to have to go back under the dash and mess with the wiring again. Something is obviously a little loose. I'm starting to think that I need to pull the Berk adapter harness out and just repin all of my plugs. If I hadn't repinned it earlier to run the 90-91 JDM ECU, it wouldn't be really involved from looking at the wiring diagrams. Going from the 90-91 to the 205 pattern is more involved. I may still do it depending on how much trouble it is getting the damn thing sorted and working consistently.

01-25-2015, 07:18 PM
Went through and made sure pins going into the Berk harness and then into the ECU were all firmly set. I then got the harness shoved back under the carpet so it should move much if any now.

So, for the time being everything seems OK. I've started it and let it idle, which it wouldn't do before. I still need to take it for a test drive but right now it looks like everything is good.

01-25-2015, 08:38 PM
Ive never had a problem with any Berk harness Ive used. Ive done it about 4 times with good success. Glad you got it sorted. For now at least.

01-26-2015, 01:26 AM
It's the only thing I can think of. I know that Berk makes good parts. I've got their downpipe and that thing is a work of art. It could be something in the Toyota harness that has worked loose and have nothing to do with the Berk harness. The Berk harness does make this conversion much easier than moving pins in the OEM plugs.

Once spring gets here I think I'm going to pull everything out and go through and make sure all of the connectors are tight in the OEM harness plugs. Like I said, I had moved some pins around when I put the 90-91 JDM ECU in and I also noticed at that time that a previous owner had been into the harness before as well. Given the age of the car, it is probably something in the Toyota harness. I think I've jarred it loose with putting the Berk harness in the car. Don't anyone think that I'm condemning the Berk harness. It looks like it is a well made piece. And if you're doing a 90-91 to 3rd gen conversion, this is the easiest way to go.

02-04-2015, 03:33 AM
Mine actually just did the exact same thing. Turns out it was running lean and I had to replace one of the O2 sensors. The best thing to do is take it to Auto Zone or any parts store so they can run a free check on it...as long as your check engine light is on anyways. If the person is knowledgeable,they can tell you exactly what the problem is. I'm sure you already got it fixed,but just for future reference.

02-04-2015, 05:59 AM
We don't need to go to Autozone to pull codes, besides they only typically have OBDII Scanners there anyhow, which will not work for our cars.

All we need is a paperclip to jumper the diagnostic ports and read the code on the instrument panel.

02-04-2015, 06:04 AM
Well,I've got an 04 Celica GT TRD so that's why I suggested that.

02-04-2015, 06:05 AM
Wish all I needed was a paperclip,lol

02-04-2015, 06:24 AM
Ah yeah you are running OBDII. :) No worries, I was just explaining that for our older Celicas, that option won't work.

02-04-2015, 06:38 AM
Yeah,I didn't realize that y'all were running older one's. I just installed this app today,but I always enjoy talking to new people and getting/giving any advice I can. I'm not any help on the older ones as you've seen,lol.

03-03-2015, 09:42 PM
Quick update. Finally had time and the damn snow and ice melted enough that I could get the car out.

Ran it probably 10 miles and over rough patches as much as possible. No issues. I think I've got this particular problem fixed. Going to drive it to work tomorrow and see how that does. Hopefully know walks back home in the cold, rain and snow to get the truck!

03-03-2015, 11:39 PM
Thanks for the update Mike.