PDA

View Full Version : Rear Brakes



grimmythereaper
10-31-2014, 03:16 PM
so i changed the rear pads on my 94 GT and they still make noise when i hit the brakes. the pads arnt glazzed over, im a little lost. does the 6th gen use pads for the e brake? and if so does it act like a drum brake while braking?

bloodMoney
10-31-2014, 03:24 PM
Yes. There are parking brake shoes inside of the rotor hats in the rear. I would start checking there and see if you have rust rolling around in there.

Its a common issue if the shoes haven't been changed for a while. Just pull the rotor off, clean with some brake cleaner and air. Did you get the rotors machined? They usually do both surfaces.

grimmythereaper
10-31-2014, 04:04 PM
i didnt really have the time to get them machined, i havent had a day off in about 2 weeks. you think the rotor may be warped?

bloodMoney
10-31-2014, 04:22 PM
Probably. Its best to have two true, fresh mating surfaces for brakes so that the pads and rotors will bed in correctly. Right now, your fresh rotors are bedding into your worn rotors and any warpage in the rotors can cause annoyances like noise or a pulse in the pedal. Neither of which are unsafe, just annoying.

VavAlephVav
11-04-2014, 01:24 AM
especially cheap rotors, they tend to be warped right out of the box. another thing, that I'm also dealing with, is I have a strut mount on the rear blown out and that is causing some uneven forces to make brake noise as well.

grimmythereaper
11-04-2014, 04:02 PM
i noticed yesterday that if i brake softly it makes noice from the driverside rear, but if i press harder then the noice doesnt seem to happen. im finilly off today so i take a look, im hopeing for the best :)

Nitro_Alltrac
11-04-2014, 09:24 PM
What kind of pads did you use Grimmy?

grimmythereaper
11-04-2014, 09:59 PM
What kind of pads did you use Grimmy?

i used the Wearever Silver Organic Brake Pads from advanced auto parts.

the shoes look very worn but are not bare metal yet, and the rotor has a "hump" on the back side that goes in the shape of a circle around it almost as if it was machined at one point and the machine missed it, so ill be replacing the shoes and the rotor tomorrow :)

Murgatroy
11-04-2014, 10:18 PM
That is called a ridge, and it is from wear. The shoes need replaced and the rotor/drum needs turned.

grimmythereaper
11-07-2014, 08:45 PM
do i have to adjust anything besides the adjuster that sits at the bottom between the shoes? the top part of the shoe that has the ebrake attached to it is catching the rotor and holding it very tightly

Murgatroy
11-07-2014, 09:05 PM
You may want to adjust the cable down and see if that frees you up, the cable is adjusted from the lever, between the seats.

93celicaconv
11-28-2014, 03:52 PM
If you have new pads on old, unmachined rotors, then the wear patterns on the old rotors are affecting the fresh pads that could likely be causing your noise. If you don't get the old rotors trued up soon, or new rotors, your new pads will become old pads (from a wear pattern perspective) quickly. A general rule in brake repair is to never put new pads on old, unmachined surfaces. Depending on the quality level of the pads you installed, it is possible the shims are not adhering to the piston (rear) and clamps (front) portion of the caliper, so the pads are vibrating relative to the caliper causing this noise. You would need a compound to apply to the back of the pad shims, or get higher quality pads, to eliminate this source of brake noise.

And yes, it is possible your parking brake linings inside the drum hat portion of the rotor were the noise makers to start with, so the new pads did not address the noise issue.

grimmythereaper
12-16-2014, 06:48 AM
srry i forgot about this thread, yeah the new shoes and rotor fixed the problem :) thanx everyone