PDA

View Full Version : 91 AllTrac, power drain issue, would like some new eyes on it.



Shadowlife25
09-18-2014, 07:34 AM
My 91 AllTrac has 183k miles on it. All original everything minus the clutch.

Had an issue some months back some of you may remember where the shop I brought it to to replace a busted hose behind the engine block area mis-connected the jumper cables on their box and blew every fuse in the car including the 100A ALT fuse.

Fast forward to now, I have again replaced the battery and as of 2 weeks ago also installed a Moroso battery cut off.

I hooked up my test light and started pulling fuses to track down the power drain issue.
I have gotten as far as determining with certainty that the main circuit exhibiting the fault is in the J1 under hood (2E) block 20A DOME circuit.
I tested all of the door and trunk switches, the sunroof and interior courtesy and map lights. All are in good working order.
I pulled out all of the fuses in the J2 driver kick panel area and there was no change, drain remained the same.
I am going cross eyed looking at schematics in the BGB and am kind of at a loss as to how to proceed at present.

If anyone can lend some advice to help me work through this in an orderly fashion, I would really appreciate it.

- Mario

Nitro_Alltrac
09-18-2014, 01:35 PM
This is probably a stupid question but I'm trying to make sure I understand your findings so far Mario.

If you pull the 20A Dome fuse, no power drain?

Shadowlife25
09-18-2014, 11:17 PM
Indeed Mike. The issue lies in that once you pull that fuse, a myriad of things also no longer function such as the interior lights, instrumentation illumination and I'm not sure yet just what else.
I do know that even if the car runs, it is not in any way driveable at night, so kind of a deal killer. I only installed the cut off because it was the least intrusive way to achieve the same effect and takes less time than pulling the fuse.
The Moroso unit simply clamps on to the negative on the battery and you put your NEG clamp onto it. There is then a small knob in the center with a plastic isolator. Turn the knob counter clockwise a turn or two and no more continuity.
it works and it was $25 so I can't bitch. Beats replacing the battery every couple months.

alltracman78
09-22-2014, 09:23 PM
This is too complex for me to sit and help you with, but I'll at least try to point you in the right direction.

There's a power source chart in the front of the wiring manual. It lists everything each fuse controls. You'll have to go through and disconnect each one.
My first guess for the dome fuse is the integration relay. But you can't really disconnect it; it controls loads of things. So you'll have to rule out everything else and get to it by the process of elimination.

Shadowlife25
09-22-2014, 10:55 PM
Right on Jeremy, Thank You.
I narrowed it down to the DOME fuse in the engine bay. I did systematically pull all other fuses and it just seems to lead from the DOME circuit (Being the root).
Now I am still trying to find the branch that is responsible for the drain. It could be the integration relay as you say, but I really do have to eliminate things one by one. Just incredibly time consuming.
Also, difficult to be in awkward positions to test it all. :D LOL

I will get out to my storage unit and find my EWD so that I can see the fuse schematic you are referring to.
Thank you as always!