View Full Version : Going to work on the 2nd gen to 3rd gen electronics conversion tomorrow.

08-15-2014, 02:26 AM
I've been gathering parts for over a year now and I'm ready to start the process. I've been following Luni's write up over at MR2OC about how to go about this.


There is a lot of go information about what you need and how to go about doing this in his thread along with another thread that is linked to his. It doesn't appear to be that difficult with Berk conversion harness that out there due to Luni's work.

I've got that and a 205 ECU that I got from lalojamesliz. He also hooked me up with the cold start injector plate that allows for the MAT to be installed in place of the CSI. I picked up the injectors from spitfiremk16. Thanks to the great Pic n Pulls in San Antonio I got the igniter, the AFM plug, the IAT. I've made the harnesses for the MAT and IAT and they're ready to go. I've made an adapter harness to adjust the voltages so I can use the gen2 map sensor for now. Here's a link to a thread at MR2OC on how to do this for either a GM 2bar MAP sensor or to adapt the existing 2nd gen.


I know that this isn't ideal but I don't want to put out $120-150 bucks for a 3rd gen right now. I've been looking trying to find a decent deal on one in Europe but so far no luck. Based on that thread and few other things I've find this should work for now.

So, the weather is supposed to be good tomorrow. I've got the day off and I'm going to start tomorrow morning. I'm going to try to take pictures as I go and post my experiences up. Changing the injectors is supposed to be about the worst part.

Wish me luck.

08-15-2014, 07:16 AM
Best of luck man! :)

08-15-2014, 12:28 PM
Thanks Mario. I'm probably going to need it.

08-15-2014, 10:35 PM
Made progress today. I finished what little wiring I had left. I got the 540 injectors ready to install and then worked on getting the 2nd gen fuel rail and injectors out. This took about 3.5 hours. Finally got it out. It was a pain in the ass. Also got the cold start injector out. I cleaned up the fuel rail and took out the old injectors. This was where I ran into trouble. Somebody had been in there before (I could tell before this as some of the OEM clamps had been replaced with worm clamps). Some how they had cracked the bottom of one of the injector holders (could have been a manufacturing defect I guess, but anyway, when I pulled the insulator off to put the new one on there was a chunk of aluminum was gone. I double checked to make sure that I didn't mess it up but there were no pieces laying around so it's been like that for a good while.

So, now I'm dead in the water till I find a new fuel rail. Anybody got a 2nd gen fuel rail they want to get rid of?

08-15-2014, 10:38 PM
I'm pretty sure that someone here has one they could send you. If I did I would send it, but all I have is the one that runs the car. :D

08-15-2014, 11:12 PM
No problem Mario. That's not something that you're normally going to have laying around.

08-15-2014, 11:27 PM
im in the same boat as shadowlife on this one nitro, wish i could help

08-15-2014, 11:28 PM
oh wait will a 5sfe fuel rail work? if so i can hit up the pull a part for you tomrrow?

08-16-2014, 01:12 AM
Thanks Grimmy but I think that the 5S is different. I think read that it is a top feed rail while the 3S is a side feed. I just checked a dealer parts site and it is showing a different rail for the 3S.

I really appreciate it though.

08-16-2014, 03:41 PM
Thanks Grimmy but I think that the 5S is different. I think read that it is a top feed rail while the 3S is a side feed. I just checked a dealer parts site and it is showing a different rail for the 3S.

I really appreciate it though.

no problem :)

08-18-2014, 03:56 PM
I've got a rail if you want it.

08-18-2014, 11:03 PM
Thanks man! I've got a line on a couple right now. If they fall through I'll get back with you.

08-19-2014, 01:37 AM
OK, an update on something other than the fuel rail fiasco.

In billion percent humidity (I love WV in the summer time) and between rain showers, I actually got a little bit done this evening. I swapped out the igniter. I used a 5S unit with the 175 on top. It is more or less a straight swap. It does require just a little modification for the stock plug to fit. Looking at the connector on the igniter, on the left side there is a hump (for lack of a better term) that is too big to allow the harness connector to slide all the way into place. It's about twice the size of the one on the right side Take a pocket knife, Xacto, Dremel or what ever and remove this hump. (I've got extra igniters so I'll try to get a picture illustrating this hump.) It's pretty easy to get off. Once that is done, the plug goes straight on. From here, straight bolt on to the bracket on the firewall.

I got the MAT installed in the place of the cold start injector. I used the adapter plate that I had gotten from lalojamesliz. Worked great. The plate is a straight bolt in. I did have to retap the sensor hole. I used the GM sensor with has a 3/8-18 NPT nut. I'm guessing that the adapter plate was originally tapped for a Toyota MAT. The threads were off enough that the GM sensor wouldn't go in.

I also go the harness run to the sensor and got it hooked up. I pulled the AFM out and have my MAT/IAT adapter harness hooked up. I have to get something to hook my intake hoses back together. (I have the battery mounted in the stock location so no straight intake.) Once I get the adapter piece in place I'll install the IAT. This will also give me a place to install a barb and recycle my blow off valve.

Next step after this, when I'm not swimming outside, will be to install the 205 ECU. I've got the Berk harness so this should be plug and play. The only thing I'm concerned about since this is a 205 ECU, am I going to get the Code 54 for the intercooler water level/intercooler pump? There shouldn't be anything in the harness to feed into that pin on the ECU. I looked at the pinouts and that part should be OK. I wondering though that if even nothing is hooked to that pin, will the ECU through the code? On the 205 swaps that don't use the WTA but have the 205 harness, the easy way around this is to jump the two pins. Since I'm on the 185 harness there is nothing to modify. All of the 3rd gen electronics conversions that I've found detail info on so far have used the MR2 ECU, so this is not a problem. Anybody have any idea if this is going to be a problem and if so, any ideas on how to get around it? I have the 205 WTA intercooler but I really don't want to have to figure out how to wire that float in or figure out how to wire the pump so that the ECU sees it.

More updates to follow.

08-19-2014, 07:58 PM
I think youll pull the IC code on the 205 ECU.

As for the igniter, yeah, I just shaved the connector on the igniter itself and the plug slides on. I used a dremmel with a sanding barrel disk on it.

08-19-2014, 09:35 PM
So Luni you think I need to find some way to jump that pin on the ECU or something?

I know this isn't something you had to do since you used a MR2 ECU. I guess I'll see when I get it all hooked up.

08-19-2014, 09:51 PM
Youre going to likely have to build the resistor array to satisfy the ECU on the "circuit"

Theres been talk about it before.

I mean, Id run it and see what happens, but dont be surprised if you pull a CEL and that is what youre pulling a CEL for.

08-20-2014, 12:51 AM
Other than the possible code 54, do you think I'm going to have problems using the Berk harness on the 205 ECU? I found one post on MR2OC from the east coast sales rep for ATS, Scremin I think it was, about the pin outs. The ones he was showing for the Gen 3 SW20 and the 205 were the same. If that was the case, I'm good. But I don't think that the MR2 pins are the same as the 205. There's a 3SGTE pin diagram showing pretty much all of them in the Useful Information section here and that shows two different pin outs.

I'm thinking now that I'm probably going to have to pin the Berk harness.

08-20-2014, 02:11 AM
Hate to say it but you wasted your money on the Berk harness IMO; there's literally like 5 wires that need to be swapped around for you to run the 205 ECU on your car.
Open the connector, unlock the wiring pin, pull out the wire and push in new location.

You will get a code 54 with the 205 ECU and unfortunately you can't just jump 2 wires. Even if you had the 205 harness you can't just jump wires, you need resistance.
I have the schematic that works [there's a couple different ones out there and I don't think they all work]. I will TRY to post it up, it's so hard for me to get time to go online....
It's pretty simple.

08-20-2014, 11:11 AM
Thanks Jeremy. If you get time to post that I would really appreciate it.

08-21-2014, 01:42 AM
Ok, I don't have time tonite to explain stuff, but I'm sure someone can figure these out. I'll TRY to come back and explain.

First is my wiring pinouts for the harness. In case you want to ditch the Berk jumper. I have no clue why it's rotated, that's not the way it is in the album.
It's for a 94 JDM 205 into a US 93 [same as your 92].
http://i1198.photobucket.com/albums/aa460/alltracman78/20140820_195748_zpsb32699bf.jpg (http://s1198.photobucket.com/user/alltracman78/media/20140820_195748_zpsb32699bf.jpg.html)

And this is how to bypass code 54. I wired a relay in too, not sure if it's required, haven't had time to mess with it.
I also don't know how close to 1k you need to resistors to be. I doubt it has to be super accurate.
http://i1198.photobucket.com/albums/aa460/alltracman78/20140820_195837_zpsf6d6a1f5.jpg (http://s1198.photobucket.com/user/alltracman78/media/20140820_195837_zpsf6d6a1f5.jpg.html)

08-21-2014, 02:21 AM
Thanks Jeremy. After you mentioned repining the plug I pulled up the pin outs for both ECU's and I see what you mean. I think I'm going to go that route now as I'll have to repin the Berk harness since it's for the MR2 ECU. It will be just as easy to repin my plugs.

Thanks a lot for posting the fix for the code 54. I wasn't even sure where to start with that. I appreciate you taking the time to post these pictures up.

08-22-2014, 01:25 AM
OK, I've been going through some more documentation I've found and I think I've found way around the code 54 for the intercooler water level sensor.

The common fix give for the water level sensor error for a car with the 205 harness but using a FMIC is to jump the two pins in the water level sensor plug. But in my case since I'm on the 185 harness there's no plug. There's my conundrum. So, looking in the Celicatech BGB section, there is a 3SGTE supplement repair manual for the 94 model. It gives the test procedure at the ECU for this sensor and the state at the plug depending on if the float is up or down. If the float is up, it should have continuity. If it's down, no continuity. I also found the wiring diagram that shows the wiring from the water level sensor to the ECU. It's a simple circuit, one wire goes to the LEV pin on the ECU and the other side goes to a body ground. Here's the diagram. The water level sensor pin, LEV and sensor are in the bottom right corner.

http://www.celicatech.com/gallery/files/6/7/9/1/205ewd7.jpg (http://www.celicatech.com/gallery/showimage.php?i=23975)

Based on this and what the 205 owners say they do to get around the code 54 when going to a FMIC, I'm thinking I should be able to just ground the LEV pin and that should show continuity on the circuit. By putting a jumper in the plug on the 205 harness all they are doing is hooking the LEV pin to the ground on the other wire. I'm thinking this should work.

Jeremy's post above will take care of the issue with intercooler pump and the ECU. His post has the web address for a GT4 site in the UK and I checked it out as well. They have some good info there and even had some pictures of what they were doing with wiring on the 205 harness to get around this. Based on the diagram in Jeremy's post, I'm just going to make a small circuit with the resistors as shown and wire everything into the correct pins. This should cure that issue.

If you've got an opinion or advice on the water level sensor fix, please let me hear it. I haven't been able to find much of anything about getting around the code for the water level sensor that wasn't associated with the 205 harness.

08-22-2014, 01:28 AM
Also, here's a diagram I found that decodes most of the 205 pins. Thought this might be of help to someone doing something similar.

http://www.celicatech.com/gallery/files/6/7/9/1/205_ecu.jpg (http://www.celicatech.com/gallery/showimage.php?i=23976)

08-22-2014, 07:14 AM
Very informational posts Mike. Thank you. :)

08-27-2014, 03:16 AM
Yeah Mike, you just need to ground the LEV pin, I completely forgot to mention that. Sorry.
Same thing for the RC, FYI.
I just used the stud the ECU bolts to. Nice and easy.

08-27-2014, 11:53 PM
Thanks for confirming Jeremy. That makes me feel better. I thought it would work but I wasn't 100% sure.

09-09-2014, 02:07 AM
Time for an update.

I'm getting close. I finished making up the wiring that I needed over the weekend. I had to get the adapter harness put together to get around the code 54 intercooler issue with the 205 ECU. Thanks to Alltracman I think I've got all of that worked out. The post that Jeremy put up with the diagram is the way around that. I made a harness that I spliced into the Berk harness. That went fine.

A couple of things about the Berk harness. It makes this a simple process for the 90-91 wiring (I have a 90-91 JDM ECU so I had already repined the harness previously. With the stock 92-93, I really think it would be easy and cheaper to repin the plugs. They are pretty close to the 205 setup). First, on the one I got the FC pin on the 205 side was in the wrong place. It was in the spot for the intercooler water level sensor, LEV. Easy enough to fix by moving the pin but if I hadn't checked the harness this would have been a major pain. This may just have been a mistake on the one that I got but if you use the harness be sure to check that. Second, unlike the harness that Luni got, the wiring for the MAT and IAT are labeled and there on the 205 side but the are just cut wires and not connected to the VS and THA spots on the 185 side. Not a big deal but I was under the impression that they would be connected. Third the wire for the M+ pin is wired into the E2 pin. Not an issue if using the MR2 ECU but for the 205 this wire/pin is needed for the code 54 fix. Once again, not a big deal but something to be aware of if doing this conversion with the 205 ECU.

I've got the ECU in, the harness hooked up to it and the extra wiring under the dash finished. I also got the converter harness for the gen2 MAP installed. The only things left are getting the connector pipe into the intake hoses and putting the IAT into that and getting the fuel rail put together with the 540 injectors and installed. I want to thank ChrisD and Luni for helping me out with the fuel rail issue. Luni hooked me up with a good stock one and ChrisD made me a hell of a deal on a WolfKatz. Once that's put together and installed I'll be ready to try to fire it up.

09-17-2014, 02:45 PM
Haven't gotten much done so far this week. The recovery from the sinus surgery, while not as bad as I thought it would be, is taking a little more than I expected.

Anyway, I got the fuel rail assembled. That went together pretty well. I've got it ready to go in. I have my AFM replacement pipe done and ready to finish putting in.

Once I get the pipe and the fuel rail back in I'll be ready to fire up. Hopefully soon.

09-17-2014, 06:20 PM
Got the AFM replacement pipe installed and taken care of.

The part I've dreaded the most, putting the fuel rail back in, is not going so well. I've got the rail in and laying at an angle where it looks like it should be but I can't get the damn bolts to start. They're close, they go into the holes but they won't start into the threads. Everything I've found about putting it back in says to pull the wiring harness up and out. That has helped but it still won't go the rest of the way in.

If anybody has any suggestions please feel free. I'm done for today I think but I really want to try and get it together tomorrow.

09-18-2014, 06:45 PM
The fuel rail finally went in. That was a job. I finally got it in with the help of Norma, my cat, the Toyota Master Tech. She jumped up and sat on my back, took a look over my shoulder and then the rail dropped down into place and the bolts started. That was one thing down.

I've got everything put back together and hooked up. Didn't have any fuel leaks. Hit the key and the engine turns over but no start. I'm pretty sure I'm getting fuel. My nose is still pretty missed up at the moment but I thought I could smell fuel. Something is off somewhere.

I've got a couple other igniters that I may try but I'm going to go through the trouble shooting section first. I've got to double check the ECU pin out and make double sure that I did need to move that one wire in the Berk harness. If it's not the igniter or that wire, I figure I've got a long road ahead of me tracking this down.

09-18-2014, 09:49 PM
Printed out the voltage diagnostics for the 3rd gen ECU. Everything is in spec except for the PIM voltage. It is showing to be at the 2nd gen level. I've got to go back and revisit my voltage reducer from that post on MR2OC. The other voltages are right where they should be.

I guess I could have a fuel issue. No problem before but whose to say what has happened in the last month sitting.

Opinions and suggestions gladly accepted.

09-18-2014, 10:18 PM
Wrong igniter would allow you to start.

Wrong MAP sensor would allow you to start. Your fault is somewhere else IMO.

09-18-2014, 11:13 PM
Thanks Luni. That's what I thought. I changed the igniter to begin with to a 5S igniter. I thought I had read that it would work. I've got the 2nd gen MAP sensor but I did the voltage reducer that Eshiikai put up at MR2OC. It should work but I've got to double check that.

I just checked a little while ago and I've got fuel through the filter any way. I'm going to go check in a minute and see if I've got spark. If I've got spark, not sure at this point where to go.

09-19-2014, 12:37 AM
It lives! Some ass monkey had disconnected the coil wire from the distributor. Hooked that up and it runs. Not well, but is starts. It is PIIIIIG rich right now where the MAP sensor signal is double what it should be. It's probably dumping WOT fuel at idle at the moment. I've got to check that voltage divider I made and see what, if anything, it's doing. May have to rebuild that one. I need to check the sensor as well to make sure that it's good. I just found out a few months ago that the vacuum wasn't hooked to it. I'm guess that was a jack leg FCD. Any way, it's running. Now to get it running right.

09-19-2014, 03:37 AM
Congratulations! :)

09-19-2014, 12:22 PM
Thanks Mario.

I'm going to check the MAP sensor voltages today to see what's going on. I've also got a steady CEL right now. Not sure what's up with that. I can't get it to flash at all right now. I need to check to make sure that the 205 ECU doesn't impact the diagnostic terminal. I'm probably doing something wrong. I figure the light has something to do with the 205 WTA pins. I need to double check my adapter wiring for that to make sure that it is all correct. I looked at it several times before hand but I'm going to go back and make sure.

If anyone is going to do this conversion, and it's not bad, go with the MR2 ECU. From what it looks like, it's basically the same swap but you don't have the WTA pins to deal with.

More updates later today.

09-19-2014, 07:00 PM
Got the MAP sensor issue taken care of. I had to remake my voltage divider. I had got the resistor backward the first time. Now it starts and runs half way decently. It's chugging and sputter some. Almost feels like a miss. Still running rather rich. I'm wondering if the 2nd gen map sensor conversion is going work as planned.

It won't rev past 4000 so I'm wondering what's up with that. I'm going back out in a few minutes to see if I have a loose vacuum line anywhere. I thought I had them all taken care of but going to double check.

Any ideas or suggestions welcome.

09-19-2014, 08:23 PM
Went back out and checked the vacuum lines. Everything was good there.

I'm thinking that my MAP sensor adapter experiment isn't working. I checked the voltages at the ECU with the car idling and I'm getting voltages of 2.3 at idle with a vacuum of about -12 or so PSI. Based on this graph of the MAP sensor voltages I should be around 1.3 volts or so.


If I give it much gas the voltages go up into the 3.3 to 3.6 range which should be for around 10-15 psi of boost and I'm never even getting to 0 vacuum/boost. The vacuum will come up to almost zero but never hit it. When you rev it up to around 4000 or so, there are strong fumes coming from the driver's side rear corner of the engine. I was afraid at first that it was the fuel rail not seated completely but I'm pretty sure it just heavy, rich exhaust fumes coming up from somewhere on that side.

I'm thinking that with the 2nd gen MAP sensor, even with the voltage divider, I'm showing the ECU too much voltage and it is just dumping fuel. I'm getting some thin, black smoke at idle too, so I'm sure it's still running ridiculously rich.


09-19-2014, 08:33 PM
One more thing. Is pulling the codes the same process for the 3rd gen ECU as the 2nd? I'm getting a CEL but I can't get it to give me anything.

09-19-2014, 08:57 PM
Not sure on the code issue nor the procedure for pulling on a 3rd gen ECU it should be the same though, but it sounds like you are pig rich and it is shuffling all the additional fuel through to the charcoal canister. Most likely what you are smelling. Do double check to make sure that it is all still intact with lines connected to it as well.
I am trying to remember the issue that caused the 4k rpm thing. If I remember it I will post up. Luni likely knows what it is. I know a couple fellas that did swaps to 3/4 gen engines had something like this as well for a time, so maybe poke around in those threads and see if anything useful comes up.

09-19-2014, 11:47 PM
Reading codes is the same.
You can also jump TE2 and E1 for a more sensitive diag mode, just like the 92/93.
Are you sure all the Berk wires are right?
Possibly the TE1 wire may not be connected right?
Try grounding it right off the ECU [attach it to the stud by the ECU].

Not revving pas 4K is usually the wrong igniter. But it may also be your MAP sensor issue. I would suggest fixing that before you put a lot of effort into chasing anything.

09-20-2014, 12:11 AM
Thanks guys. I'll double check the Berk harness for where it's going to on TE1/TE2. I've got to double check my harness. While I do have a 92 I was running a 90/91 JDM ECU so I have done some repinning but that part of the harness should still be there.

As for the igniter, you're supposed to be able to use a 5SFE igniter, correct? I got it to rev to about 4400 or so. The igniter was the first thing that I thought of too but I have swapped it out yet. I pulled three from the Pic N Pull before I came back from San Antonio. They all three have 175 on them. They all came off of 5S Celicas. These should work provided they're good correct?

I'm also thinking that it is dumping so much fuel that the ignition may not be able to over come that and won't rev any higher. I checked the voltages on PIM at the ECU and it was like 3.6 to 3.8 at 4000+ rpms. It had to be dumping a ton of fuel.

It doesn't look like there are a lot of alternatives to the 3rd gen MAP sensor. From what I've been able to find there doesn't seem to be anything that is PNP out of the box. There are some threads around the interwebs about using GM MAP sensors, 2 bar or 3 bar, but they both require modifications. The 2 bar requires the same mod I've already done to the 2nd gen MAP. The 3 bar requires more mods to adjust the voltage up.

I'm not sure what's wrong with the set up I've got at the moment. The voltages with the engine off and key on are in the range where their supposed to be at about 2.2 V. I checked the vacuum part of the sensor this morning and it held 15 psi of vacuum. I don't have a pressure pump but I would think that route would work as well. I guess I need to check the voltage coming off of the sensor with just the key on and pulling vacuum.

09-20-2014, 01:08 AM
It's supposed to be a 6th gen 5S igniter.
Maybe only certain years? Not sure on that. I know the P#s cross over all over the place, but they may not all work for the 3S.
E2 is probably fine, if the engine starts. It's just ECU ground. Grounding TE1 [or 2] is what puts the ECU in check mode.

09-20-2014, 02:45 AM
Oh, never actually saw the part about the igniter needing to be a 6th gen. Damn, these are all 5th gen.

Going to check the pin tomorrow and see what's going on with the diagnostics.

09-20-2014, 05:36 PM
Went out this morning with the vacuum pump and the multimeter. With the adapter harness in place and just the key on, engine off, no vacuum, I got high readings through the adapter. Pull vacuum up to -15 psi and the voltage was well above 2V. I then checked the voltages BEFORE the voltage divider and the were LOWER than after. Pull the same vacuum and checked the voltages before the voltage divider and they were in the 1.4V range. After that I thought what the hell and took the voltage divider out completely and fired the car up. After about a minute or less, idles fine. Vacuum is at about -18 PSI where it normally runs and the PIM voltages at the ECU were in the correct 1.3V or so range.

I'm thinking that I need to go back and modify my voltage divider. I've got the resisters in the right places (R1=330 ohms & R2=1800 ohms). I tested the divider on a 9V battery and it does work BUT I think when I installed it with the bullet connectors I have the R1 resistor on the wrong side of the R2 joint in the wire. I'm going to swap that around and see what I get.

Still have to check the TE1 & TE2 pins and see what is going on with the diagnostics.

More later.

09-20-2014, 07:35 PM
Changed the position of the R1 resistor on the voltage divider and that fixed it. Voltages fell right in line with where they're supposed be and the car idles fine and runs.

Took it for a test drive. It ran pretty well. It will boost but there is a stutter in the engine under boost and it wouldn't boost above 10 psi. Ran pretty good though.

I got codes pulled. I'm getting 21, 24 (I thought I counted 3 blinks on the end but evidently not), 31, 34 and 54.

Since the 54 is showing up, something in my adapter harness isn't exactly right so I have to look into that.

The 21 was the oxygen sensor heater showing a short or not reading correctly under load. 24 is the IAT sensor. I've got to go back and check that I'm still getting voltage at the ECU. This looked OK the other day when I checked the ECU pins. 31 and 34 are related to the MAP sensor. I haven't reset the ECU from the beginning so I'm going to do that, run the car and then see what codes I have other than the 54.

Making progress.

09-20-2014, 09:46 PM
You move fast Mike. Good to hear that forward progress is being made. :)

09-23-2014, 07:31 PM
Mike, you definitely need the 6th gen igniter. You want 89621-16020 or 89621-26010

09-24-2014, 11:07 AM
Thanks for the numbers Luni. I didn't have those numbers. I'm going to look for those after I get the new O2 sensor installed, it should be here today or tomorrow, and get the Code 54 issue fixed.

Jeremy was right, you do need the relay. I found a thread on MR2OC that shows that fix. The one on the UK sit seems to work as show for the 205 but if you don't have the 205 harness you need the relay and include the INT pin in the circuit. I've got the diagram. I'll get it posted up soon for anyone wanting to do this with the 205 ECU.

09-25-2014, 12:57 AM

First off, I checked the igniter numbers that Luni posted above and I do have one of those numbers, the second one so I should be good there.

I had to go to the doctor for the first follow up after the surgery so I got home early. I used that time to work on the code 54 issue and the O2 sensor came today as well.

I picked up the relay and got it wired in, rebuilt my "intercooler pump" harness and got it installed. I then got the O2 sensor installed. Then I fired him up. No CEL light!! I let it sit and warm up to operating temperature and still no CEL. I then took it for a drive. Car ran great. Hit the interstate and accelerated pretty good. Boost came on and was good up to 10 or 11 PSI and then it struttered like it did before. The CEL came on for a few seconds and then went out. I continued on and no problems. I hit boost again and ran it up. Same issues as before. Good to about 10 PSI but then it stuttered. CEL came on for a few seconds and then went out.

When I got home I checked the codes. 21, the O2 sensor came up again. Not sure about that one. I put in a brand new Denso OEM sensor so I'm going to hang loose on that one for the moment. 34, turbo pressure abnormal came up again. I'm guessing that the 2nd gen MAP sensor is giving a weird signal just above 10 PSI. I think they may both be related. On the trouble code list for the 6th gen Celica, both codes mention issues with the vacuum sensor can throw those codes. I've to some more research to do there to track that down.

As for the conversion, I like it. The car start up quicker code and isn't rough at first like it was with the 2nd gen electronics. It seems to run a little smoother. I please so far. After it warms up, the idle is a little funky when stopping in traffic. When you come to stop light or something and hit the clutch the idle initially drops to about 1400 RPMs. It will stay there for 4 or 5 seconds or so and then it starts to drop and then will settle in at about 1000 RPMs. On the 2nd gen electronics it usually idled between 900 and 1000 so once it drops it's not much, if any higher, than it was before. It's that initial stop at 1400 I'm not sure about at the moment. I haven't tried to see if it will rev to the 7250 or what whatever the 3rd gen redline is set at. I've got to look that up. I think I'm good with that though since I've got the right igniter. I have to check though.

So that's where I am at moment. I've got research my final few issues but I think I'm close.

09-25-2014, 01:08 AM
Here's the diagram for the code 54 fix for a non-205. The other diagram I posted is supposed to work with the 205 to solve the code issue if you remove the WTA and go with a front mount. This solution works without the 205 harness. I'm not sure that the relay is actually necessary. You might be able to get away with using the diagram and running switched 12V to the INT pin. That pin is part of the WTA system and the 205 would have the wire in the ECU harness for that one, thus not needing it to cure the code 54 issue.

Anyway, I can say this solution works. Here's the diagram.

http://www.celicatech.com/gallery/files/6/7/9/1/code54elimination-wiring_with_relay.gif (http://www.celicatech.com/gallery/showimage.php?i=24012)

I'm also posting a diagram I made to show the correct way to hook the voltage divider up. I hooked mine up wrong the first time and figured I might not be the only one. The key thing here is to make sure that the R1 resistor is below the R2 resistor for this to work. Here's that diagram.

http://www.celicatech.com/gallery/files/6/7/9/1/map_voltage_divider.jpg (http://www.celicatech.com/gallery/showimage.php?i=24013)

Hopefully these will help anybody doing this conversion.

09-25-2014, 01:43 AM

09-29-2014, 11:37 PM
Here's the latest update:

The O2 sensor came last Wednesday and I picked up a relay on the way home that day as well.. I got the relay installed in the WTA spoof circuit like the above diagram shows and installed the new O2 sensor as well. Fire the car up and NO CODES!! Drove it to work Friday and everything was fine. The only time I got a code was if I pushed the boost. Still same scenario, under acceleration OK till 10 psi, over that the car stutters and the CEL comes on for a few seconds. I'm sure it's got to do with the response time for the 2nd Gen sensor but I haven't heard anything from anybody that has used one to see if my theory is correct.

Saturday I figured I'd remount the ECU in the proper place and get it out of the floor. Got everything in, hit the key and the car starts. It runs for about 30 seconds and quits. Hit the key again, same thing. Getting all of the wiring back in that spot and getting the carpet back up over it is like putting 10 lbs of shit in a 5 lbs bag. There's not a lot of room there without the adapter harness. Put that in there and there really isn't any.

Pulled the wires back out and found one had come loose from the harness. Got in back in and made sure the rest were tight and where there supposed to be and put it all back together. Hit the key and the car fires up and runs. Great!

After about a minute, the damn CEL comes on. Check the codes, 21 and 54, O2 sensor and Intercooler pump. Must have jarred something else messing with the wiring. I didn't have to time fool with it any more Saturday or Sunday. I went out when I got home and pulled it all loose again. Check all of the wires. Looked at the wiring for the relay and for the Code 54 harness. It looked like one of the connectors I put into the Berk Harness might have slipped back a little. I pushed it up in the connector and checked the other 4 wires. I had to add one other wire to the harness, the one for the INT position. Checked it. Made sure it was up far enough and that the relay fix was working. Everything was good. Put it all back together again and fired the car up. No codes!

I moved the car out of the driveway so I could drive it to work tomorrow. Got down out of the driveway and went park by the curb, damn CEL comes on. Check the codes again, 21 and 54 again! I'm guess I jarred something AGAIN putting the harnesses back in the ECU and move the car out of the drive way jarred it loose. The car runs so I'm going to drive it tomorrow but I probably won't get a chance to get back in there till the weekend. This is getting really aggravating.

10-02-2014, 07:15 PM
I can send you my Gen3 MAP sensor if you wanna try it and see how it runs with it?

10-03-2014, 02:30 AM
^Thanks Rob. I may take you up on that soon. I want to get my O2 sensor and code 54 issue fixed first. The car is drivable as it is right now, I just can't get full boost out of it.

One question, where are getting you vacuum signal for the sensor from. I've got mine hooked into one of the manifold ports to the right of the throttle body. This line comes off of the manifold and then is teed to the MAP sensor and to that vacuum pot that goes up against the throttle linkage. Some people were saying that the MAP sensor should be on it's own line and definitely hooked into a manifold port. What's your opinion?

10-03-2014, 02:41 AM
Time for another update.

My luck continues. As you may have seen I've got an issue with the O2 sensor wiring on the harness side of the plug. I decide to check that this evening to see if something was loose and long story short I ended up holding the harness plug and having 4 loose wires. On top of that the wires in my harness don't match the colors shown in the 92 wiring diagram manual. I took a guess on a couple of them but I'm still getting the 21 code.

I'm also still getting the 54 WTA intercooler code. This one really pisses me off as the fix worked as long as I had the ECU laying in the floor. Since I've mounted the ECU in the correct spot I continue to get the 54 code. I've pulled the relay out and checked that it is working. I've pulled the harness plugs out and checked them, they appear OK. I've taken the LEV and INT wires that I had to add back out of the harness plug and put them back in to make sure that they are seated right. They appear to be prior to plugging them back into the ECU. I guess I'm going to have to pull the entire adapter harness back out, double check to make sure everything is still function as it should and put it back together. That is getting really frustrating.

The good news is even with these problems the car seems to run better. It starts faster and doesn't sputter cold first thing in the morning. The power is good. The idle is starting to straighten out. I'm going to adjust the manual idle screw a little to see if I can get it down to 900 or so where it probably should be. I'm happy with the conversion I just wish I could get these last two CEL code issues fixed and then I'll move on to the MAP sensor issue.

More later.

10-03-2014, 09:39 PM
^Thanks Rob. I may take you up on that soon. I want to get my O2 sensor and code 54 issue fixed first. The car is drivable as it is right now, I just can't get full boost out of it.

One question, where are getting you vacuum signal for the sensor from. I've got mine hooked into one of the manifold ports to the right of the throttle body. This line comes off of the manifold and then is teed to the MAP sensor and to that vacuum pot that goes up against the throttle linkage. Some people were saying that the MAP sensor should be on it's own line and definitely hooked into a manifold port. What's your opinion?

I take signal where the stock sensor takes signal from. The nipple under the throttle body.

10-04-2014, 02:08 AM
Sounds like you're pulling from the correct location.

I answered your other question in your other thread.

10-04-2014, 02:10 AM
Thanks guys. I appreciate the help. That where I thought I should be pulling from. Having that tee in the line won't hurt the signal will it?

10-04-2014, 06:06 AM
It shouldn't, no.

10-04-2014, 10:34 PM
Comes from the factory that way.

10-05-2014, 06:26 AM
^^ This.

10-05-2014, 03:02 PM
I like the map to have its own port, but as long as there are no leaks, it's fine. You running on a Gen 2 map? I don't know if I really like the idea of the voltage divider... Map is now the most important sensor on your engine. I don't know how well the Gen 2 sensor responds. But I like trying new things so keep it up. :-)

For the 54, have you tried just running m+, m-, and mtt directly to ground? And leave int just attached to the relay? Something seems odd to me in giving them resisted voltage and then bridging to ground anyway. I'd actually try unplugging pin 30 on your relay and double check your ground. I'm not sure what causes the ecu to throw the code exactly, but that seems like as good as anything to try. As an alternative, I would also try leaving the circuit as is and disconnecting the ground. There's something there if you bolted up the ecu (grounding it) and it threw the code again.

Sent from my Nexus 7 using Tapatalk

10-05-2014, 10:40 PM
Chris according to the right up on the UK GT4 site, there is a 4K ohm resister in the factory 205 harness. No body is exactly sure why it's there but without on a 205 they say you throw the codes. Supposedly somebody there had researched this (using the 2 1K resistors) for being able to go with a FMIC and not through the code. It doesn't make much sense to me but they swear it works. My set up was working before I bolted the ECU down and moved all of the harnesses.

I'm using the 2nd gen MAP for now because I didn't want to have to lay out $175-200 for the 3rd gen MAP. I'm keeping an eye out for a better price and I've seen several reports that the 4th gen MAP sensor will work, just bolts up differently. Still verifying that one before I try to buy one.

The 2nd gen MAP has worked OK so far. The only issue I'm having is that something doesn't seem to like to go about 10 PSI quickly. The car stutters and throw the turbo boost sensor code, 34 I think. I've read that the 2nd gen sensor doesn't have a really quick response time so I'm leaning that way. It makes sense give what the car does and that it's throwing that code. It runs fine out of boost and good up to 10 PSI or so.

10-05-2014, 10:52 PM

I think I've got the O2 sensor problem fixed. Following alltracman78's guidance, I checked for continuity through the OX sensor on the diagnostic port and found the right white wire. That one went to the blue wire on the sensor. Next, I turned the key on and check for 12V on the other three wire. Turns out in this case that it was the black/grey wire. I had previously checked and the wire going to the OX pin on the ECU was pink/black. I figured the pink/black wire in the O2 sensor harness would be the same as that one so I hooked it to the other black wire on the O2 sensor. The remaining white wire went to the white ground wire one the sensor. Fired the car up and NO code 21! Hopefully that one stays fixed for now.

I worked on the harness again for the code 54 issue. It looks like the wire that I ran for the INT pin on the ECU isn't staying far enough up in the ECU plug to make contact. I've check the other 4 pins (MTT, M, M+, LEV) and they all seem to be OK. I pushed the INT connector all the way up in the connector and again and put everything back together. When I fired the car up, no CEL. I let it run for 5-10 minutes and no light. Pulled it out of the driveway to take it for a run and the damn light came on. Code 54 again. I'm guess that connector was close when I put everything back together but moving the car caused it to move back again. Not sure though. It is on the plug closest to the fire wire and in the middle of the mess of wires. It's really hard to get to with everything plugged in. I did try pushing it in again with everything plugged in but I didn't start the car back up. I guess I'll see in the morning. I may end up pulling that connector back out of the pull and rewiring that one if this didn't work.

10-06-2014, 04:28 AM
Have you ever been able to drive around without 54?
The code doesn't usually come up until you drive.
Where's the weak connection? The Berk harness or the factory harness? If it's the factory harness you can remove the pins and join them outside the harness [wrap in tape].
If it's the Berk, it's warranty time.

10-06-2014, 11:02 AM
I was able to drive it without the code 54 until I bolted the ECU back in place. While I was checked everything and chasing codes after firing it up for the first time I had the ECU laying in the passenger footwell.

Where I think the weak connection is occurring is in a wire I had to add to the Berk harness. Since the harness is built for the MR2, it has empty spots for the LEV and INT pins. I had to add wires into both slots. I got the ECU connectors and put them onto the end of the wires then put them into the slots. The one that I put in the LEV slot seems to be staying put fine. The one that goes into the INT slot is the one that appears to be backing out. I used 18 gauge wire as this was the smallest the auto parts store had but I think that is part of the problem. It seems like the wire is a little too big for the connector and is causing the connector to catch a little in the slot on the plug. I may need to get a little smaller gauge and redo this one with a new connector and see if it goes better and stays.

Since this one is on 26 pin plug and way that the ECU bolts into my car, this wire is on the bottom toward the firewall so it's kind of hard to get to with everything plugged in. I was able to kind of get to it yesterday to push that specific wire in further so I'll see what happens with it today.

This has been a frustrating part of this conversion. If you used the MR2 ECU you wouldn't have this issue but it has it's own quirks with the traction control thing. There are two extra pins on that one you have to do something with but I think in that case it's just grounding those two pins.

10-07-2014, 02:13 PM
You don't have any spare harnesses? I always use them for wire.

10-07-2014, 04:57 PM
Nope. Right now just have the one in the car. I've been building what I need so far. No pic n pulls here. That's something I reaaaaaaally miss about San Antonio.

10-07-2014, 05:59 PM
Ive got spare harnesses for wire too. Good shizz.

10-08-2014, 11:10 AM
I'm going to have to make a trip to the pic n pull in Columbus OH and pick up some harnesses.

10-26-2014, 11:45 PM

I've been fighting the code 54 problem off and on since the last post. I thought that I might have a bad relay so I replaced that. No change. I got to looking at the wire that I had going into that slot on the plug. The wire was a little big and it looked like it wasn't letting the connector go all the way forward to match up with the ECU pin. I took some of the wire harness out of Bruce's car while we were pulling it apart this week. I used it yesterday to rewire that particular wire in the plug. No change.

I went back out today and checked some more and pulled that plug out of the ECU ago. I checked with the multimeter and I had power all the way to the back of the plug. I flipped the plug around and checked on the ECU side. No power. I got to looking and it looked the connector had slipped back in the plug and wasn't making contact with the ECU pin possibly. I fooled with it and couldn't really seem to get it to stay where it need to be. I worked on it some more and got it where I could get voltage right at the very front of the plug without having to insert the probe into the plug.

I plugged the connector back into the ECU and hit the key. I revved the engine up some and the light came back on. I went back to the ECU and was finally able to see the connector in the plug. It looked like it had moved back again when I put the plug back into the ECU. I was able to take the multimeter probe and push the wire connector up into place. Hit the key again and revved the engine up. No light. Not getting excited at this point.

I didn't have a lot of time but I did back the car out of the driveway and parked it on the street. Still no light. I'm not 100% positive but I might have got it this time. Every other time I've thought I had it, when I backed the car out of the driveway, I had the CEL had come on by the time I got to the end of the driveway. I guess I'll find out tomorrow when I drive to work if I have gotten this time.

Hopefully this got it. I'm pretty much down to the point now that changing out the ECU is going to be the next step. The other wires involved in the code fix were already in the Berk harness so I don't think they're the problem. I've to power coming out of the relay where it's supposed to be so that should be OK and hopefully the INT pin is getting power now. I'm thinking that I've got it now since I didn't get a light at the bottom of the driveway but I'll know for sure when I actually drive it tomorrow. Keep your fingers crossed!

10-27-2014, 04:17 AM
Hoping for the best for you Mike!

10-27-2014, 04:14 PM
Drove it to work this morning, 20+ miles, no CEL. I think I got this one finally solved hopefully.

This evening I'm going to try and see if the boost issue at 10 PSI and above is actually the response time of the 2nd gen MAP sensor or if it had to do with the ECU thinking the intercooler wasn't working correctly. I didn't really think about it before but I have read that the ECU will make changes to limit the amount of boost if it thinks the intercooler pump isn't running and therefore the intercooler not working as it should. I'm hoping this is the case.

10-27-2014, 06:03 PM
Yeah. Its called "limp mode"

It also holds timing back too. So yeah, hopefully you got that sorted.

10-27-2014, 11:30 PM
Fingers Crossed!

10-28-2014, 02:46 AM
No CEL on the way home either so I'm pretty sure the code 54 issue is fixed.

I was only able to run the boost up once on the way home and I went above 10 PSI with out a problem but I missed exactly how far it went above before it felt like it hit the fuel cut. The 205 fuel cut is supposed to at 17 PSI give or take. I did have my boost controller set at 13 PSI previous but I messed with it a few weeks ago to try and dial the boost down while I was having the stuttering issue. I may have got the wrong way and actual hit the fuel cut.

Hopefully traffic will be lighter tomorrow and I can check it again and get a good look at the gauge to see where I'm getting. It could be too that the voltage divider is working exactly as planed and it is showing a higher voltage on the top that is causing the fuel cut. I'll have to experiment some more and see what is going on.

But for now, no code 54 which is good!:facesjump:

10-28-2014, 11:24 PM

10-29-2014, 12:04 AM

No code today either so I'm going to mark that one off.

I didn't get to try to run the boost up as much as I wanted to try and check that problem but I did run it up to 12-13 PSI. I was wanting to go further but I glanced at the speedo and I was over 100 on the interstate so I thought it prudent to back off and hit the brakes a little. LOL

But the good news on this topic is that at over 10 PSI there was no stutter like before so at the moment it looks like the 2nd gen MAP is working. I'm guessing that the issue I was having with boost was related to the 54 code. From what I've read, the 205 ECU goes into safe mode if that code comes up. It makes sense that if the ECU thinks the intercooler isn't working correctly that it would limit boost. I'm going to experiment some more to see where the stutter or fuel cut is coming in. If I'm going over 13 PSI I'm going to have to readjust my MBC to get it back to that point. 13 is enough for me and the engine is getting some miles on it and I don't need to blow it.

With the code 54 taken care of I have to say that the 3rd gen conversion is worth it. The car is running better, it starts faster and better cold. It runs good hot and it is smooth at cruise. After getting the that CEL code taken care of, the warm idle isn't doing what it was (dropping to about 1400 or so for a few seconds and then dropping to right at 1000) but it was staying at about 1300. I adjusted it down this even to 950 or so. It's running really good now.

So at this point, I would highly recommend the conversion. Like I had mentioned earlier it would probably be simpler with the MR2 ECU but if your get the freaking ECU connectors added in correctly where needed it works fine.

More updates later.

10-29-2014, 09:23 PM
I was able to do some more testing on the way home tonight and it looks like I am hitting the fuel cut at about 14 PSI or so. Since the 205 ECU is supposed to have fuel cut at about 17 I'm guessing my voltage divider is not working exactly right up toward the top end.

For now, I'll just get my MBC set at about 12-13 PSI and live with it. That works for me right now. Later on when I've got some extra money I'll get a 3rd or 4th gen MAP sensor and all will be well.

10-30-2014, 05:26 AM
Yeah, the improved drivability you get with the map based control shouldn't be underestimated. I absolutely hated driving on Gen 2 electronics, which ultimately lead me to going standalone.

Sent from my Nexus 7 using Tapatalk

10-30-2014, 10:05 AM
The WolfKatz fuel rail is working great Chris.

10-30-2014, 12:35 PM

Sent from my HTC One_M8 using Tapatalk

12-29-2014, 07:23 PM
Update on the project.

I traded some of the parts I had to BlueDragon for a 3rd gen MAP sensor. It came today and I got it put on. First off, it fixed the fuel cut issue. I'm going to 14 psi right where the MBC is set. No problem at all. Second, right now it looks like it has helped with the cold idle issue I've been having. Prior to the change to the 3rd gen MAP, the car ran like crap when starting up cold. It coughed and sputtered pretty bad for a minute or two before it finally settled down. The car was cold when I started it after changing the sensor and it idled fine right from the start.

So, for anybody looking to do this conversion, it is possible to run it on the 2nd gen MAP with the voltage divider. It works OK. Using the resistor set up that I did, it looks like the voltages that the ECU sees are higher than they should be for the given pressure/vacuum. You could play around more with the resistors to see if you could get the ECU signal voltages more in line with the 3rd gen sensor. I'm see this now as a stop gap measure until you can get a 3rd gen MAP. It would also be a good back up in case the 3rd gen sensor goes out. The 2nd gen with the voltage divider would allow you to the car running until you could get a replacement.