View Full Version : Issue with 3rd Gen 3SGE swap - please help!

07-24-2014, 05:05 AM
Been working on this swap for awhile now, and finally got it to a stage where it can turn over, and idle.

There are no problems at idle.

When gas is applied the car sputters and starts backfiring like crazy, sometimes stalling out completely.

Leakdown test was done on all cylinders with an average of 95% across all 4.

Thought the fuel was being choked out somewhere, replaced the fuel filter (the old one was very restrictive), tested the fuel pump, drained the tank and filled with fresh 91 octane.

Still backfires.

I will post a video - the engine and harness are OBD1.

Help! :(

07-24-2014, 09:56 AM
Check your cam timing and the firing order.

07-24-2014, 02:46 PM
Video: https://www.dropbox.com/s/uuaf8kbduj60yze/Video%202014-07-21%2C%209%2020%2051%20PM.mov


07-24-2014, 03:17 PM
Check your timing & plugs like Joey suggested. Really sounds like one of those are off.

07-24-2014, 06:05 PM
I am helping him with this.

Timing is good, 10 degrees with check connector bridged. Firing order correct - spark plug wires are all good. If you unplug each one of the wires it definitely changes the way the engine runs, so it is idling on all 4 cylinders. We had to take the timing belt off to deal with an oil leak, and it had the same misfire before and after. I triple checked the cam timing when the belt went back on.

No codes, even when I try the diagnostic mode. the CEL will flash when it misfires and hits this weird 2500 - 3000 RPM rev 'limit' but no codes are thrown. It will drive the wheels in 5th (car is on a hoist) so it runs fine under load, but has the same stumble/rev limit at 2500/3000.

Also loud backfiring out the exhaust, and the intake vacuum 'pulses' to atmospheric when it hits this rev limit. Plug gaps are fine but plugs are a little black. Seems like an ignition problem? Has new plugs, cap and rotor. Was going to try an igniter/coil assy from a known working ST205, also different plug wires. We also have another ECU to check with.

It runs beautifully right up until you hit this weird rev limit/misfire point. Starts right up, idles nice and smooth.

Any other ideas?

07-24-2014, 06:18 PM
Very confused with this thread. 3rd Gen 3S-GE swap...are we talking about a 3rd Gen A60 Series (1981-1985) Celica, or a 3rd Gen 3S-GE engine? What car & what engine do we have here? At least what year Celica and what year 3S-GE swap do we have?

07-24-2014, 06:27 PM
3rd gen 3S-GE swapped into a 94 celica GT-S (ST204). engine etc. are from a ST202.

All OBD1.

07-24-2014, 06:34 PM
We had a similar issue on a car at the Dragon a couple of years ago, Celicatuner92's car I believe. There wasn't a misfire, but it wouldn't rev past 2k, it just hit a wall.

Eventually we narrowed it down to the connector to the TPS (Bugs and Andy did, I was holding the umbrella and flashlight.) It was connecting on some pins, but not all of them. I don't remember exactly what we did, but I think we took it apart cleaned it and put it all back together. What eventually led to the fix was simple. When holding the connector and a certain angle, the problem went away.

07-24-2014, 07:05 PM
Sounds more like overfueling than underfueling, how does the exhaust smell when this happens?

07-24-2014, 08:07 PM
Sounds more like overfueling than underfueling, how does the exhaust smell when this happens?

We've tested the fuel pump and replaced the filter, the flow is normal. New fuel line from filter to rail. Fresh fuel.
I'm not saying you're wrong, it could be ignition somewhere - not sparking at the right moment, etc.

Can't comment on the smell, it didn't smell out of sorts the other night - but it could be different with the new filter/fresh fuel.

07-24-2014, 08:33 PM
Also helping along with this. Thinking it through it definitely seems like an ignition problem now...could be

Hey Jer - what igniter are you running? I've had the wrong one in before and hit low rev limits.

The other thing is the fuel pressure VSV, have to fix that but it wouldn't cause as much of an abrupt limit.

07-24-2014, 08:58 PM
the fuel pressure VSV is only for hot starts, to keep the fuel pressure up so it does not vapor lock. Looked into it, and bypassed it for now with straight vacuum to the pressure regulator.

The TPS could be the issue - but wouldn't it throw a code? I am going to try a known good 3SGTE igniter/coil (from Tara's car, same PNs) and then we will also try different spark plug wires and ECU.

I seem to recall the exhaust smelling of unburnt fuel. I am leaning towards ignition problem too, but it could be the ECU, wiring harness, igniter, coil or plug wires. Distributor, rotor and plugs are brand new. firing order is good.

07-24-2014, 09:14 PM
I'd start back probing sensors to check voltages honestly. I'm guessing the gen 3 is a MAP system? Could be something with that system. You sure it's got the right igniter? TPS set properly? Swap ecu first cause that's easy and could be the problem.

07-24-2014, 09:17 PM
Can you check the injector duty cycle with OBD1? Either the ignition could be breaking up like you said or a sensor could be reading out of wack causing it to dump fuel to the point it effectively drowns itself.

Does it make a difference how you get to this limit? Ie easing the throttle up vs hammering on it?

07-24-2014, 09:26 PM
No difference, but the backfiring is a lot louder if the throttle is opened more when it is hitting the limit. I tried unplugging the MAP sensor and it just dies - the sensor is getting good vacuum from the manifold.

Unplugging the TPS made no difference, it just threw a code and had the same weird limit.

07-25-2014, 12:24 AM
Internal distributor issue? Valve issues?

07-25-2014, 07:22 AM
If you can get your hands on a known good distributor I would give that a shot.

07-25-2014, 01:46 PM
We could borrow the distributor from my 205 and check that. This would be really rare of an issue though...

Sent from my Nexus 7 using Tapatalk

07-25-2014, 04:02 PM
If you can get your hands on a known good distributor I would give that a shot.

Could be it, but it was brand new and has been repacked by FunkyCheese - he knows his shite. It would be unfortunate at this point if it were the distributor.

I'm going to try a few things Monday night - and if they don't work, I might have to tear out the wire harness and start testing it.

07-25-2014, 04:27 PM
The cap and rotor were replaced with new, and the seal and bearing replaced. The gaps on the sensors inside were also checked.

I tried the igniter/coil with the single plug wire to the distributor, inlet air temp sensor and TPS from a known working engine. Also the coolant temp sensor has the correct resistance at room temp and full operating temp. Tried disconnecting the vacuum sensor (MAP sensor) while revving it so it doesn't die, and it still misfires and has the limit. I also triple checked the ignition and cam timing, all good.

We are going to try different plug wires and an ECU - if it isn't that, the only items left are trying a known good MAP sensor (the car I was borrowing parts from is a ST205 so it has a turbo pressure sensor instead of a vac sensor) and a known good whole distributor. If those don't fix it, then the wiring harness will need to be tested in its entirety.

I am suspecting the ECU itself at this point. Whenever it misfires, the CEL blinks for each misfire, but no codes are stored. Also, it is actuating the VSV for the ACIS system on each misfire. I had initially thought that the movement of the ACIS actuator was due to backfiring into the intake, but after bypassing the VSV for it, no more movement when misfiring.

Based on the CEL flashing for each misfire and actuation of the ACIS, along with no stored codes, I am definitely curious what will happen with the other ECU we have. The tach output on the dash is accurate but drops off 'further' than the engine does, kind of bounces around. Also the water temp needle bounces when it misfires.

11-26-2014, 04:42 AM
What Murg was talking about with my car never thru a code for the tps it only came up as an air fuel ratio lean after I drove the car for 20 minutes or so until at the dragon all of the sudden it wouldn't rev past 2k. It had done this once before and I changed the tps Ignitor so I thought I had fixed it before the trip but it ended up being corrosion on the pin inside the connector, so it might not hurt to go through the harness and look inside the plugs for any sort of corrosion.

11-26-2014, 06:38 AM
When I first read the description of the issue, that's where my mind first went was that issue with the corrosion in the TPS connector.

The addition of the CEL flashing for each misfire and not storing the code, plus needles bouncing... Man, I don't believe in coincidence. All items above do point to the ECU and/or wiring harness.

11-26-2014, 07:34 PM
This was solved - it was a grounding issue. One of us forgot to hook up a ground on the firewall side of the head.

11-27-2014, 05:27 AM
This was solved - it was a grounding issue. One of us forgot to hook up a ground on the firewall side of the head.

First, thank goodness...

Second... seriously? Lol, a grounding issue? I mean I figured a wiring issue. But I figured one that involved the ECU instead of just a ground. That's sweet cause it wasn't an ECU.

Thanks for posting the resolution. :)

11-27-2014, 09:14 PM
Which specific ground at the firewall was not connected?

11-28-2014, 06:38 AM
car is being parted out...

11-28-2014, 02:57 PM
Well. That escalated quickly...