PDA

View Full Version : Now no start



Nitro_Alltrac
05-29-2014, 11:00 PM
Well the adventure continues. Come out of the plant this evening, hit the key, the engine turns over but no start. I'm really thinking this is something in the ignition. Turns over fine and actually sputter a few times but would never really fire up. On top of the everything else it was raining pretty good and the wind was blowing. Several times after cranking I saw smoke blow up past the car so I'm thinking it is probably getting fuel. I'll have to do some checking to make sure whether it's fuel or fire.

If fire, what are the best guesses whether it's the coil or the igniter? Plugs, cap and rotor are pretty new. I'd say the coil is original to the engine so that would put it over 100K mile and 20+ years old. If original to the body, 277K. Same with the igniter. I've got several igniters that I picked up for my 205 electronics swap. Will these work with the 2nd gen electronics or am I going to have to shell out $200 for a new one?

I'm going to try to check things out tomorrow at lunch or after work. I'm hoping that I don't have to get a trailer and tow it home.

Oh, and to make things even more complete, I found this evening that I've got a leak at the top of the windshield right over the steering wheel. The head liner was wet and dripping. I'm really hoping that it's just the seal going bad and not rust.

The All Trac is starting to make the decision to order the FR-S through the lease program next year easier. :fire:

T-spoon
05-30-2014, 05:24 AM
Check and recheck the intercooler/intake couplers, the airbox and the AFM and especially the AFM plug. It might actually start up fine once it dries out - blowing rain getting into the engine bay through the vents could potentially do funky things, especially as it ages. The leak is probably the sunroof.

Nitro_Alltrac
05-30-2014, 10:04 AM
Thanks Spoon. I'm hoping the rain is over for a while. I'm going to go out at lunch and check things out.

On the leak, the only spot on the headliner that was wet was at the very front edge next to the windshield. It was dry from the sun roof all the way under the visor. Is it possible that a leak at the sunroof could end up just there? I'm just wondering. The sunroof was my first thought too. I'm finding it a little hard to believe that I've got rust just in that one spot under the windshield. The car is pretty clean other than some rust that has shown up back around the rear wheel wells.

T-spoon
05-30-2014, 11:44 PM
Hmm, I dunno, it's possible. I don't really recall how everything is assembled up there, but I know there are drain tubes also, so who knows where water would end up if they clogged or if water got in at one level and seeped into another area.

Nitro_Alltrac
05-30-2014, 11:49 PM
Well I think you were right Spoon. Went out at lunch, hit the key and he fired right up. I'm going back down in the morning and bringing it home. I'll do some more checking then to see if I can figure out what happened.

I'll have to check my drain hose. I've never had a problem like that before. I did notice today that the rubber molding around the windshield is coming loose at the top. I've got to check but I think I may have to have the windshield pulled to fix that. Still have to research that one.

bloodMoney
06-07-2014, 03:14 PM
Well now that I'm reading this, I think your best bet is to pull the windshield and reseal. Again, mine leaks in the same place, even after the adhesive.

Nitro_Alltrac
06-08-2014, 02:47 AM
It's rained a couple of time since then, MUCH harder than it did that day. But the way the car was parked that day the wind was hitting it at a weird angle. I'm thinking that possibly in this case that wind may have forced the water down around the sunroof. I'm not sure though. I'm going to keep checking and use the adhesive for now.