PDA

View Full Version : New Celica owner from Maine



42012rs
03-24-2014, 11:36 PM
Hello everyone!

Well, I picked up a 1993 Celica ST 5-speed over the weekend. It is in pretty rough shape and I plan on fixing her up as I go. She runs good but looks terrible. All I have done is patch up the drivers rear quarter with some fiberglass for now to get inspected but once I have more time and money I will be going over everything and cutting out as much cancer as I can. She is going to be the new DD because I travel too far to run my 2004 Impreza RS which will now be a full on project.

225/70r15 general grabbers and a tired 2.5 N/A don't treat the wallet nicely with a 150 mile daily commute.

I'm sure I will have some questions at some point. reading through some things here I found that I have almost every one of the common problems(drivers door sensor, heater fan speed knob, rusted/broken trunk hinges). I picked the car up from a guy who didnt seem to take very well care of it so I'm hoping the important parts hold together. And as much as I was hoping that once the impreza stopped draining my pockets the Celica could become something, I now plan to restore it the best I can and possibly upgrade to something already all-wheel drive.

Pics to come.

hobbie2k
03-25-2014, 12:28 AM
Good luck and I hope it works out for you. I'm not sure the Celica will be that much better on fuel for you, but it's always nice to hear that someone wants to fix it up rather than drive it into the ground. Anyway, just about any problem you could possibly have has been discussed on here at some point and the members are pretty good at not being dicks.

Welcome.

The Captain
03-25-2014, 12:57 AM
Welcome!

42012rs
03-25-2014, 02:35 AM
Thanks!

The subaru with the grabbers gets about 21mpg highway. If the Celica can't beat that then I would say I did make the wrong choice haha

I am registering the Celica tomorrow and just gotta get some tires on it and a few bulbs in it and she'll be good to go.

What is the biggest tire that will fit on one of these? the car came with dangerously bald tires on 14" steelies and a set of unmounted snow tires that I will have to throw on for a few weeks and since my my cars have the same bolt pattern i was thinking of throwing the subarus tires/wheels(not grabbers!!) on it but they are 235/45r17. i don't think the 1.6 could push those 75 miles but it would get me on the road a day or two sooner if they fit. I really want to start putting some miles on this thing

crymson
03-25-2014, 07:12 AM
Welcome!

Maybe I'm just tired, but isn't the pattern on the Imprezza 01-now 5x114?

You should get better than 21 highway out of your ST, if you're not something needs a little work.

42012rs
03-25-2014, 09:57 AM
Welcome!

Maybe I'm just tired, but isn't the pattern on the Imprezza 01-now 5x114?

You should get better than 21 highway out of your ST, if you're not something needs a little work.

The 2005 and newer STi's have 5x114 everything else is 5x100 except maybe 08+ wrx's, they may have upgraded

Sent from my XT556 using Tapatalk 2

Lonestag
03-25-2014, 02:18 PM
You should be able to pull 35mph out of that thing on the highway as long the motor is in decent shape.

Get us some pictures!

42012rs
03-25-2014, 05:26 PM
I have averaged about 27mpgs with the subaru so that or better will be fine with me.

Something that worries me(aside from knowing this car has probably not been maintained well) is that the coolant temp gauge read cold for my 1 hour drive home and jumped up a couple tick marks now and then. This bothers me because i read a post about the gauge not working after someone over heated their engine. The coolant looks good and there are no leaks which makes me think loss of coolant could have led to the overheating and they just repaired the leak and have ran it since. Hopefully it didn't go down like that though and the engine will last a few thousand atleast until i get an h6 in the subaru.

I will really be going over and under the Celica this weekend. Sunday I just patched the quarter and checked fluids, wheel bearings, brakes and fuel/brake lines. I need to get my tires swapped on and I will change the oil then give it a decent cleaning. Once its nice and warm i plan on pulling the interior, fixing the rust and giving everything a good deep cleaning. The car just has a smell to it that i need gone, even though the guy i got it from masked it well with 'new car' fresheners.


Be a few days on pics... 7 day rule lol


Sent from my XT556 using Tapatalk 2

grimmythereaper
03-25-2014, 05:32 PM
welcome :)

42012rs
04-01-2014, 12:24 AM
I got 18 mpg(hard, let's see what she's got miles) over the first 64 miles I put on since I bought it, topped it off this morning again got just over 18 mpg over the same range driving efficiently. I replaced the air filter and also bought a fuel filter and pcv valve which I will put in this weekend unless I find time before then. I will probably be picking up a set of spark plugs tomorrow too. if I cant get the mileage up over 30 mpg the celica will have to go sadly

Also, finally got some pics and time to get them on the computer. Just a few for now and hopefully I'll have more progress on the car this coming weekend.

http://i1247.photobucket.com/albums/gg629/42012RS/Mobile%20Uploads/IMG_20140330_150931_zpse3fd109c.jpg (http://s1247.photobucket.com/user/42012RS/media/Mobile%20Uploads/IMG_20140330_150931_zpse3fd109c.jpg.html)

http://i1247.photobucket.com/albums/gg629/42012RS/Mobile%20Uploads/IMG_20140330_150916_zpsf2f4e5cd.jpg (http://s1247.photobucket.com/user/42012RS/media/Mobile%20Uploads/IMG_20140330_150916_zpsf2f4e5cd.jpg.html)

http://i1247.photobucket.com/albums/gg629/42012RS/Mobile%20Uploads/IMG_20140330_150904_zpsb7c89b0c.jpg (http://s1247.photobucket.com/user/42012RS/media/Mobile%20Uploads/IMG_20140330_150904_zpsb7c89b0c.jpg.html)

And the subaru how she sits now, I picked up 04 XT struts with springs over the weekend and will be making some big changes soon!
http://i1247.photobucket.com/albums/gg629/42012RS/Mobile%20Uploads/IMG_20140330_150844_zpse6adf3c8.jpg (http://s1247.photobucket.com/user/42012RS/media/Mobile%20Uploads/IMG_20140330_150844_zpse6adf3c8.jpg.html)





I suppose one "teaser" of grabbers at stock height

http://i1247.photobucket.com/albums/gg629/42012RS/utf-8Qaja7upav_zps2136acf6.jpg (http://s1247.photobucket.com/user/42012RS/media/utf-8Qaja7upav_zps2136acf6.jpg.html)

BabyBear
04-01-2014, 12:59 AM
The 2005 and newer STi's have 5x114 everything else is 5x100 except maybe 08+ wrx's, they may have upgraded

Sent from my XT556 using Tapatalk 2

All WRX's are 5x100, only Subaru's that aren't 5x100 are 2005+ STI's. I wish my BRZ wasn't 5x100 so I could run my old STI wheels..

Congrats on the celica!

42012rs
04-17-2014, 03:42 PM
Well, I have been too busy to work on the celica, waiting on a radiator drain plug right now as i snapped the head off mine. Tie rod and fuel filter have been replaced though so once I have the plug ill change the thermostat and coolant temp sensor. Hopefully i will get better mileage.

Especially since stage 1 of the subaru lift is done!

http://img.tapatalk.com/d/14/04/17/qu6eva6e.jpg

http://img.tapatalk.com/d/14/04/17/gy4agamu.jpg

Looks pretty tall beside the coworkers 2by Chevy haha

I should have some nice action shots this weekend!

Sent from my XT556 using Tapatalk 2

42012rs
03-15-2015, 02:06 PM
I'm having an issue that I hope has an easy fix, I haven't looked into it yet because it's been so cold and I have other cars to drive.

A week ago I went out to start the car and she wasn't having it. I can get it started but I have to hold the starter on for 20-25 seconds a few times while giving it some gas. Once running it idles fine. If I lightly touch the gas pedal it dies, press a bit further and it is fine, any further than half an inch and she bogs right down. It will hold speed on flat ground past the half inch but lose it on any hint of incline.

My first guess is vacuum, either a leak or sensor. It does have the engine light on since I got it started the first morning. My next guess would be plugs and then fuel pump or injectors, but I've been needing to run dry gas frequently since it got cold, so I have used Heet with cleaner. I'm going to check the codes first. Hoping it's not the map sensor as I pretty much have this car sold to a buddy for not much more the cost of one. Will be a bit before she goes as I have a motor for the Subie at the machine shop but it's going to be a while before it will come together.

I really wish this was a liftback. I'd keep it. I've put close to 30k on it this year and when it's running good I love it.

Shadowlife25
03-15-2015, 03:12 PM
Definitely pull codes first to get a general starting point. That is a lot of mileage for the year, not bad :D

42012rs
03-16-2015, 10:39 PM
So I got to the codes today, three flashes then one. Air Flow meter circuit. I have a Haynes manual and it says "best left to dealership" with no testing information. I'm going to look around here and see if there are any potential fixes without buying a new one but things don't work out like that for me usually haha

4thgenceli
03-16-2015, 10:53 PM
Typically code 31 is the MAP sensor wiring is problematic between the ECU & the MAP sensor. Check the plug on the MAP, check all wiring, look for breaks, disconnected wires, worn insulation, etc.