PDA

View Full Version : rev problem



ssj3timy
01-27-2014, 04:23 AM
hi,

Does any one know why my gen3 3sgte is revving until 5800-5900 rpm? I have changed the rotor cap, rotor, wires, spark plugs, checked vacuum, fuel pressure and every thing is normal.
My ignition mods are:

MSD SS coil
MSD 6AL 6425
MSD tach adapter
NGK wires
sparkplug IK20 (same problem)
sparkplug BKR7EIX (same problem)
New rotor and cap

There is no diagnosis code stored on the ecu and running on RON97.


http://www.youtube.com/watch?v=C9oS82K9QJ0&list=UUnm-ITdYpEwUQlAG_mQcjFg&feature=c4-overview

http://www.youtube.com/watch?v=C9oS82K9QJ0&list=UUnm-ITdYpEwUQlAG_mQcjFg&feature=c4-overview

MrWOT
01-27-2014, 04:38 PM
plugged exhaust

T-spoon
01-30-2014, 02:46 AM
plugged exhaust

Could be. If that's the case, should be having trouble building boost, too.. Does it feel like a hard cut-off, or it sits there working and just unable to rev any higher?

ssj3timy
01-30-2014, 04:15 AM
I checked and the exhaust pipe isn't plugged. The turbo boost at 15 psi without any problem but I can't reach the whole rpm. Maybe the 6AL is pre programmed to cut at 5800rpm.

T-spoon
01-30-2014, 07:27 AM
Does it actually feel like ignition cut/rev limit, or does it stay at a stable 5800rpm until you let off?

ssj3timy
02-02-2014, 01:56 AM
it definitely feel like cut/rev limiter

T-spoon
02-02-2014, 04:11 AM
I don't know much about the ignition setup you have, but if it's aftermarket and you're getting a hard cut at a particular RPM, that's where I'd start looking, especially if it didn't do that before the aftermarket was installed.

KoreanJoey
02-03-2014, 10:00 AM
Yes the 6AL has a programmable rev limiter. It's adjustable by two rotary dials that you can adjust with a small screw driver. I have a hi-6 on my corolla and it adjusts the same way.

KoreanJoey
02-03-2014, 10:04 AM
http://www.youtube.com/watch?v=HWLTgEOI1mo&feature=c4-overview&list=UUPxvUzyDAUDn6Ni9lOcJkIw

Notice the same sort of rev limit at 1:04?

KoreanJoey
02-11-2014, 10:18 AM
This get fixed?