PDA

View Full Version : 1992 toyota celica 5sfe gt idle issues



candice
12-14-2013, 12:29 AM
I have changed all vacuum lines, egr, idle air control valve, temp sensor, and throttle position sensor, My problem is when I first start the car and drive, it is fine, usually seems when the engine gets to a certain temp. when coming to stops it will idle up and down and then die out on me, then I have to crank the engine at a stop light like four times and then it starts back up again, so what I have been doing lately is driving the car with one foot on gas and one on the brake to keep it from dieing out on me. I took it to the guy at aamco and he is an idiot, he tells me the car drives fine, it also throws an o/d light code #62, anybody have any clues. thanks

Doowstados
12-15-2013, 12:23 AM
My favorite way to check for EGR related issues is to unplug the top vacuum line on the EGR valve. If the problem goes away then there is a chance your solenoid is bad or another VSV is malfunctioning. If that doesn't work, check for intake manifold leaks. Get a $2 can of carb cleaner, wait for the engine to start doing its thing and then spray the carb cleaner around where the EGR valve comes out of the block, where the EGR valve meets the intake manifold, around the manifold/head mating surface and around all your vacuum lines. While doing this if you notice the engine smooths out then you have found your leak.

In doing my own research I've come to find that the mating surfaces for the EGR valve are prone to leaking, I've seen a lot of EGR valve flanges cracked at the junkyard. Seems they might be weak.

candice
12-16-2013, 09:59 PM
thanks man, I am going to give it a shot and I will let you know if it worked out or not.

tony.
12-25-2013, 05:22 AM
I've got a very similar problem, when the car is warm, the idle surges a little, and if you were to stop the car and restart it soon after (i.e. drive it within say a few hours, such as a quick stop at a petrol station, etc), the idle will surge even worse, occasionally stalling.

For me it's the MAP sensor, yet to replace it. Try disconnecting it to test (just look to see if the idle improves).

candice
12-29-2013, 03:30 AM
The thing that makes it so frustrating is that the car only acts up on me when coming to a stop at a stop sign or stop light, so I cannot just get out of the car and pop the hood and run any tests on it when the idling issue happens, and even if I could, the other problem is the car dies on me anyways.