PDA

View Full Version : Wont start when engine is warm.... HELP



shazabf
08-30-2013, 11:21 PM
hey y'all i have a 1991 celica gt 5 speed, and it recently hasnt been starting up when the engine is warmed up. but when its cooled down alll the way it will start without a problem any ideas??

Doowstados
08-31-2013, 01:01 AM
Check your coolant temp sensor on the water neck, should be either the beige or green plug. I don't remember which one.

shazabf
08-31-2013, 02:19 AM
i replaced that 3 hours or so ago and still the same i also have replaced the efi relay nothing.. but my distributor is leaking pretty badly but its been doing that for a while

Doowstados
08-31-2013, 07:37 PM
Well, I would definitely fix the distributor leak but that's probably not what is causing your starting problem.

What does the engine do/sound like when you try to start the car? Does it turn over? Have you verified it is getting proper fuel pressure? Try disconnecting the vacuum line to the fuel regulator on the intake manifold and see if it starts with that disconnected. That should increase fuel pressure to maximum.

allTRACway
09-01-2013, 02:37 AM
Check and probably replace your inline fuel filter

ChrisD
09-01-2013, 05:30 PM
Well, I would definitely fix the distributor leak but that's probably not what is causing your starting problem.

What does the engine do/sound like when you try to start the car? Does it turn over? Have you verified it is getting proper fuel pressure? Try disconnecting the vacuum line to the fuel regulator on the intake manifold and see if it starts with that disconnected. That should increase fuel pressure to maximum.

Werd. Need more info. Then we can better help. :)

Sent from my HTC One using Tapatalk 4