PDA

View Full Version : Broken shift linkage



Ads28
08-08-2013, 02:00 AM
So I recently replaced my clutch n flywheel ... And upon test driving I noticed 1st n 2nd gear and extreme side to side play while in gear ... Yet 3,4,5 n reverse had the normal lil play I was used to ... So finally had some assistance to see what was wrong .. And I found the linkage on my trans is broken :(
http://i31.photobucket.com/albums/c392/Imprezaluver/image_zps1dbaf1f6.jpg (http://s31.photobucket.com/user/Imprezaluver/media/image_zps1dbaf1f6.jpg.html)

http://i31.photobucket.com/albums/c392/Imprezaluver/image_zps517da39c.jpg (http://s31.photobucket.com/user/Imprezaluver/media/image_zps517da39c.jpg.html)

http://i31.photobucket.com/albums/c392/Imprezaluver/image_zpse9f26638.jpg (http://s31.photobucket.com/user/Imprezaluver/media/image_zpse9f26638.jpg.html)

So I'm hoping that I can remove that whole "U" linkage set up there. And just replace that .. There's 1 and only 1 celica in scrap yard intown so hopefully I can salvage that piece off of it tomorro ... Wish me luck

4thgenceli
08-08-2013, 02:18 AM
You talking about that little square thing?

Sent from my SCH-I535 using Tapatalk 4 Beta

Ads28
08-08-2013, 02:55 AM
Yeah...it looks like it should be connected to the piece with the rubber boot ? or does It not ? haha

4thgenceli
08-08-2013, 02:59 AM
No it doesn't.

When you move the shifter up and down (1st, 2nd, 3rd, etc) that moves the transmission into gear which is the part connected to the selector (to the round thing). When you move it side to side, that moves the other piece. With slop in the play like that, chances are that little square piece is worn out (happens). You can rotate it 90 degrees to wear the other sides or buy a new one. No need for a whole new shift assembly.

alltracman78
08-08-2013, 03:02 AM
He's right.
Though from the pic it looks like the wear is on the shifter linkage and not the sugar cube.
Which is unusual.

Ads28
08-08-2013, 03:14 AM
Ah ok makes sense...but yea, I definetly need to change something haha, with this much slop, it makes shifting really difficult haha

http://i31.photobucket.com/albums/c392/Imprezaluver/th_IMG_1543_zps483cf549.jpg (http://i31.photobucket.com/albums/c392/Imprezaluver/IMG_1543_zps483cf549.mp4)

Ads28
08-08-2013, 04:14 PM
Well the scrap yard was a bust damn automatics so looks like ill be buying a new one ... Off to the lithia sub forum I go

KoreanJoey
08-09-2013, 11:16 PM
You don't need a shift linkage, you need the bushing.

Should be 90389-10009

As for the boot, you can just push it back onto the selector shaft.