PDA

View Full Version : code 25 help



celicatuner92
03-26-2013, 01:11 AM
Ok I have been trying to get rid of this lean malfunction CEL for some time now and I am at the end of my thoughts on what to do now. Car is a 92 GT with the 5sfe and the CEL only comes on under cruising conditions, but not when I am on and off the gas or putting my foot in it.

Things attempted to solve the issue:

Fuel system cleaners
Changed fuel pump
Changed fuel filer
Tried 3 sets of injectors and checked at 13.5 or so
3 different fuel pressure regulators, now running honda fpr with blox adjustable diaphram set at 50 psi
Ignition timing set at 9-10 BTDC
Changed disributor, distributor cap and distributor rotor
NGK plug wires
Different plugs
Changed ignitor
Changed MAP sensor
Checked and adjusted TPS, tried different TPS
Changed TB and intake manifold gasket
Added more groungs to the engine
Changed O2 sensor, and checked wiring
Changed IAT sensor
Changed coolant temp sensor


So after all this I am out of ideas on what to check or replace so if any one else has any ideas I would appreciate it.

Thanks

Bugs found the issue while we were at the dragon turned out to be the ground terminal into the tps plug was corroded and not getting full connection.

Luni
03-26-2013, 07:20 AM
It really only listens for the O2 signal when cruising so that doesnt really mean anything other than thats WHEN youd see the issue.

After looking at your list, there are 2 factors you dont mention

1) different ECU and
2) more likely - a wiring gremlin.

You familiar with a digital multimeter?

Ninja Edit...

Ive seen a faulty EGR valve (sticking open from carbon buildup) cause a code 25 as well. However, it usually has other codes that accompany it. But it is worth checking IMO.

SO it could be 3 issues that I can think of.

l0ch0w
03-26-2013, 04:05 PM
If it turns out to be a wiring monster, I can make you a patch harness...

Sent from my PC36100 using Tapatalk 2

celicatuner92
03-26-2013, 11:32 PM
Yeah I am familiar with a multi meter. Egr and all components have been removed so that leaves wiring or the ecu.

Any specific areas I should look. I checked the O2 sensor wiring when I changed that and I looked at the injector harness every time I pulled the rail out.

Luni
03-27-2013, 01:11 AM
Id ohm all wires on all applicable systems out and check for high resistance shorts.