PDA

View Full Version : Heater only works when I crank to highest setting and thump is heard



mikepl333
01-03-2013, 01:42 PM
2003 GT Celica

Hi there, I have tried searching on other celica forums and similar posts on this forum. I have never taken the console apart or heater components.

The heater only works when I crank it on full blast and turn all the way onto the hotest setting, like I am really forcing it to. ONce the thump is heard, I have hot air.

I can lower it after that, and it is fine.

If I shut it off after that and want to restart, I have to redo the same procedure.

I would like to try to fix this myself and don't have a garage (its in the single digitals here in RHode Island). I am coming to the experts here, since I don't really want to spend lost time shooting fof the hip.

Can anyone help me out with specific instructions?

It would be greatly appreciated!

The Captain
01-04-2013, 03:23 AM
Sounds like the heater control valve is sticking. It's on the firewall with a cable attached to it. Near the middle with two 1" hoses coming out of it.

mikepl333
01-04-2013, 03:37 AM
Thanks captain!

Do you suggest I replace the valve? Whats the easiest way to access it? I am hoping from the console..

The Captain
01-04-2013, 10:47 AM
I'd at least take it out and clean/lube it and see if that fixes it. I don't know where it is on a 7th gen but if Toyota is consistent, it's on the firewall in the engine compartment.

mikepl333
01-11-2013, 01:06 AM
I also heard a coolant flush may fix it. I never had a coolant flush it has 90k. SHould I get one anyways? The dealership said I should have one every 30k for an 03 celica. Is this true>

93celicaconv
01-11-2013, 01:43 PM
In 2003, most Toyotas still used the Toyota Long Life Red coolant (and the long life wasn't describing how long the coolant lasts, but rather how long the cooling system will last by using the Toyota red coolant). I believe the change period for this particular coolant is 2 years / 30,000 miles. If you are at 10 years / 90,000 miles now, I would have concerns. But if you ever had major service work done (headgasket replacement, water pump replacement, etc.), you would have had the coolant replaced then.

Facime
01-11-2013, 10:02 PM
I disagree on the valve diagnosis. The "thump" is more likely the blend door sticking. I dont know the '03 system at all, but I'd look into that as well. The valve is an easier fix I believe, so its a better place to start, but its easily disagnosed by simply feeling the hoses going to and from.