PDA

View Full Version : New member here .. I have a 88 celica ST 3S-FE with a few issues ....HELP



natural4reelz
12-22-2012, 08:39 AM
Unburned fuel issues...and have done tune up but the distributor cap bottom screw underneathe is not tight and just spins .....

I have surging, and no power upon acceleration..
rough idle at stop... ( intermittently..)
some days it smooth and the idle is perfect in drive ( at stop light ) but only for 2-4minutes and then starts back being rough...
I have very high cold start idle first then in the morning like 1300...
I have unburned fuel issues and have no power when accelerating... it feels like a banana is in the tailpipe.. ( easiest way to describe it)

ALSO... I recently had huge vacuum leak ( loud ) in the injectors were to blame... .. BUT when I HAD the VACUUM LEAk my ROUGH IDLE was GONE .. completely gone..

AS soon as I fixed the injector vacuum leak the rough idle came right back ....

Last thing ... i have 3 burnt/melt brake light lens and the housing their in are all melted...


also..
When i first bought the car i had electrical issues and the mechanic just did a short relay switch to the starter from the battery...:banghead:.............

sorry if this is all scrambled up info.... ..
ITS been awhile since i posted info on my celica isses..
Thank you...
Nikki Kole

Car_Barn_Bandit
12-22-2012, 08:54 AM
Do you have any smoking issues?

1000 rpm is normal at startup until the engine warms. Then 750 rpm is correct.

You also said a mechanic adjusted your MAF.

Lonestag
12-22-2012, 09:29 PM
It sounds like a timing issue to me. It sounds like your distributor housing is cracked or somthing. Easy to find and re-seal a used one. Maybe upgrade to removable plug wires from a similar year camry.

Being forced to put in a relay to make these cars start is extremely common. It seems to be a reliable fix though.

I'm not sure why a vacuum leak would cause the issue to aleviate though, might point to the original problem being in the vacuum system.

CollapsedNut
12-22-2012, 09:57 PM
I would like to know more about this injector vac leak. Do you know where exactly it was leaking?

If a vac leak fixed it, then I would assume your idle air control valve (IAC) is not working properly and not letting enough air through at idle, causing your rough idle.
Or maybe the Throttle Position Senser (TPS) is bad/out of adjustment.
Also with Lonestag, the rest of this could be an ignition issue.
I have a 3SFE IAC laying around somewhere you can try. The the thing on the bottom of your throttle body with an electrical connector and a buncha vac hoses. I should have a TPS also.

4thgenceli
12-24-2012, 06:11 PM
Yeah all the above :)

Check all your ignition connections and verify your timing is within spec (10 degrees BTDC at idle with the T-terminal shorted in the diagnostic box). Warm idle should be 650-750RPM, 550-650RPM with the E1 and T terminals bridged.

About your running rich issues, unburnt fuel and sluggish performance, this kind of points to the cold start injector acting up. Another thing is your exhaust may be clogged (failed catalytic converter or dead squirrel) leading to banana in the tailpipe feeling.

natural4reelz
12-25-2012, 12:18 PM
Hey... I forgot to mention last yr I failed smog and they told me i was running lean... ( long-story short ..$100 bucks and he adjust the screw and i passed smog..


Now.. I have 3 other stories..

1)... I had OBD 1 scan done and it coded me a (((( Code 43 ))).. === NO starter signal to the ECU.. .. and I never had it fixed and actually forgot.....

LOW FUEL PRESSURE 35PSI

and when I first bought the car i had electrical issues and took it my mechanic.. Decatur auto.... They either didnt have time to search for electrical short.. etc.. s..
so he put a SHORT RELAY SWITCH to the STARTER from the BATTERY.. and since he had done that i never got stranded again....
But the electrical issue is still lurking ..

NOW I have 3 brake lights housing and even the hole where the screw goes in to hold the bulb in place was melted and blk.

...i ansdwer some more issues below this box from other celica helper ... :)

Th

natural4reelz
12-25-2012, 12:49 PM
hate cigarettes... *** ha ha **
no my car does smoker..
or have any oil burning issues

just a gas guzzling &&(OY#%! car.. OMG.... god... I need the manual...