PDA

View Full Version : Kollanda's 93 gt2



kollanda
07-09-2012, 08:41 PM
Hello everyone, My name is John and i have been a celica enthusiast for a long time now. I currently own two 93 celica gt coupes. My experience with working on cars is not that great, i think the most challenging thing Iíve ever done is put an exhaust on an mr2. However i am an engineering student, so naturally i believe i know everything about everything. (I was so wrong)

This is my daily driver. Not much has been done with it other than new wheels, stereo, seats, suspension, and intake. There are probably a few little things also that i forgot about.

http://i1031.photobucket.com/albums/y373/jkollanda/littlered.png

My other celica i got for a good price because the motor was blown.
http://i1031.photobucket.com/albums/y373/jkollanda/Picture0619120950_1.jpg

so i decided to do something stupid and try and put this into it

http://i1031.photobucket.com/albums/y373/jkollanda/IMG_8141.jpg

An st205 wrc 3sgte, i was planning on doing a 185 swap but a problem arose from the dealer and i ended up getting this for the same price. So this was the start. after a bunch of complications at home, the car was sent to a garage to get the swap done. however after taking the old motor out and stealing it, then preceding to just wedge the new motor into the chassis i had to step in and take the car back to its home. luckily the new home had a garage for the beast to rest in.

http://i1031.photobucket.com/albums/y373/jkollanda/motorremoval.jpg
The 5s is basically out.

http://i1031.photobucket.com/albums/y373/jkollanda/motorin.jpg
And with the new 3s thrown in, after the engine bay was painted.

And here she is at home.
http://i1031.photobucket.com/albums/y373/jkollanda/PreCC.jpg
I started out easy by taking off the bumper for better access, and took out the ac. then i replaced the fuel pump with a walbro 255.
I knew that i would have to do something with the transmission so due to bang for buck i decided to modify the e154f into a 2wd trans. here is my new Quaife dif that i got
http://i1031.photobucket.com/albums/y373/jkollanda/Quaife.jpg
Because i didnít want to screw up something that important i decided to get it sent out and have a professional do it for me.
after a lot of work on the little things my new heat exchanger and pump came in for the chargecooler
http://i1031.photobucket.com/albums/y373/jkollanda/chargecooler.jpg
i decided to remove the latch for the hood to allow better airflow and weight reduction. i plan on putting a carbon hood on with pins anyway so i feel it was not needed. also i got a cs wrc bumper with support.
here you can see the new support with the chargecooler setup and the transmission cooler attached
http://i1031.photobucket.com/albums/y373/jkollanda/Picture0625120914_2.jpg
and a better picture of the pipework
http://i1031.photobucket.com/albums/y373/jkollanda/CCplumbing.jpg

The VIS hood
http://i1031.photobucket.com/albums/y373/jkollanda/photo5.jpg

a lot of work has been done, and there is still a lot to do. One of the biggest problems is sourcing parts for a 205 motor, also i really donít know what i am doing and am just learning as i go.
things that still need to be done: a lot more wiring, all those damn vacuum lines ( not sure which go to the anti-lag system that Iím not hooking up ), the intake, axels, and a lot more misc. stuff. sorry if the post doesnít come out great or the pics donít show. bear with me Iím also new to posting, but have been reading for a long time. also i would like to thank all of the members who have helped me out by getting me good deals on parts. if anyone has any advice i welcome it fully.

kurt95gt
07-10-2012, 02:24 AM
Looks like your off to a great start

Galcobar
07-10-2012, 05:13 AM
For ST205 parts, I suggest checking in with Lithia Toyota. It's a board sponsor with its own sub-forum, and its reps Aaron and Lisa are very good about finding parts which don't normally show up in the North American database.

MCcelica
07-10-2012, 06:43 AM
Welcome, thanks for posting pics. Looks like a fun project, but I'm glad you have the ability to recognize when you're in over your head. That is a skill I have yet to master.

kollanda
07-11-2012, 03:58 PM
thanks for the help, and Recognition. yesterday i purchased an intake pipe kit from autozone. its nothing special but i liked how it made things alot simpler to do, with this i also got a filter.
http://i1031.photobucket.com/albums/y373/jkollanda/intake.jpg
i test fited it yesterday and it looks like it should fit fine, ill have to get a pic of it mounted, but i have to find a way of mounting the battery first.

jdm_celica_gts
07-12-2012, 06:54 AM
Where did you get that motor? Looks super freaking clean!
Looks like this is gonna be a great project.

jaydog82
07-12-2012, 02:01 PM
Do not use spectra filters they will ruin your motor, also the intake pipe is not metal and can melt.

Sent from my MB525 using Tapatalk 2

jaydog82
07-12-2012, 02:02 PM
Other than that nice build.

Sent from my MB525 using Tapatalk 2

kollanda
07-12-2012, 02:25 PM
The motor is from importdirect, i think, i purchassed it so long ago so i forgot, but i will check into that when i get out of work. and jaydog, what exactly is wrong with spectra filters? i've never used one before but i dont understand how it would ruin the motor, also how sure are you about the pipe melting? thanks for the heads up, and if you think this intake is a bad idea i will return it later today.

jdm_celica_gts
07-12-2012, 10:02 PM
I had that filter and intake on my old gt convertible. Mine never melted but it didn't seem to work any better than the stock intake. A dirty k&n filter worked better than the spectra filter did.

jaydog82
07-14-2012, 01:27 AM
1: with a 3sgte you will have way more heat then a 5s, wile it may not melt plastic and high heat don't mix.

2: spectra lost a law suit from k&n their claims are totally unfounded and I have had problems with them and so have my friend on his subbie.

I would not use spectra if u paid me too. Get an aem dry flow or a neo filter.
Sent from my MB525 using Tapatalk 2

kollanda
07-23-2012, 01:37 PM
thanks for the advice guys. i have returned the filter and pipe, and am working on an new one with a k&n filter. im debating wether to move the battery and do a sraight pipe or just leave it with the 45. i think the latter choice will be the one i go with because its less work and creating a mount for the battery will suck. as an update, i had to remove the intake manifold and throtle body to clean it and that was a complete pain to do while the motor was in the car. and with all of the stuff underneath it for the water injection, i got confused and a little over whelmed by all of the hoses. but with that all remounted i am staring to put everything back together. i am pretty sure the fuel system is not all attached, also the power steering was hooked up without the resevior. but the cooling system is all hooked up with the intercooler and everything. But now it is time for some help. i dont know where some of this stuff goes
http://i1031.photobucket.com/albums/y373/jkollanda/Picture0718120711_2.jpg
this is the first hose coming off the top mount.
http://i1031.photobucket.com/albums/y373/jkollanda/mystery2.jpg
along with these two.
and finally (for now) i got these two lines coming off the body that im not sure about along with what i think is a filter for the fuel (circled in blue) if i can get some help as to what gets attached onto these, it would be greatly appriciated.
http://i1031.photobucket.com/albums/y373/jkollanda/mystery1.jpg
Thanks for the help guys and im sorry if some of these questions seem stupid. like i said before i have basically no automotive backround aside from reading celica books and forums like crazy.

The Captain
07-23-2012, 02:14 PM
http://i1031.photobucket.com/albums/y373/jkollanda/Picture0718120711_2.jpg
Goes to a plastic reservoir bottle that mounts to the strut bar on a 205.

http://i1031.photobucket.com/albums/y373/jkollanda/mystery2.jpg
Looks like the factory BOV. That vacuum T fitting doesn't look factory. Maybe they had a boost controller. Somebody will chime in I'm sure.

http://i1031.photobucket.com/albums/y373/jkollanda/mystery1.jpg

One is the fuel return line. The other goes to the charcoal canister.
The blue circle is the fuel filter. A larger hose with a big banjo fitting goes from there to the fuel rail. It's a high pressure hose.

"Thanks for the help guys and im sorry if some of these questions seem stupid. like i said before i have basically no automotive backround aside from reading celica books and forums like crazy."

Not stupid questions. If using search doesn't find your answer, well, that's what we're here for.

Galcobar
07-24-2012, 03:28 AM
And kudos for posting a picture of the mystery parts.

kollanda
07-24-2012, 06:26 PM
thanks for the help captain. and your welcome galcobar. So i guess i should remove the T fitting? i dont think there was a boost controller attached because the motor should have come out of a stock 205. unless it has something to do with the anti-lag system that i know nothing about lol. also the charcoal canister is in a pile of parts right now. is it true that i dont need it, and if so do i just plug up that hose.

underscore
07-24-2012, 08:47 PM
The anti-lag can't be made to work on the street cars, last I checked anyways. TTE never let us civvies have the parts needed to make it function.

kollanda
07-27-2012, 02:40 PM
An update: i've still been working on the little things, like wireing, all the vacuume hoses, the power steering, installing the boost controller and reparing the ole in my floor.i also had to create a new battery mount because i wanted it moved back a little more and i also wanted it more secure. so here is a pic of it unpainted.
http://i1031.photobucket.com/albums/y373/jkollanda/Batterymount.jpg
Also due to the insight of the member i purchased a new K&N filter and i a 45 degree exhaust pipe to use for a new intake. im still not to sure if i want to keep the exhaust pipe or go and order a propper pipe. but here is the picture anyway
http://i1031.photobucket.com/albums/y373/jkollanda/newintake.jpg
i will update with some mounted pictures early next week. i have trouble focusing on one task at a time so i bounce around alot, thats why i work on so much but dont have much done yet.

spitfiremk16
07-27-2012, 05:31 PM
Looking good! Happy to see you got an rc hood to match that rc bumper! For the intake i would sand it down and paint it, no one will tell its a parts store exhaust pipe, theyll think it was a custom built cold air intake!

kollanda
08-01-2012, 01:18 PM
so here is the picture of the mounted intake and the battery in the new position
http://i1031.photobucket.com/albums/y373/jkollanda/intakemounted.jpg
i still need to drill some holes into the intake to attach some stuff. If anyone knows exactly what needs to go into the intake pipe that would cut down some time on research. Also my baby showed its first sign of life in about 2 years yesterday as the lights came on, along with a few other little things. i know its not much but it was surely an exciting moment for me.
http://i1031.photobucket.com/albums/y373/jkollanda/life.jpg

4thgenceli
08-01-2012, 03:20 PM
I'm not sure on the 205, but on my 215 I have an IAT sensor (intake air temp) and the PCV that are pre-turbo. I drilled some holes and stuck the grommets in there.

I know what you mean about being happy when the lights turned on, I was thrilled when I sat in mine, turned the key and the motor turned over (didn't start but it was turning over). Made my day. Then I knew that my wiring and battery relocation was all OK and the motor would turn at least heh.

zen
08-05-2012, 08:52 PM
the T fitting from the vacuum line connects to the second port on the bov. there is suppose to be a one way check valve on the allowing only vacuum to that port.

kollanda
08-22-2012, 07:03 PM
thanks for the info, sorry it has been a while since ive updated but i have been too busy to get much work done aside from patching the passanger side floor. (zen) do you know what the valve looks like or where i could get one? also my biggest problem right now is still the wiring, if anyone knows which wire is which from the 205 harness, that appear as if they are supposed to go into the fuse box by the battery? or if anyone knows where a diagram is that will tell me. i have looked everywhere
http://i1031.photobucket.com/albums/y373/jkollanda/Picture0822121115_1.jpg
also the wires coming out of the fuse box from the 5s
http://i1031.photobucket.com/albums/y373/jkollanda/Picture0822121115_2.jpg
i am pretty sure i have to use the old fuse box, correct me if im wrong though. Finally there are a bunch of wires in the cabin from the engine harness that do not go into the ecu, i am fairly certain they are supposed to go the random plugs from the body that are in the footwell also but i can not find the pinouts for those plugs or a colored diagram for the harness' wires. help would be great. i've checked all over the web already.