View Full Version : Aftermarket head unit won't turn on

05-03-2012, 07:07 PM
Hi! I'm new to this forum and actually registered earlier this week, and somewhat have a solution to my own question now that my account has been verified, but I figured I'd post up anyway...

I have a 93 All-trac that I've been working on all winter. I'm just a couple hours away from having it running as soon as I find time to get to it.

But anyway, car was completely stock with the original double-din system 10 stereo. As part of my upgrades, I replaced the stock double din stereo with a 3-gauge single din panel (added boost, wideband, and EGT gauges), and to go with that I also replaced the head unit with a single din Sony unit I got from Crutchfield.

I had Crutchfield include the Toyota pre-amp harness that they swear doesn't fit the car (but of course, it seems to be common knowledge that it does). Anyway, wired in the head unit (battery, acc, att, and rem (to amp). Seemed pretty straight forward. I turned on the head unit to test it out, everything seemed to work great.

The problem is when I hit the source button on the new head unit to test it, it killed the power to the head unit. Also, the stock amp began clicking. I popped the new faceplate off, put it back on, and boom, back to normal. Except that the head unit is stuck in a non-stereo source mode so now it won't play anything. Again, as soon as you press source (or call, which effectively does the same thing), power dies and the amp starts clicking.

Just to make sure I didn't blow something up on the amp, I reconnected the oem head unit and it seems to work just fine (I have no idea why it didn't ask me for a security code, but I'm glad it didn't). Anyway, sony head unit back in, and same issues.

I talked to Crutchfield's technical department and they were stumped too. They are sending me a new head unit and a calltag for the old one. It should be here either tomorrow or Monday so I can test it out.

I guess the main reason I'm posting is backup ideas if the new head unit doesn't work either. I figure it doesn't hurt to ask the gurus on this board while I'm waiting on the new head unit to arrive. Any thoughts?

05-04-2012, 01:44 AM
Double check your wiring, make sure you have no exposed wire, and that the wires from the stereo harness are joined to the correct wire on on the toyota harness. That would be my suggestion anyway.

05-04-2012, 06:14 AM
Yeah, I checked all that. No exposed wires either. Everything was nicely heat shrunk. Also, did the testing with the radio still out of the dash, just connected to the harness.

05-04-2012, 07:22 PM
Continuity testing on the wires I assume? otherwise probably just a bad head unit, it happens.

05-04-2012, 07:40 PM
Actually I didn't test the continuity on all the wires. I suppose it doesn't hurt to try that. Although if there was a bad connection somewhere (which i highly doubt, since I soldered everything nicely), I still don't see how that would cause the symptoms I'm experiencing.

If I get around to testing the continuity before the new head unit gets here I will, but I have a feeling that it is just that...a bad head unit.

On another note though, the car ran for the first time since August last night! Unrelated to the subject at hand, but I went from a very clean stock 93 All-trac to a fully built bottom end, CT27 turbo, ATS ECU, etc. Had my fingers crossed on start last night that I did everything correctly (that's always a fear when you build an engine LOL), but it seemed to run well except for a coolant hose leaking somewhere that I need to fix. Excited to be back running. Once I get the stereo thing figured out I can button up the interior and be done! Should be around 275 whp once it's broken in I'm guessing, which should make a very fun and reliable track car to beat on, yet still very streetable :)

05-13-2012, 08:08 AM
When in doubt, pull it out.

Pull the headunit out, and disconnect the red switched, yellow constant, and black ground wire from the PnP harness and use a battery charger to test whether it will switch sources or not. If it powers up with a battery charger, test to see if you can even switch sources. If it wont switch sources with a battery charger, chances are somethings wrong with the headunit.

So, just so I understand, youre running an aftermarket headunit with the stock amplifier in place?

05-13-2012, 02:51 PM
Make sure your using or connected the right rem wire to the deck. If its not the right rem (normally blue with white strip) then it also won't turn on.

Neglect this. Didn't read the post. Haven't heard of this before. Personally I just go aftermarket for Amps. Better power output :)

Sent from Qbabys Tapatalk.

05-15-2012, 03:30 AM
I appreciate the replies and advice. However, as it turns out, it started working.

I had done all of this to the car without the engine running because I was still working on it. However, once I started the engine for the first time, all the sudden the radio turned on and was working. Now it works just fine.

I'm not sure if it just needed the kick of power from the alternator to click it on or what, but it seems to be working just fine now. Weird.

Thanks again...now onto other issues which are more under-the-hood related (luckily nothing major, just a few things I need to fine tune).

05-15-2012, 03:33 AM
If it took the extra voltage from the alt to get it turned on you better check for resistance on power and ground. It should work off 12V just fine.

05-15-2012, 03:41 AM
If it took the extra voltage from the alt to get it turned on you better check for resistance on power and ground. It should work off 12V just fine.

It does work off 12V now just fine. It's like it was stuck just that one time turning on the amp.

I don't know, can't explain it...but the bottom line is it works now like it is supposed to.