PDA

View Full Version : Restore and Transform: 89 Celica GT



Zaluss
09-22-2011, 08:03 AM
This has been my ongoing project for the last few months. During this time I've went from absolutely no prior knowledge about vehicles to having quite a bit more respect for the profession. Shortly after picking up this car for about $900, I went on to find out the heater didn't work. After being quoted very high amounts to replace the heater core, I decided to do it myself. Spending a few hours searching online, I stumbled onto various forums related to my car and specificly, ST162.net. There I found a specific thread on how to remove the dash so I went ahead and proceeded with that.

Success! I reached the heater core after hours of beer and cursing. Then, after removing the heater hoses from the engine bay, I extracted the core and replaced it with a brand new one from O'Reileys. Overly excited, I reattached the heater hoses, refilled the coolant in the car, and away I drove to the DMV to finish the title change.

Next thing I know as I pull into the DMV is that my car started to overheat. As I get out and look under the car I see my coolant GUSHING out from underneath. Not good. I popped the hood open to see that not only did I loose all my coolant, apparantly I didn't properly seal the heater hoses and it was leaking at the firewall. Being the noob that I was at the time, I refilled the coolant after the engine cooled and attempted to drive it home to fix the issue...

Several miles later the car stalled, steam blew out of the cabin vents, and smoke poured from the exhaust. Head gasket was done.

Again, despite everything, I decided to fix it myself. I mean...how hard could it be right? Picked up a Haynes manual and the internet at my side, I managed to do a head gasket job in my garage. $600 in tools and a few hundred in parts later I had done the following:

Head pulled, milled, hot tanked, and valves checked at a machine shop.
Properly cleaned all the old gasket material off the intake manifold and exhaust manifold off the head.
Cam seal
Water pump
Timing belt (failed on that twice before I got it right, thank god for non-interference)
Ignition coil
Dist cap/rotor/spark plug wires and new spark plugs
New alternator and power steering belts.
Removed EGR system and cleaned it out, cleaned out carbon buildup in the intake.
Ran Seafoam through the brake vacuum lines.

After all that the car started up and ran great! But why stop there? I did a whole lot more...

New front rotors/brake pads.
Rebuilt and greased calipers.
New 17" wheels.
New passenger CV joint and inner tie rod boot.

And of course some cosmetic stuff...

Fixed major crack in spoiler, bondo and repainted.
Repainted front bumper.
Like new GTS seats from the yard.
Dyed lower dash black and center console.
New deck.
New pod filter for kicks.

I unfortunately still have some issues I need to take care of and I'm having a hard time diagnosing.

1) CEL Code 26. Running rich. I can't figure this one out. I've replaced the o2, ran injector cleaner, replaced air filter. I may have screwed up the vacuum wiring but I'm not sure.

2) I still have a small valve tick from underneath the valve cover. Nothing series as far as I've read but annoying none the less. Doesn't change in frequency between revs.

3) Awful oil leak. I leave oil puddles wherever I park and I can't find the source of the leak. I've washed the engine down with simple green and started her up and just find the oil running down the center and dripping down but no source. Nothing by the timing belt cover area, distributor area, oil pan...nothing. I'm sure its oil as my oil level drops.

And whats a project without photos?

https://lh3.googleusercontent.com/-AgRPLcj2ppo/TlxzDnmgWYI/AAAAAAAAAHk/NibsSf5JLbE/s640/2011-08-29%25252022.05.37.jpg

https://lh5.googleusercontent.com/-Mc9pZcLLGGk/TlxzVbqLvaI/AAAAAAAAAHg/in5LmXE5Bu8/s640/2011-08-29%25252022.04.58.jpg

https://lh3.googleusercontent.com/-diKxJL7YoJ0/TlxzMpmYetI/AAAAAAAAAHU/dx4phvKF094/s640/2011-08-29%25252022.05.17.jpg

The oil leak...
From what I can tell it runs down the center beam and drips down here.
https://lh3.googleusercontent.com/-qC0bgKwPIio/TmheOyMriwI/AAAAAAAAAIA/zR6P9_f6lrM/s640/2011-09-07%25252023.16.59.jpg

And the resulting puddle after a short drive...

https://lh3.googleusercontent.com/-UT8ikRVOoLE/TmheUy9r8EI/AAAAAAAAAIE/3PY-yXyMkWY/s640/2011-09-07%25252023.16.36.jpg


New GTS seats

https://lh3.googleusercontent.com/-TIeVq232EDY/Tm8S78zUPNI/AAAAAAAAAIU/D2yGEkH0uCM/s640/2011-09-13%25252000.53.57.jpg

Pre interior facelift.

https://lh3.googleusercontent.com/-beS0sFPjWmE/Tm8TDPUnKpI/AAAAAAAAAIs/tAq6P_YXzeo/s640/2011-09-12%25252021.50.28.jpg

Out comes the seats, center console, etc. Going to be repainted black for a more stock look and match the seats.

https://lh3.googleusercontent.com/-if5iUyl4bSU/Tm8S6kPZwdI/AAAAAAAAAIQ/RsK4uOjdiPM/s640/2011-09-13%25252001.00.43.jpg

Picked up some ST165 doors panels locally to match the seats. Heres the stripping of the old.

https://lh5.googleusercontent.com/-pBhVsmTHV10/Tm8TA7CSHZI/AAAAAAAAAIk/rG91KLJAKqw/s640/2011-09-12%25252022.18.22.jpg
https://lh6.googleusercontent.com/-EgikbNeWV4Y/Tm8S_1JPGtI/AAAAAAAAAIg/cwCGRQNsKgY/s640/2011-09-12%25252022.18.45.jpg
https://lh3.googleusercontent.com/-0dFVxQcVaf4/Tm8S-V0KpBI/AAAAAAAAAIc/iBPAt39xATM/s640/2011-09-12%25252022.19.01.jpg
https://lh6.googleusercontent.com/-RT0E586HaEo/Tm8S9CMSZXI/AAAAAAAAAIY/sxNUQhVajE4/s640/2011-09-12%25252022.19.28.jpg

https://lh6.googleusercontent.com/-Rf7LetYnj00/TnLIAd1GI1I/AAAAAAAAAJA/7-NsruocekI/s640/2011-09-15%25252020.36.30.jpg
https://lh6.googleusercontent.com/-ea1VgOrl5gg/TnLH-fCygfI/AAAAAAAAAI8/KT3DUAbmm4w/s640/2011-09-15%25252020.36.47.jpg

Some bad cell phone pics of the gts seats installed.

https://lh5.googleusercontent.com/-46F8bcbYv2k/TnLH8plcryI/AAAAAAAAAI4/o1fo8rMOaiQ/s640/2011-09-15%25252020.37.08.jpg

New shifter. Broke my original one during the seat installation by tearing the shifter apart with the seat rails. Bought a replacement at autozone until I can find something better.

https://lh5.googleusercontent.com/-iB6RSV2gUqU/TnLH6pqgheI/AAAAAAAAAI0/8RW0caS5fhk/s640/2011-09-15%25252020.37.33.jpg

Painted the center gloss black and the little coin holders primer gray.

https://lh5.googleusercontent.com/-wIr5uZWiYRU/Tnk0b0D44gI/AAAAAAAAAJ0/WJO8FJdXoVU/s640/2011-09-20%25252017.41.19.jpg

Spectre cheap pod filter. Had some store credit so I used it on these. Has a nice whurrrrr sound to it. Old air filter was dirty anyway.

https://lh3.googleusercontent.com/-5fQyvxmuH6Q/Tnk0Ydz01rI/AAAAAAAAAJs/-SM6SSakEBs/s640/2011-09-20%25252017.41.57.jpg

Motegi Racing 17x7. Feels nice but now I think I need it a bit lower.





Sent from my Transformer TF101 using Tapatalk

UtahSleeper
09-22-2011, 04:52 PM
Very nice story and pics.

On the oil leak, have you felt around the valve cover, near the intake manifold?

Also, have you felt around where the head meets the block?

4thgenceli
09-22-2011, 05:10 PM
Tracking down the oil leak can be a bitch sometimes. What I would do (as it's worked before) is before the next oil change wash the engine & get all the old oil washed away. Add some dye (similar to the AC/coolant stuff they use to track those leaks) to the oil. Take it for a quick drive and then park it. When it cools off you should find your leak.

The ticking under the valve cover really is not a big concern. It is just your valve lash. $25 tool, $15 in shims and an hour and the tick is gone. My '87 GTS did that, the '89 GT did it as well.

As far as running rich check all your vacuum lines. After I did the head gasket on my '89 GT I too ran rich for a bit. Turns out the air intake tube was cracked and air was sneaking in past the MAF.

Nice car, keep it goin!

Zaluss
09-22-2011, 05:49 PM
Thanks for the replies. As for the oil leak, I've checked and rechecked the valve cover. I do see oil all over the backside of the engine. If oil is leaking from where the head meets the block does that mean I have to redo the entire head job?

As for the running rich issue, the Haynes manual didn't mention anything about the air intake tube thats mounted underneath the intake manifold so I'm not even 100% sure I assembled that correctly. I have two vacuum tubes going to the power steering pump and the other two are connected to the back of the intake manifold.

Sent from my Transformer TF101 using Tapatalk

4thgenceli
09-22-2011, 06:05 PM
When you installed the head, did you follow the torque-down steps provided? Could just be that the head isn't torqued down properly. Regardless I would rip & redo the HG personally if that is the case.

Zaluss
09-22-2011, 07:04 PM
Yes I bought a brand new torque wrench and used it only for that. I torqued to what both the Haynes manual and Toyota manual stated. I believe it was 49ft-lb or something like that using new head bolts. The only reason I'd rather not rip it apart again is because I'd have to pull the cams out as well and that was a pain to do. However if its really the case I have no choice.

Sent from my Transformer TF101 using Tapatalk

4thgenceli
09-22-2011, 07:30 PM
Did you follow the pattern for the torque-down? (inside-out criss-cross)

Zaluss
09-22-2011, 08:00 PM
Yes. Exactly as its shown in the haynes manual in 1/4 turns each.

Sent from my GT-I9000 using Tapatalk

UtahSleeper
09-22-2011, 10:29 PM
I was thinking maybe there was some debri left on the black as the head was cleaned, but I assume block left on.

I would park it, wipe the back, start the car and watch. That type of leak should be pretty noticeable while idling.

And good job taking on a big job early on. The biggest job I have done to this point is a damn timing belt. Dreding doing my first HG.

Zaluss
09-26-2011, 09:57 PM
Small update here. I've noticed I have a pretty nasty exhaust leak and I also need to take a look at the cat so I pulled both off today.

https://lh6.googleusercontent.com/-sfzhcQSEOz8/ToDlfsc3CqI/AAAAAAAAAKU/jrahlkscdqg/s640/2011-09-26%25252013.48.47.jpg Manifold and cat off.

https://lh6.googleusercontent.com/-GKeICi_6VEc/ToDljdzopBI/AAAAAAAAAKc/E2rrQiB8nFg/s640/2011-09-26%25252013.48.03.jpg The cat. I'm not sure how to judge a cat but that doesn't look good.

https://lh4.googleusercontent.com/-DnSdH8px6Ug/ToDlh2Y47HI/AAAAAAAAAKY/cqogtx7ma_Y/s640/2011-09-26%25252013.48.31.jpg Bad exhaust leak.

So I've been looking around for a replacement cat and the shops want excess of $600 just for the cat itself! Crazy. One shop suggested I gut the cat below the manifold and just have the rear cat replaced and that should pass emissions. Anyone else in California care to chime in on that suggestion?

Sent from my Transformer TF101 using Tapatalk

Tecker184
09-27-2011, 02:56 AM
looks normal for a cat. If the honey comb was plugged up or was melted it would need to be replaced.

Zaluss
09-27-2011, 03:32 AM
Well if its normal looking ill reinstall it. I cant pass smog and ive ruled everything out except the leaking and the main cat. Maybe the aux cat is done?

Sent from my GT-I9000 using Tapatalk

Zaluss
09-28-2011, 08:59 AM
I believe I have found the oil leak(s). I've ripped the car apart to find two things:

1) A line of oil leaking from the distributor. Looks like I need a new distirbutor o ring? I didn't find any oil inside the dist cap.

2) Front main? I pulled the timing belt cover off to see if oil was leaking from the cam seal I installed but no oil there so I worked my way down to find an interesting oil spray pattern on the fender wall. Also the entire area around the power steering pump and pulleys are covered in oil, leaking down to the passenger side of the oil pan gasket. The oil travels along the base of the engine mount to the center where it pools and drips down. I assume this is the same with the distributor. I'm not 100% sure on this yet but I cleaned out the area with simple green and after I fix the distributor and reattach my exhaust manifold (or buy the one from st162rocket and use that) I'm going to run the car with the timing belt cover off and see if the oil is leaking there. If so, I'll be doing the crank seal and oil pump. Not too difficult.

Also I'm still trying to source parts for my manual swap. From there I'll do the rear main while I have the transmission dropped.

Heres some pictures of the leaky areas.

https://lh4.googleusercontent.com/-s1qSy_GCFQM/ToLPK16ehYI/AAAAAAAAALg/yL_sxb8dq6o/s640/IMAG0580.jpg

Where the engine mount bolts was covered in oil.

https://lh5.googleusercontent.com/-I4nNK2ZRoNY/ToLPIEnq8PI/AAAAAAAAALY/3rN5TaD9x_s/s640/IMAG0582.jpg

Oil.

https://lh5.googleusercontent.com/-ZlNZeaAeP8k/ToLO6khgwRI/AAAAAAAAAK4/IvKP6uQNLXg/s640/IMAG0590.jpg

More oil.

https://lh5.googleusercontent.com/-tw2PBJoBEqM/ToLOw5YjzGI/AAAAAAAAAKk/nlLDBuC0Uu0/s640/IMAG0595.jpg Distributor cleaned and ready for reinstallation. I need to replace the o ring but I can't find the part # anywhere for it. Any ideas?
Sent from my Transformer TF101 using Tapatalk

Zaluss
02-04-2012, 05:55 AM
Quite a bit has changed since my last post and I forgot I have a project thread here.

Lets revive this long forgotten thread with some new pictures!

https://lh4.googleusercontent.com/-NZVXRzL4bXk/TycGHoNKRaI/AAAAAAAAAZ8/bEMNyxyeUHY/s640/IMG_20120130_112433.jpg

Cleaned and refreshed the engine. Replaced the VSV with a junkyard one. Added a few more grounding points and preparing for the Big 3.

https://lh3.googleusercontent.com/-6zR5OkV3juU/TycGQTRygVI/AAAAAAAAAaE/yvWHnIyWW78/s640/IMG_20120130_112423.jpg

Brother in laws garage. Had to fix a few rain leaks in the interior. Found water under the passenger seat, underneath the antenna area, etc. Hopefully fixed all. Didn't see any rust though. Resealed the rear hatch also.

New gauge lighting.

https://lh6.googleusercontent.com/-mAtP_w0SRM8/Tydy6G8qQJI/AAAAAAAAAaY/BfF3oaHqZEs/s640/IMG_20120130_202827.jpg
https://lh6.googleusercontent.com/-s4XVhTP068o/TydywUGF1tI/AAAAAAAAAaQ/RNgsth4hJKA/s640/IMG_20120130_202835.jpg

https://lh3.googleusercontent.com/-KspbijbyAjs/Tyr_mQRnWHI/AAAAAAAAAa0/jcDRHUFNfNQ/s640/IMG_20120202_130031.jpg

Put on original emblem vs the prefacelift. You can see my girlfriend's Honda behind my car.

I took a quick video of the jumpy RPM issue i've been getting.

http://youtu.be/MrTPyeDOXps

You can see between 30-35mph when I let go of the throttle the RPM bounces around 1k and I can feel it jerking the car back and fourth. This happened after I replaced my cracked radiator.

Car wash deserves new pictures

https://lh4.googleusercontent.com/-ZbKzKzAMcpw/TyyZwViGLRI/AAAAAAAAAbU/buHO1oBk0ak/s640/IMG_20120203_173004.jpg
https://lh4.googleusercontent.com/-T23TugmfRiw/TyyZtxLQj-I/AAAAAAAAAbM/64hSmGacOAI/s640/IMG_20120203_173108.jpg
https://lh5.googleusercontent.com/-0I5N_i1wzco/TyyZ0_3FNfI/AAAAAAAAAbk/Mbqha7R2yLA/s640/IMG_20120203_172856.jpg
https://lh6.googleusercontent.com/-Rsj70x0aY9g/TyyaHeOwWpI/AAAAAAAAAbs/TRLNI09_Fz4/s640/IMG_20120203_172844.jpg
https://lh6.googleusercontent.com/-FwsoiTUeP10/TyyaPpoPAGI/AAAAAAAAAb8/h7rhVTyRRYY/s640/IMG_20120203_172724.jpg

black_celicagti16
02-04-2012, 01:51 PM
Looks great!!!I like that garage pic a lot!

The Captain
02-04-2012, 02:53 PM
I replaced the cat on my folks 5S from Toyota and it was only $175. Nice job!

Zaluss
02-04-2012, 07:59 PM
Thanks guys! I just arrived here in Washington and I'm about to move into my new place in Tacoma. Still have lots of work to do.

The car has seen quite a bit of overhaul since my last update. New cam seals, front main, oil pump seals. Still have a nasty rear main leak but I don't have a place to drop the tranny yet. I've decided to wait until I get all the parts for the manual swap sent here from AZ from the parts GTS car I picked up there. It has a 3sge with low compression in #2. Once the parts get here ill pick up a used 3sfe manual tranny locally and go from there.

Sent from my SGH-I777 using Tapatalk