PDA

View Full Version : LED instrument cluster



Masani
07-09-2011, 09:01 PM
I've replaced the six large bulbs in my instrument panel with blue LEDs, but for some reason only one or two will light up at once. I thought it was a loose connection, but I checked and they seem fine. Is the requirement for the LEDs too great? Or perhaps more modification is required, or maybe I should use less LEDs in the panel? halp

93celicaconv
07-09-2011, 09:25 PM
Do you have the dimmer switch adjusted to something other than full brightness?

Masani
07-09-2011, 11:06 PM
Nope, and if I touch the dimmer when it's all lit up it shorts, or something, they all go out. Maybe one will remain on.

93celicaconv
07-09-2011, 11:14 PM
And all the other illumination lamps work properly with your dimmer switch (radio, HVAC, etc.)?

Masani
07-09-2011, 11:38 PM
I have none of those. But the cluster lit up fine before I put the LEDs in.

Max Vador
07-09-2011, 11:42 PM
Did you use the right kind of LED's? Non dimming LED bulbs won't work unless you bypass the dimmer. Use these.

http://www.superbrightleds.com/cgi-bin/store/index.cgi?action=DispPage&Page2Disp=%2Finstrument.html

Masani
07-10-2011, 05:25 AM
Hmm, would a bypass be advisable? These things are bright when they're all on.

Max Vador
07-10-2011, 11:06 AM
I'd advise getting the dimmable LEDs from that site. Having them very bright at night is very distracting and they can give you a headache

93celicaconv
07-10-2011, 03:33 PM
If you don't have dimmable LED's, then anything less that full battery voltage will cause the lamps to go completely out. The more expensive LED's have dimming capability. So, unless your current LED's are of the dimmable variety, they will either be fully on or fully off. It all depends upon if you bought the kind of LED's to operate the way you want them to operate or not.