PDA

View Full Version : LOL new but not new...



timmy2
06-21-2011, 04:12 AM
Posted here a couple of years ago, got busy. parked car.
1988 Celica GT convertible with 128K miles, restoring for my son.
New top, new paint new cv's new ignition parts etc. I've restored lots of vehicles over the years, '55 & '56 chevy car and truck, working on '69 442 convertible and this one currently.
I do all my own work, have for 30 years.
Rough idle on the Gt brought me here. Runs like a top otherwise, pulls strong, burns no oil, no discernable vacuum leaks.
Oh well, off to search the forums....

MCcelica
06-21-2011, 06:11 AM
Welcome back. Care to enlighten us on some of the other work you've done?

Hookecho
06-21-2011, 02:13 PM
Howdy

timmy2
06-22-2011, 06:21 AM
So far I've replaced the top, headliner, ignition wires, plugs, cap, rotor, water pump, idler pulleys, timing belt, p.s. and alt belts and heater hoses, CV joints, steering boots, PS hose, distributor coil, throttle position sensor. Gone through emissions, replaced fuel filter, ordered BVSV valve for charcoal can as it was snapped off when I got it and vacuum hoses plugged to and from. I'm looking at replacing all vacuum lines to see if that fixes slight stumble in idle. Next would be to get cam clearance adjusted (wish I had the shims, I've done them on vw's)
Ordered motor mounts today, adjusted idle, she's running good considering it's been mostly parked for the last 4 years. Suspension and dampening(shocks, struts etc) as needed are next.
AC needs fixing, but hey it's a convertible in Oregon....usually cool enough with top down.
How's that for a list?
Oh yeah, complete new white paint job from Maacco after neighbor backed into rear quarter last year. They paid cash to fix, I stripped car and had a quicky repair and spray done. Looks good from 5feet.
:amuse:

MCcelica
06-22-2011, 07:32 AM
Lol good summary... I was just hoping for pics of the '69 442. :D

UtahSleeper
06-22-2011, 05:58 PM
Lol good summary... I was just hoping for pics of the '69 442. :D

+1

Plus the other projects :)

Galcobar
06-22-2011, 11:31 PM
Checked if the EGR is stuck open -- I'm currently looking at that as a possible culprit for my rough idle.