PDA

View Full Version : sub frame



LittleMissAllTrac
04-06-2011, 09:08 PM
Hoping I can get some help here.
I'm not sure of the part name, so please forgive me if you don't understand what I am looking for.

My car was pretty rusty when i bought it, and while i was taking off the rear sub frame, the rear drivers side "sub frame mount to chassis" came off with it. Do you have this part available or know where I can get one? I have been told by a couple of other people that its discontinued??
I've tried looking through diagrams, and just can not seem to find anything. I've been searching for months now with no luck!

Thanks so much!

alltracman78
04-06-2011, 09:24 PM
If it's discontinued for my parts dept it's discontinued for every other parts dept. :)

I haven't forgotten about you, I haven't been able to get under the rear yet to try and remove the part.

Aaron Willis
04-06-2011, 09:47 PM
This is for the '92 ST185 you just picked up? It sounds like what you are describing is highlighted in the attached drawing as 52277 and 52278. The full part numbers are 52277-20020 on the pasenger side and 52278-20020 on the driver side. They are not discontinued. You can order them from us at www.LithiaToyotaParts.com by pasting the part number you want into the Search By Part Number bar, without selecting a vehicle.

Let me know if I am barking up the wrong tree. I may need more info or a pic if this isn't what you wanted. Thanks for the inquiry!

http://www.celicatech.com/gallery/files/4/1/4/3/st185rearsub.jpg

Hookecho
04-06-2011, 10:26 PM
Hey Aaron.

I edited your post so the image would be displayed. Hope you don't mind.

Aaron Willis
04-06-2011, 10:29 PM
I don't mind a bit, thanks for the effort! Unfortunately, all I see if a red X. Short of uploading images and hosting them somewhere, is there another way I can display images rather than links?

Hookecho
04-06-2011, 10:49 PM
So you can't view the image after I modified your post? I see it just fine.

Hookecho
04-06-2011, 10:55 PM
Can you see this image? Is the image in your original post still a red x?

http://www.celicatech.com/gallery/files/4/1/4/3/st185rearsub.jpg

Aaron Willis
04-06-2011, 11:05 PM
Can you see this image?Yep, looks perfect.



Is the image in your original post still a red x?Sure is...

Hookecho
04-06-2011, 11:33 PM
Ok.

You uploaded the picture as a file attachment. It uploads as a php file so the only way to view it is by following the link. I messed up because I wrapped the image code around it when it wasn't an image file.

So the only way you can place the picture in a post is to upload the image to our gallery first. Then insert the image into the post using the image button on the toolbar. It's probably easier/faster for you to just attach the file being that time is a factor for you. We know to follow the link. I'll try to keep an eye out and place the images in your post for you.

You should be able to view the image in your original post now. I uploaded it into the gallery.

Aaron Willis
04-06-2011, 11:40 PM
So the only way you can place the picture in a post is to upload the image to our gallery first.Ah, perfect. I will start uploading pics to the gallery from here forward. That should also be fairly useful as a reference. Thanks again for the help!

Hookecho
04-06-2011, 11:48 PM
I'll warn you that the gallery is kind of wacky right now. It works though. When you do upload an image you will get an error page. Just ignore that and reload the gallery page. Then go to "my images" in the gallery and your file should be there.

Aaron Willis
04-06-2011, 11:51 PM
Excellent, thanks for that.

LittleMiss, sorry to sidetrack your thread! Hopefully it did you more good than harm...

LittleMissAllTrac
04-07-2011, 12:47 AM
Unfortunately that's not the part. Its actually a part of the underbody, spot welded into place on the underbody to mount the rear subframe into. The other side has the long bolt attatched to it. what happened to mine is... where the metal circle spacer is between the bushing and the body (one of the 4 main subframe bushings) it rusted, so the bushing/metal spacer/bolt/ and a small circle section of the underbody(attached to the bolt) are now sitting in my subframe with the bolt still inside the bushing (subframe is OFF the car completely) If you look at the underbody the section that the bolt is welded onto looks to be a additional section added to mount the rear subframe into (im guessing they used the GT body or something and just spot welded on the mount to save on costs?) So the section im looking for is the actual spot welded section of the underbody with that bolt on it. I see the bolt i believe in the diagram you posted as #90109-12049, so i need that and the underbody section its welded or attached too. (the section would be no larger than a sq ft.)

Aaron Willis
04-07-2011, 02:05 AM
That helps a lot. Unfortunately, we cannot return the favor. I think you're looking for the highlighted part marked 57609A in this pic. The full part number is 57609-20050 and it is indeed discontinued. I think you're going to have to break out the MIG welder and repair what you have. 90109-12049 is still available if you need that, though.

http://www.celicatech.com/gallery/files/1/4/6/5/5/st185floormember.jpg

LittleMissAllTrac
04-08-2011, 07:05 PM
Ah! Thanks anyway! I still need the bolt though, so I will go and place an order! :D
Thanks for your help!