PDA

View Full Version : im so lost, ive got the engine i just dont have the info, need help once again lol



javy
03-02-2011, 04:16 AM
so i got the engine today from jdm and i realized the to harness plugs go into the 3sgte ecu just fine but that leaves me with a third plug that doesnt fit from the 5sfe harness. i did some research and i found that there are 13 wires i need to redo but i dont have and cant find the diagrams. my car is a 90 celica gts, the motor from jdm is an st185 but i dont know what year it came out of. im really frustrated. could some one possibly help, do i need that third ecu plug off of the front clip the engine came out of ? im goin out to work on the car now, i'll come back in and check on this forum in a few. thanks

fdfx3
03-02-2011, 04:33 AM
I'm affraid I cant help you with the diagrams but the ecu plug you mentioned could you use one of these?: http://cgi.ebay.com/ebaymotors/ECU-Patch-Jumper-Extension-Harness-AEM-_W0QQcmdZViewItemQQfitsZModelQ3aCelicaQQhashZitem3 5a6c4b127QQitemZ230431174951QQptZMotorsQ5fCarQ5fTr uckQ5fPartsQ5fAccessories

Is it electrical wireing diagram for 5sfe and 3sgte you need?

javy
03-02-2011, 05:22 AM
yeah i think i could probably use that, what im really looking for is a plug and play kinda thing u know. tryna get this motor mounted and running quick

T-spoon
03-02-2011, 05:41 AM
Tons of archived info on this swap in the Forced Induction forum. Also might want to re-ask the question there

andy
03-02-2011, 05:44 AM
Its very simple, you can get that plug from a 90s camry v6 automatic. and truly there are only 3 wires needed to hook up to run it. 3 power wires i believe. look at the 3sgte pinout.