PDA

View Full Version : throttle body, 1994 2.0 GT



liverpool558
10-18-2010, 11:57 AM
Hi guys
i have a late 1994 2.0 GT gen 6, ive just replaced the throttle body, but still isnt running right, revs are still up and down but not as much as they used to be.
Now heres my problem......is there a certain way of setting up the throttle body so the engine runs smooth?
Bearing in mind i dont have any hi-tech equipment apart from my ears and eyes, i would be very gratefull for any instructions or guidance to cure this.
look forward to any answers
Liverpool558

Smaay
10-18-2010, 08:30 PM
Its a 2.2 if you have a GT. unless you have a 3S-GE. Its not the throttle body thats the problem, its the idle air control valve under the throttle body. take that off and clean it out really good.

KoreanJoey
10-19-2010, 03:40 AM
Its a 2.2 if you have a GT. unless you have a 3S-GE. Its not the throttle body thats the problem, its the idle air control valve under the throttle body. take that off and clean it out really good.

x2

85gtsblackman
10-23-2010, 04:50 AM
sometimes the tps sensor will do this as well, or you may have developed a vac leak.

btw im sure he has a 3sge or a 3sfe cause he is in scottland either could be a 2.0

liverpool558
10-23-2010, 03:07 PM
hi
its definately 2.o GT, and yes i do live in Scotland, You mentioned the TPS sensor, where is it and what do you suggest i do with it? and how do i go about checking for a vac leak?..is it just a case of inspecting the pipes?
thanks
Ron