PDA

View Full Version : no constant or switched power to radio



hobbs75011
10-05-2010, 07:59 PM
91 Celica gt s - The biggest issue i have right now is my radio. I have no constant or switched power to the radio. When I removed the radio the first time it was working. When it was put back in there was no power, that was when i rewired it and still no power. I have checked the Dome light fuse, the radio/cig lighter fuse and two fuses in line. All are good. Is there something i am missing????

alltracNyx
10-06-2010, 12:40 AM
A few questions..

Are you visually confirming the fuses are good, or are you actually testing them with a multimeter?

Are you testing the wires at the radio (12v switched and constant) for 12v with a multimeter, or assuming there is no power because the radio is not turning on?

Something may be wrong with the radio itself, so you need to test the wires in the harness to see if they are getting the proper voltage.

Hipster Lawrence
10-06-2010, 02:04 PM
^Always look at the fuses along with the old test light test.

On my ae86 the tail/inst fuse as no good. But the element of the fuse was fine. The fuse was melted on one side between the element and the spade. Sometimes it would make contact and sometimes it would not but the fuse was not "blown". I messed with the fuse panel for 20 minutes or so before figuring out that the fuse was the problem.

hobbs75011
10-06-2010, 03:52 PM
I tested the fuses with a multi meter and i unplugged the radio and tested the wires in the plug it self. Is there someplace between the fuses and the radio that could have miraculously have come unplugged?

grimmythereaper
10-12-2010, 06:13 AM
does the radio have a fuse on the back of it, its self?

alltracNyx
10-13-2010, 03:34 AM
Sorry about not getting back to you sooner, but I haven't been around. So, you didn't say what your results were, did the fuses test okay, but no power to the wire harness?

hobbs75011
10-13-2010, 04:41 PM
I have checked all the fuses both visually and with a meter. I have checked two inline fuses, the radio/cig fuse in the drivers side kick panel and the dome light fuse under the hood. Are there others? I ran a "jump" wire to the constant and it lit up the radio, so the radio is good. I have power to both the illumination and dimmer wires. I have been doing all my testing with the harness unplugged from the radio and testing at the plug terminals. The radio is AM/A\FM with a cassette, Anti-Theft with no code installed, Single Din Toyota radio. Is there a connector that connects just the switched and unswitched wires that could have come undone. I can understand loosing power to one or the other but not both at the same time.

grimmythereaper
10-13-2010, 07:00 PM
look at the cig/radio fuse again, i had this problem and when i thought the fuse was good i would hook up the radio and it would blow the fuse. i ended up taking off the negative on the battery cable and hooking up the radio replaced the blown fuse hooked the battery up again and it has been workin ever sense