PDA

View Full Version : Convertible top problems



StormyBklyn
08-28-2010, 08:51 PM
Hey all. The convertible motor stopped working on me out of the blue. When I checked the motor, I noticed that the black wire from the motor was loose, so I tightened it. It worked for a while, but now it stopped working again. I checked the wire, and once again it was loose. The first time I tried to open it, it clicked once, and now it doesn't do anything.
What's odd is, the radio doesn't work either anymore. I don't know if I'm just having a lot of electrical problems, or if they're unrelated. I checked all the fuses, and they look fine. The cigarette lighter works, the dash lights and gauges work. I looked at 1sttoyotaparts.com, and they want almost $1k for the motor. I see a few on ebay for around $100, but they're for a 6th gen.
A - does anyone know if the motor from a 6th gen will work on a 5th gen
B - anyone have any ideas on what this could be? Where should I check? How can I tell if the motor really is bad, or if it's the wiring somewhere? I can operate the top manually, but it's a pain, and I have no idea what happened to the radio. It's the OEM AM/FM/Cass/CD, I pushed in a tape, it came on for a second, then died. I'm less interested in the radio than I am in the top.
I'm starting to get really sick of this car. It's been a money pit, and looks like it's just going to get worse.
HELP PLEASE!!!!!!
Thanks

alltracNyx
08-30-2010, 01:09 AM
As far as the motors working from one generation to the other, check to see if the part number matches for the fifth and sixth gen motors.

Sometimes visually checking fuses doesn't ensure that they're good. Have you tried testing them with a multimeter? Or testing the wires at the radio or convertible top motor? Make sure that you are actually getting power to the wires in question before you start considering if the motor has to be replaced, especially considering the fact that you are having multiple issues right now.

93celicaconv
08-30-2010, 12:15 PM
Do your power windows work? Cruise control? Air conditioning?

There is a 15A GAUGE fuse that is common to all the above, and to the convertible top motor.

I suspect the 15A GAUGE fuse is OK though, because you said something about a loose black wire that temporarily fixed the operation of your convertible top motor.

Can you explain what you mean by "loose" black wire? The covertible top wiring shouldn't have any wires that can be "tightened", as there is only a 3-wire electrical connector used between the wiring harness and the motor connection. So I don't understand what you are able to "tighten". Do you take the motor apart and tighten the wiring connection inside the motor?

To test, disconnect the 3-wire harness connector at the pump/motor. On the motor side, identify the blue wire with red stripe, and the black wire with yellow stripe. Connect a length of 2-wire cable (something that has 2 separate wires within it) to the battery positive & negative terminals. Push the other two ends of this 2-wire cable into the pump/motor wiring connector having the above stated two wire colors going to the terminals. The pump motor should run in one direction. Reverse the wire connections in the pump/motor wiring connector. The motor should run in the opposite direction. If you get no action from the motor, it is up to you if you want to disassemble the motor to see what is going on inside to repair.

If the motor works, then your motor/pump assembly is good. You should next check your convertible pump/motor relay (located in proximity to the pump/motor assembly), the convertible main relay (I think located under the center console, but not sure, I've never taken this all apart) and the 30A Circuit Breaker located under the passenger side kick panel.

From what I can see in the wiring diagrams, unless your 15A GAUGE fuse is bad, there is no common fuse/wiring between the covertible top motor and your radio.