PDA

View Full Version : Fuel Problems with Alltrac



klapa
08-28-2010, 08:21 PM
I've got some problems here - namely I can't get my 91 Trac to start.

I bought this car a few months ago and have had it in my driveway since - with a few drives a week to "keep it going" till I can get my garage cleaned out and a proper place to work on it.

This car was "billed" by the seller as having a JDM swap - and the guy had it rigged with a "pushbutton start". Everything was fine till about four weeks ago I went to press the button to start it and the whole thing disintegrated into my hands. It was some really cheap Chinese switch - high current - not like the "normal" pushbutton start switches in other cars that are made to control a relay.

So i tried to simply short the wires that had been connected to the switch - as the BGB indicates that I have a starter relay to control the starter solenoid - but no such luck - just a "click".

Today I rigged up a relay of my own controlled by a pushbutton and indeed I have the starter running and the engine turning over - but the car is not starting - even if it was running fine before.

The problem IS fuel delivery - as if I spray "lawnmower" ether in the intake the thing will start and run briefly. So that tells me everything in the "ignition world" is A-OK. It seems to me - my best guess - the thing is not getting fuel. My first guess here would be that the fuel pump is not running.

The BGB does not really do me much good - because I really don't know what I have. I DO know for a fact that I have NO clutch switch in the starter circuit - as I can press the button with out the clutch depressed and the starter will sill engage - and I also highly suspect that I have no starter relay either - as the starter would not even run until I implemented a high current path in the "pushbutton circuit" by inserting this "temporary" relay. So - all this makes me think that the diagrams on the BGB will just confuse the issue - as they are not pertinent to my particular car.

My "goals" are really simple here - I just want to be able to move this thing around in my driveway while I get my garage in order such that in the coming winter months I can tear into it and find out what I have - and get it all in shape - or at least make a good start on that process.

Any ideas are welcome here as far as a way to get fuel to this thing or the best next troubleshooting steps.

banshee 101
08-28-2010, 08:37 PM
i recommend looking at the bgb wiring and passing a new relay

klapa
08-28-2010, 09:14 PM
As mentioned above - BGB diagrams don't seem to doing much good with this modified electrical harness.

klapa
08-29-2010, 01:08 AM
It is for whatever reason the fuel pump control - because if I jumper it at the diag connector (fp to B+) the thing runs with no problems.

So I have a "rigged" relay and then jumper the fuel pump control circuit when previously all I had was a pushbutton start switch.....

Without a doubt - there is no accurate "schematic" for this car - it is every man for themselves here.

Still - at least I have a "rig' to be able to move it around - though it would be nice to understand everything enough to actually DRIVE the thing once and awhile.

banshee 101
08-29-2010, 05:46 PM
send me your model number and year, i work at toyota should be able to get you a proper wiring diagram if you want for the pump and starter

klapa
08-29-2010, 06:56 PM
banshee - thanks - I'll do that.

This does bring up another point - how can I find out what engine I actually have in this car? I know the engine has a serial number - yet this number is in a place that is very difficult to access - but I would take the trouble to get there if this would tell me what engine I have.