PDA

View Full Version : Whoever packaged my NGK spark plugs failed



Hookecho
07-27-2010, 05:49 PM
So i'm working on the Celica today as i have a long list of things i wanted to take care of. As most of you know I have been having a problem with my motor pulling timing when i go into high boost. I also had a boost leak due to my intake to tmic connector had 2 nasty cracks in it.

Well i replaced the intake connector with a brand new one and decided to inspect the spark plugs. I pulled them all out and they looked exactly like they they should in a properly running engine. Plus i only had about 400 miles on those plugs. So i set them aside and installed a new set of NGK's that are a step colder.

Afterward i took another look at the old plugs and noticed that one of them looked different and sure enough it was. One of the plugs was about a 1/4 inch longer. The part# on the plug was NGK ZFR5FGP. Which i found was used on some Honda and Mazda motors. So the person who packaged the set of plugs i bought failed.

I'm hoping that this was the cause of my problem.

Back to work.

donteatbugs
07-27-2010, 06:48 PM
where did you get them? i got mine at oriellys and they have been right so far

ChrisD
07-27-2010, 06:52 PM
Wow, fail by NGK. Using the correct plugs can't hurt, that's for sure. Hoping these changes will finally let you enjoy the car. :)

I guess we should all take note to always give the plugs a quick inspection before installing.

Hookecho
07-27-2010, 07:38 PM
I got the plugs at O'Rielly's. That's usually where I shop.

---------- Post added at 01:38 PM ---------- Previous post was at 01:37 PM ----------

i'm off to wire up the LED knock detector.

Nitro_Alltrac
07-31-2010, 08:14 PM
It's always a good idea to check the number before you put them in. Quality control problems happen to everybody. There was probably a batch change and that one was sequenced wrong.