PDA

View Full Version : Idle problem; bounce from 1500 to 2100, and back again



sleekcelica
07-12-2010, 05:12 PM
I posted this on 6gc.net, also. I am just trying to get the largest database of people who know so much more about this car than I do to help me with this... so here it goes
This car just seriously hates me. My idle bounces from about 1500 RPM's to 2100 RPM's and then back again, over again, pretty rapidly. Also, there is a LOUD sucking sound from the intake manifold, and if you plug up the IAC hole, the sucking sound goes away and it calms down a bit. This car can be in gear, and actually just pull itself without me giving it gas, and i can shift all the way to forth without giving it gas.
The guys on 6gc say it's a vacuum leak, but like I said, everything calms down when I plug up the IAC hole, on the filter side of the Throttle body.

93celicaconv
07-13-2010, 02:35 AM
What you are hearing is a vacuum leak. I think the IAC is trying to stablize the engine RPM, but because it is way too high to start with, it starts hunting. Normal for a major vacuum leak.

You should look over the entire intake manifold from downstream of the throttle plate to the point where it bolts onto the head (including the gasket around this mounting area). I'm sure you either have a vacuum hose disconnected or broken off somewhere, or your intake manifold gasket has a major leak due to a failure or a mounting bolt or two that worked their way out.

sleekcelica
07-13-2010, 02:58 AM
Alright, thank you very much, going on a vacuum leak hunt tomorrow, won't stop until it's found!

93celicaconv
07-13-2010, 03:02 AM
How do your power brakes work? Could be your power brake booster has a hole in it. I'm betting it is something else that was left off of some repair at one time though.

sleekcelica
07-13-2010, 03:06 AM
My brakes are pretty good, they are strong, and feel like normal vacuum assisted brakes. I'm not sure if there's a problem there, though. Any other suggestions?

93celicaconv
07-13-2010, 03:35 AM
You may still have sufficient vacuum in your brake booster for it to feel right, but you may be sucking in a lot of air to do it. The way to check is to let the engine run, then remove the larger vacuum hose that comes from the brake booster from the intake manifold connection. If the engine speed does not increase at all, then your brake booster is the problem. If the engine speed goes up, then your brake booster is not the problem.

I think if you can hear the sucking sound, just go find out where it is originating. I think you will find out what is wrong and will be able to fix/connect the disconnect relatively easily.

sleekcelica
07-13-2010, 02:26 PM
It's coming from the IAC hole on the filter side of the throttle body.

93celicaconv
07-13-2010, 02:35 PM
It's possible your IAC valve is dirty and cannot close completely at all, so it is letting too much air go through. Perhaps the coolant lines going to it are also plugged, so it never warms up enough to drop down into a slow idle.

Either way, the only thing I can think that you should do is to take the IAC valve off, open it up, and clean it thoroughly. You might want to get a salvage IAC valve as well, just in case a thorough cleaning doesn't help your old IAC valve.

sleekcelica
07-13-2010, 02:48 PM
I took it off twice, and cleaned it. i checked it to see if it worked, and it clicks when the key is turned on. It still does this.

93celicaconv
07-13-2010, 02:57 PM
Then you should probably get a salvage IAC valve, clean it up, then put it on and see if it works better. Something doesn't sound like it is working right with your old IAC valve.

sleekcelica
07-13-2010, 05:27 PM
Alright, I'll try that. There's just no celica's in the junkyards, and most of the camrys have been robbed.

sleekcelica
07-19-2010, 03:42 PM
Fixed it. When I went to clean the IAC the first time, when I reassembled it, I installed the valve upside down. I installed it right, and problem solved!!

93celicaconv
07-19-2010, 05:43 PM
That is amazing. The problem you had with excessive idle speed and hunting existed before you took the IAC valve out the first time, and continued with the same symptoms after cleaning it and putting the valve in upside down. I would have expected some kind of change, but you had none.

Well, congratulations on getting the problem fixed. I think this is a good thread for people who have very high idle speeds to learn from, that the IAC valve can be cleaned and that it can be put back together incorrectly so care has to be taken, and this can solve high idle speed and idle hunting problems.

sleekcelica
07-21-2010, 01:29 AM
I had taken it out once before, when I took off the throttle body to get to the tps.