PDA

View Full Version : My 3rd gen 3SGTE Swap into a 94 GT



presure2
06-13-2010, 03:34 PM
So as most of ya know, i've had jenns 94 GT setup with a 5sfte for just about 5 years now, and its time to move on.

after going thru all the options we decided on a 3rd gen 3sgte for all the obvious reasons.
_jim_ has been selling 3s motor sets and clips to a few diffrent members here, and is a good friend of mine, so i gave him a call, and discussed my options with him.
he set me up with a great deal on a clip minus body panels ect, since we already have the '4 front end on jenns car.
he delivered it to my house on friday.
we're pretty sure the clip is a 94, it has ~34,000 miles on it (~55,000km) and is in GREAT shape.

some pics of the progress so far.

once we got the hood and bumper off, this is what we had:

http://www.6gc.net/images/hosted/swap/img_1325_medium.jpg

http://www.6gc.net/images/hosted/swap/img_1326_medium.jpg

it came with a blitz BOV, blitz spark plug wires, and blitz ground kit.

http://www.6gc.net/images/hosted/swap/img_1328_medium.jpg

http://www.6gc.net/images/hosted/swap/img_1331_medium.jpg

the turbo has virtually NO shaft play, and spins super free and smooth as butter.

http://www.6gc.net/images/hosted/swap/img_1333_medium.jpg

the leader and supervisor of team "JDM guy"

http://www.6gc.net/images/hosted/swap/img_1335_medium.jpg

then i dropped out the 3s, its much easier to just remove the suspension, crossmembers, motor and tranny as one piece out the bottom.

this pic shows how i lifted the clip up over the motor once i dropped it onto a dolly

http://www.6gc.net/images/hosted/swap/img_1351_medium.jpg

the motor with the intercooler off out of the clip:

http://www.6gc.net/images/hosted/swap/img_1352_medium.jpg



the suspension and crossmember

http://www.6gc.net/images/hosted/swap/img_1353_medium.jpg

and chassis tag:

http://www.6gc.net/images/hosted/swap/img_1354_medium.jpg

next i got the tranny off and the motor on a stand, the more i took off the more i realized how nice and clean the motor is. what a beautiful thing.

looking up at the block, you can see the oil feed line attched to the block on the right there.
http://i9.photobucket.com/albums/a57/presure2/IMG_1361Medium.jpg

the backside
http://i9.photobucket.com/albums/a57/presure2/IMG_1362Medium.jpg

the typical trouble spot for the 3/5s motors, under the dizzy
http://i9.photobucket.com/albums/a57/presure2/IMG_1363Medium.jpg

the blitz spark plug wires, which apparently, they no longer make:
http://i9.photobucket.com/albums/a57/presure2/IMG_1358Medium.jpg

and the blitz BOV, a bit pitted, but it'll look good once its all cleaned up, however, i wont be using it. ( we still like the HKS over the blitz sound)
http://i9.photobucket.com/albums/a57/presure2/IMG_1359Medium.jpg

the steering wheel
http://i9.photobucket.com/albums/a57/presure2/IMG_1368Medium.jpg

the upper timing cover after a quick wipe
http://i9.photobucket.com/albums/a57/presure2/IMG_1366Medium.jpg

when we got the clip, the intercooler and stuff on top of the motor seemed to have this weird "film" on it, almost textured, that seemed to trap most of the dust and dirt that is visable on the motor.
i took a little lacquer thinner to a corner of the IC, and it started comming off, it almost seems like the previous owner may have attempted to spray some kind of clear coat over things, but very poorly.
once i started wiping it off, the intercooler REALLY started to come back to life.
a quick pic i snapped last night of the results ( you can see the film on the entry neck of the IC still):

http://i9.photobucket.com/albums/a57/presure2/IMG_1374Medium.jpg

yummy!

for you guys that may see this, and are looking for RHD parts, be on the lookout for a for sale thread soon, i have the FULL dash minus the CC unit, and full front SS suspension and steering rack, excluding brakes and of course all the RHD firewall stuff.

after removing the dash and whatnot:

http://i9.photobucket.com/albums/a57/presure2/IMG_1385Medium.jpg

after cutting back the frame rails:

http://i9.photobucket.com/albums/a57/presure2/IMG_1386Medium.jpg

after cutting out the firewall (no, i didnt drill out the welds, leave that for the guy who buys it! lol)

http://i9.photobucket.com/albums/a57/presure2/IMG_1387Medium.jpg

floor and door pillars:

http://i9.photobucket.com/albums/a57/presure2/IMG_1389Medium.jpg

cut in half for easy transportation:

http://i9.photobucket.com/albums/a57/presure2/IMG_1390Medium.jpg

i spent a little time cleaning up the blitz BOV that came on the clip, its not 100% done, and i am not planning on using it on this swap, but i wanted to see if it would shine back up, so that if i end up selling it, it looks good for the next guy who owns it.
its the blitz super sound, after googling for some vids of it, i actually like how it sounds.

before:

http://i9.photobucket.com/albums/a57/presure2/IMG_1359Medium.jpg

after:

http://i9.photobucket.com/albums/a57/presure2/IMG_1430Medium.jpg

steff (my friend dustins girl) is the best, she bought by the timing belt, the ATS cam gears, PCV valve and alt. belt, and this past weekend, my hommie dustin bought by what was left of the gasket set he bought when he did his swap , so i have 99% of what i need to clean up the motor other than a valve cover gasket which is being ordered this week.
so, i went out and pulled the timing covers off and took the T-belt and gears off.
heres a few pics.

timing covers off..everything is very clean, as you would expect from a motor with 34,000 miles on it.

http://i9.photobucket.com/albums/a57/presure2/IMG_1440Medium.jpg

noticed the cam seals are starting to seep a little... lucky for me, i have em in the gasket kit!

http://i9.photobucket.com/albums/a57/presure2/IMG_1446Medium.jpg

original tensioner:

http://i9.photobucket.com/albums/a57/presure2/IMG_1444Medium.jpg

ATS cam gears:

http://i9.photobucket.com/albums/a57/presure2/IMG_1449Medium.jpg

10* of adjustment each way, advanced or retarted. ill play with these on the dyno for sure! :)

http://i9.photobucket.com/albums/a57/presure2/IMG_1450Medium.jpg

had a few ideas on some things i wanted to do to try and clean up the look of the motor some, and the engine bay as well.

first off is the IAC (idle air controller) line.
my plan is to run a small filter directly off the IAC valve hose, to eliminate the air pipes associated with it, and the hose that normally runs to the intake piping, before the turbo. in doing so, i will also be eliminating a few other things as well.
the TVSV (turbo vacume switching valve) is basicly going to be usless on this car, its never going to be in use, so im planning to just remove it, by removing the valve itself, (unplugging it does not affect the car at all) and the hard airline that feeds on side if it.(which is normally capped when we install a boost controller) the other line from it feeds into the air hardline that is behind the intake manifold, which is a normal airsource that gets its feed from the IAC line, and feeds into one side of the powersteering idle up valve connected to power steering pump.
the other side of the PS pump idle up valve just goes up to the back of the intake manifold.
so, i will feed the PS idle up valve a filtered air source, and leave the other line that connects to the back of the intake manifold, and that way i will be able to remove all the hard air lines that normally connect to the side and back of the intake manifold.
i will also be removing the coolant lines that feed into the throttle body.
the 2 lines that feed the throttle body come from the waterneck, and water bypass lines, both under the distributor. i will loop the line from the waterneck, to the water bypass line, and eliminate the hardlines that go along the side of the head to the back and connect to the rubber lines that connect to the throttle body.
i will post pics later to show what exactly im talking about, but for now, anybody see anything potential problems with any of that?
you guys will have a good laugh when i post the pics of everything all bagged and tagged. i've been doing this stuff long enough now that i really dont NEED to do it (i basicly put jims car together out of a 5 gallon bucket of nuts and bolts..lol), but it definetly makes things alot easier when you go to put everything back together.

this first pic is the coolant line that runs from the water neck, to the coolant hardlines that bolt to the side of the intake manifold, which in turn feeds the throttle body.

http://i9.photobucket.com/albums/a57/presure2/IMG_1475Medium.jpg

this is the other line. it comes off the water bypass pipe that runs alongside the motor, under the waterneck and distributor.

http://i9.photobucket.com/albums/a57/presure2/IMG_1477Medium.jpg

this pic shows the hardlines that the coolant lines pictured above feed into. (its the silver lines)

http://i9.photobucket.com/albums/a57/presure2/IMG_1478Medium.jpg

next is the TVSV. in the pic below, you can see the TVSV, and the line im pointing to goes to the hardline that you normally cap off when you install a boostcontroller.

http://i9.photobucket.com/albums/a57/presure2/IMG_1480Medium.jpg

the other line goes to the air bypass hardline, which is why it dont have a clamp on it (it never sees boost)

http://i9.photobucket.com/albums/a57/presure2/IMG_1481Medium.jpg

and finally the airbypass hardline, which connects the air intake to the IAC.

http://i9.photobucket.com/albums/a57/presure2/IMG_1482Medium.jpg

thats part of the stuff i am eliminating, and will clean things up a bit in that area.
in the above picture, the line to the left is the one talked about above, and the one on the right goes accross the back of the motor, to feed the power steering idle up valve.

http://i9.photobucket.com/albums/a57/presure2/IMG_1483Medium.jpg

here is where the line connects to the valve. you can see how i marked the valve to show where the lines go:

http://i9.photobucket.com/albums/a57/presure2/IMG_1485Medium.jpg



the other line connects to the back of the intake manifold:

http://i9.photobucket.com/albums/a57/presure2/IMG_1486Medium.jpg

http://i9.photobucket.com/albums/a57/presure2/IMG_1487Medium.jpg

this is what it looks like with the other line removed:

http://i9.photobucket.com/albums/a57/presure2/IMG_1489Medium.jpg

once that was all set, i removed it all, then removed the intake manifold

http://i9.photobucket.com/albums/a57/presure2/IMG_1495Medium.jpg

ill shave off the stuff i dont need on the manifold, clean that and some other stuff up this weekend, and then send it all off to be powdercoated. luckily we have a guy who is right local to the house that does a good job for us.

then i pulled the turbo/manifold/DP off as one peice, i just disconnected the water lines for the turbo, disconnected the manifold/turbo braces, and the oil feed line from the block, moved the clamp on the return line, removed the bolts and pulled it off.

http://i9.photobucket.com/albums/a57/presure2/IMG_1488Medium.jpg

ill be doing the helper spring mod to help hold boost better as well.

i spent some time in the garage cleaning up some parts for powdercoat.

here are some pics.

first the 2 waternecks.

http://i9.photobucket.com/albums/a57/presure2/IMG_1501Medium.jpg

http://i9.photobucket.com/albums/a57/presure2/IMG_1500Medium.jpg

then i went to work on the manifold...a few before pics:

http://i9.photobucket.com/albums/a57/presure2/IMG_1495Medium.jpg

http://i9.photobucket.com/albums/a57/presure2/IMG_1499Medium.jpg

http://i9.photobucket.com/albums/a57/presure2/IMG_1497Medium.jpg

http://i9.photobucket.com/albums/a57/presure2/CopyofIMG_1496Medium.jpg

http://i9.photobucket.com/albums/a57/presure2/IMG_1498Medium.jpg

now for the afters:

http://i9.photobucket.com/albums/a57/presure2/IMG_1504Medium.jpg



http://i9.photobucket.com/albums/a57/presure2/IMG_1507Medium.jpg

http://i9.photobucket.com/albums/a57/presure2/IMG_1503Medium.jpg

http://i9.photobucket.com/albums/a57/presure2/IMG_1506Medium.jpg

http://i9.photobucket.com/albums/a57/presure2/IMG_1505Medium.jpg

the intake manifold:

http://i9.photobucket.com/albums/a57/presure2/IMG_1509Medium.jpg

http://i9.photobucket.com/albums/a57/presure2/IMG_1508Medium.jpg

the 2 water necks:

http://i9.photobucket.com/albums/a57/presure2/IMG_1515Medium.jpg

http://i9.photobucket.com/albums/a57/presure2/IMG_1514Medium.jpg

throttle body stay and throttle cable bracket:

http://i9.photobucket.com/albums/a57/presure2/IMG_1517Medium.jpg

http://i9.photobucket.com/albums/a57/presure2/IMG_1516Medium.jpg

more progress pics, painted the block, powersteering pump and bracket, waterpump housing, crank pully, and oil dipstick pipe

back of the block

http://i9.photobucket.com/albums/a57/presure2/IMG_1520Medium.jpg

http://i9.photobucket.com/albums/a57/presure2/IMG_1521Medium.jpg

crank pully

http://i9.photobucket.com/albums/a57/presure2/IMG_1522Medium.jpg

front of the block

http://i9.photobucket.com/albums/a57/presure2/IMG_1523Medium.jpg

water pump housing

http://i9.photobucket.com/albums/a57/presure2/IMG_1525Medium.jpg

so here are some pics of the harness work.

first a pic of the throttle body painted.

http://i9.photobucket.com/albums/a57/presure2/IMG_1526Medium.jpg

here is where 99% of the work is with the harness. you can see the way the harness is set up for a RHD car, with the boot that goes into the firewall on the left side of the pic. this is where i have alot of wires already taped and ready to be cut in this pic, the big bunch of taped up wires is for the ignitor and coil, and diagnostics box:

http://i9.photobucket.com/albums/a57/presure2/IMG_1527Medium.jpg

in the middle of this pic, where you see the blue plug (that is the turbo VSV plug, and the speed sensor plug near it) is where the harness will route thru now, to go behind the motor into the firewall:

http://i9.photobucket.com/albums/a57/presure2/IMG_1529Medium.jpg

in this pic you can see how a few wires from the resistor pack and IAT that goes in the airbox go each way along the harness, that is why i have to extend those as well.:

http://i9.photobucket.com/albums/a57/presure2/IMG_1533Medium.jpg

this pic shows the diagnostics box. the only wire from it i didnt have to extend is the green wire you can see going twoard the right of the pic.:


http://i9.photobucket.com/albums/a57/presure2/IMG_1532Medium.jpg

this one shows the ignitor and coil and how the wires run for those:

http://i9.photobucket.com/albums/a57/presure2/IMG_1531Medium.jpg

im also going to have to extend the reverse light switch wires.
if i were into that sorta thing, this would be a nice way to start a wire tuck.

this shows the basic idea of how the harness will go:

http://i9.photobucket.com/albums/a57/presure2/IMG_1539Medium.jpg

another view:

http://i9.photobucket.com/albums/a57/presure2/IMG_1540Medium.jpg

since i had an old 5s harness laying around, i pulled it apart, and was able to get matching wire colors and all.

here is how i like to solder my joints together.
first, i interlock the 2 wires, so that it makes a nice solid mechanical connection
step 1:

http://i9.photobucket.com/albums/a57/presure2/IMG_1544Medium.jpg

step 2:

http://i9.photobucket.com/albums/a57/presure2/IMG_1545Medium.jpg

step 3:

http://i9.photobucket.com/albums/a57/presure2/IMG_1546Medium.jpg

then i heat the joint with the soldering pen:

http://i9.photobucket.com/albums/a57/presure2/IMG_1547Medium.jpg

then add just enough solder to complete the electrical connection:

http://i9.photobucket.com/albums/a57/presure2/IMG_1548Medium.jpg

and finish it off with a peice of heat shrink tubing:

http://i9.photobucket.com/albums/a57/presure2/IMG_1549Medium.jpg

i took a break from the wiring and just cleaned up the wastegate actuator, and installed the helper spring to help hold boost more consistantly.
i went over to ace, and bought a couple of springs, but in the end, i ended up using one i had around the garage.
i used a bike tire pump, and checked the wastegate actuator, to see when it started to crack the wastegate open without the spring, then messed with the tension and free length of the spring to get the wastegate to start to upen ~12 or so psi, and its fully open ~16psi, which should be perfect for what i want.
once it was all set up, i took it off, and sprayed it.
a couple of pics.

http://i9.photobucket.com/albums/a57/presure2/IMG_1552Medium.jpg

http://i9.photobucket.com/albums/a57/presure2/IMG_1553Medium.jpg

finished the harness.

http://i9.photobucket.com/albums/a57/presure2/IMG_1556Medium.jpg

http://i9.photobucket.com/albums/a57/presure2/IMG_1557Medium.jpg

http://i9.photobucket.com/albums/a57/presure2/IMG_1558Medium.jpg

http://i9.photobucket.com/albums/a57/presure2/IMG_1560Medium.jpg

painted the alternator, and distributor, and installed the alt bracket and intercooler mount bracket for a final fit check before i reinstall everything:

http://i9.photobucket.com/albums/a57/presure2/IMG_1569Medium.jpg

http://i9.photobucket.com/albums/a57/presure2/IMG_1565Medium.jpg

http://i9.photobucket.com/albums/a57/presure2/IMG_1564Medium.jpg

http://i9.photobucket.com/albums/a57/presure2/IMG_1563Medium.jpg

http://i9.photobucket.com/albums/a57/presure2/IMG_1570Medium.jpg

also installed the oil filter adapter for the oil pressure gauge.

http://i9.photobucket.com/albums/a57/presure2/IMG_1559Medium.jpg

painted the valve cover, in my version of 8L5 to match the car.
i think it adds a nice finishing touch to the motor.

http://i9.photobucket.com/albums/a57/presure2/IMG_1571Medium.jpg

http://i9.photobucket.com/albums/a57/presure2/IMG_1574Medium.jpg

http://i9.photobucket.com/albums/a57/presure2/IMG_1573Medium.jpg

spark plugs:

http://i9.photobucket.com/albums/a57/presure2/IMG_1576Medium.jpg

old VS new:

http://i9.photobucket.com/albums/a57/presure2/IMG_1575Medium.jpg

installing things:

http://i9.photobucket.com/albums/a57/presure2/IMG_1577Medium.jpg

http://i9.photobucket.com/albums/a57/presure2/IMG_1579Medium.jpg

http://i9.photobucket.com/albums/a57/presure2/IMG_1588Medium.jpg

theres some good stuff in this pic if you know what to look for..

http://i9.photobucket.com/albums/a57/presure2/IMG_1587Medium.jpg

http://i9.photobucket.com/albums/a57/presure2/IMG_1585Medium.jpg

resistor pack, ignitor and coil and brackets refinished:

http://i9.photobucket.com/albums/a57/presure2/IMG_1598Medium.jpg

the only air bypass line left on the back of the motor, for the PS idle up valve:

http://i9.photobucket.com/albums/a57/presure2/IMG_1601Medium.jpg

a couple of brackets i modifyed, they both normally have throttle cable stays on them, but we dont use them when we swap.
this one is for the idle up valve and charc. canister lines:

http://i9.photobucket.com/albums/a57/presure2/IMG_1600Medium.jpg

and this one is for the map sensor line:

http://i9.photobucket.com/albums/a57/presure2/IMG_1599Medium.jpg

and finally, the lower oil pan:

http://i9.photobucket.com/albums/a57/presure2/IMG_1602Medium.jpg

pulled out the 5sfte, then powerwashed the engine bay, and replaced the radiator and bumper support with the parts off the clip, because ours was a bit damaged.

http://i9.photobucket.com/albums/a57/presure2/IMG_1605Medium.jpg

a pic of the bay after replacing the rad. support:

http://i9.photobucket.com/albums/a57/presure2/IMG_1613Medium.jpg

a funny pic i took..

http://i9.photobucket.com/albums/a57/presure2/IMG_1615Medium.jpg

i cut the hole for the harness, i welded a couple of bolts that i cut the heads off to the firewall, to secure the boot in an OEM fashion.
i also painted the bay body color.

here are some pics i took.

the starter hole:

http://i9.photobucket.com/albums/a57/presure2/IMG_1625Medium.jpg

studs welded test fitting the boot:

http://i9.photobucket.com/albums/a57/presure2/IMG_1626Medium.jpg

painting the bay:

http://i9.photobucket.com/albums/a57/presure2/IMG_1627Medium.jpg

http://i9.photobucket.com/albums/a57/presure2/IMG_1628Medium.jpg

http://i9.photobucket.com/albums/a57/presure2/IMG_1631Medium.jpg

http://i9.photobucket.com/albums/a57/presure2/IMG_1634Medium.jpg

then it was just a matter of installing the engine, and putting everything together.

the 5sfte exhaust bolted right up, which saved money, and time.

http://i9.photobucket.com/albums/a57/presure2/IMG_1674Medium.jpg

http://i9.photobucket.com/albums/a57/presure2/IMG_1673Medium.jpg

tranny painted:

http://i9.photobucket.com/albums/a57/presure2/IMG_1660Medium.jpg

the comp clutch from dr tweak i got last year, looks pretty much like it did when i pulled it a few months after the install of the last revision of the 5sfte.

http://i9.photobucket.com/albums/a57/presure2/IMG_1665Medium.jpg

putting the motor in. normally we connect the tranny and install it together, but i didnt want to scratch the bay up after just painting it, so we installed them seperately.

http://i9.photobucket.com/albums/a57/presure2/IMG_1667Medium.jpg

the boot installed onto the firewall:

http://i9.photobucket.com/albums/a57/presure2/IMG_1668Medium.jpg

and now, the basics of the wiring that is required.

first is the interior plugs.

this black wire on the white plug:

http://i9.photobucket.com/albums/a57/presure2/IMG_1675Medium.jpg

http://i9.photobucket.com/albums/a57/presure2/IMG_1676Medium.jpg

is for the clutch start switch. we need to put it to pin 17 on this grey plug:

http://i9.photobucket.com/albums/a57/presure2/IMG_1677Medium.jpg

you can see the #'s for the pins on the back of the plug (sorry for the upsidedown pic, i forgot to edit it)

http://i9.photobucket.com/albums/a57/presure2/IMG_1678Medium.jpg

so i added a pin from one of the 5s harness plugs:

http://i9.photobucket.com/albums/a57/presure2/IMG_1679Medium.jpg

and soldered the connection:

http://i9.photobucket.com/albums/a57/presure2/IMG_1680Medium.jpg

and thats it on the interior.

next up is the EA1 plug in the engine bay.

this pic is the bodyharness side of the gt-4 EA1. the 3 wires on each end are extra wires that need to be used with the swap, along with a couple on the top.

with my 94, the connector for my EA1 bodyharness side was blocked off solid where those wires go, which was diffrent from jims swap. jims 95 had little rubber plugs in them that were able to easily be removed to add pins if needed.

so, we just removed the wires from the 5s bodyharness EA1, and transfered those over to the gt-4 one.
a pic pointing to the 3 wires from each side:

http://i9.photobucket.com/albums/a57/presure2/IMG_1682Medium.jpg

http://i9.photobucket.com/albums/a57/presure2/IMG_1681Medium.jpg

in this pic, the gt-4 plug is on top, the 5s one on the bottom.
basicly, it was as easy as removing the pins one at a time from the 5s one, and installing it into the 3s one.
easy peasy.
http://i9.photobucket.com/albums/a57/presure2/IMG_1683Medium.jpg

and a pic of the pin tool i used to remove the pins in action.

http://i9.photobucket.com/albums/a57/presure2/IMG_1684Medium.jpg

a medium saftey pin also works well.

once thats done, there are 3 wires left over, 2 need power sources, and a white with black stripe gets ground.
thats all there is to it!

once it was all buttoned up, it started right up, but only ran on 2 cylinders.
after like 4+hrs of diagnosing all kinda crap, going so far as to remove and swap injectors, it was just 2 crossed wires at the distributor cap. lmao
after all that work, somthing as simple as that caused hrs of problems...lol i think part of it was just us getting tired and not stopping to step back and look at the situation.
once that was taken care of, it started right up, and idles like a champ.
lots more pics and vids later. unfortunately, its supossed to rain all day, so the vids will prolly be on the lame side for now..lol

Smaay
06-13-2010, 05:40 PM
i love this stuff, thanks manny, oh by the way your first 10 pics or so wont hotlink over. 6GC dont like it

Hookecho
06-13-2010, 06:59 PM
wow! looking great Man. i like all of the pics.

METDeath
06-14-2010, 01:46 AM
I don't think you have enough pictures... just sayin'

ChrisD
06-14-2010, 02:08 AM
fapfap

Nicely done! A lot of hard work, spent on the right things. This is essentially a picture diary of how to do the swap right! Awesome, me=jealous!

You'll have to let us know how you like it compared to the old setup.

presure2
06-14-2010, 03:45 AM
pretty much all buttoned up, just a few minor details to attend to.
i just wanted to get it road worthy, make sure there were no leaks ect.
turns out i got a bad intercooler waterpump with the clip, but luckily i had a spare in the garage that jeremey was going to let jim borrow back in the day.
a couple pics and a quick vid i threw together.

http://i9.photobucket.com/albums/a57/presure2/IMG_1691Medium.jpg

http://i9.photobucket.com/albums/a57/presure2/IMG_1698Medium.jpg


http://i9.photobucket.com/albums/a57/presure2/th_3rdGen3SGTEina94Celica.jpg (http://s9.photobucket.com/albums/a57/presure2/?action=view&current=3rdGen3SGTEina94Celica.mp4)

thanks all.
ill edit the correct pics in tommorow for the first handful of pics.

m:
ill add a bunch more tommorow, just for you. :)
gotta learn somehow!

:)

Colossus20v
06-14-2010, 04:49 AM
Awesome post Manny and great pics. Car looks great and you made the swap seem so simple. Keep up the great work and let us know how you like it.

v8killer
06-14-2010, 05:58 PM
shmexy i want it