PDA

View Full Version : wtf hawk brake pad 1 cm groove on rotor



aye87
04-03-2010, 01:26 AM
so, i put on set of new beck and arlney rotors and new set of hawk brake pad, after drive about 10 miles and recheck the brake, i notice both side left and right have 1 cm wide and 3 mm deep groove on the inner side( facing the engine ) of the rotor around the edge

i cant figure why this is happening, anyone knows? also they been making loud grinding noise since they were put on

note: the car sat around for 8 months unmove with the new rotor and new brake pad, maybe they rusted out really bad? but i dont think this is the case

KoreanJoey
04-03-2010, 02:25 AM
You probably put the squealers on incorrectly.

Picture please.

aye87
04-03-2010, 02:28 PM
its probably stuck calipers
let me replace them first, if it still doing it, i will post picture
its not the squealing noise, its much louder like metal to metal constant grinding
they sound like when you take the rotor to turn or cut but much louder

KoreanJoey
04-03-2010, 07:44 PM
Oh, you're backing plate is probably hitting. Check that first.

aye87
04-04-2010, 01:48 PM
what do you mean backing plate is hitting? you mean it come in contact with the piston or the outer side metal while the car is moving? they still make loud noise even when the brake pedal were not on
i didnt put anything chemical behind the backing plate, just the manfacture squeal shim, thin sheet of steel

KoreanJoey
04-04-2010, 02:10 PM
The plate behind the brake rotor. When you installed the brakes you might have bent the plate to the point it's now contacting the rotor. You really should post a picture...

aye87
04-04-2010, 02:54 PM
yes, i just saw the shiny wear mark on the cooling shield or backing plate, i overlooked. but i need to replace calipers anyway, its pulling to the right and alignment is in spec and inner pad got more stuff than the outer pad, now i remember used to pull the shield toward me instead of the rotor
thank you

KoreanJoey
04-05-2010, 03:03 AM
You don't need to replace the caliper, chances are the pins are just hanging up. You can take out, clean and regrease the pins that mount the caliper to the caliper mount and you'll probably be fine.

Grot
04-05-2010, 04:42 AM
Listen To what joey says... Hes a Toyota Mechanic.

And Pictures Always help and will get your problem fixed faster, without spend any cash

aye87
04-05-2010, 12:29 PM
yes i know, but they already got 135000 miles
i dont wanna fix one thing and other thing need to be fix also
i would just replace the whole assembly incase piston seal or boot give me problem in the upcoming time

Shadowlife25
04-05-2010, 12:34 PM
Are your calipers leaking?

I am a bit confused as to what the exact nature of the problem is at this point.

I thought that it was the backing/cooling plates contacting the rotors and being the cause of the issue.

What did you do at Toyota? just curious.

Seems you are a Technician? In the Automotive field?

KoreanJoey
04-05-2010, 02:16 PM
These sound like two different problems.

aye87
04-06-2010, 10:40 PM
at first the back plate was contacting the the rotor which make constant loud grinding noise and thank you for all your supports
and caliper needed to be replace because they are old and guide pin boot is rip and stuck
might as well buy a reman one to save trouble, they make inner pad thinner than outer pad. so anyways long story short
thank you for helping, i mean it

and i used be toyota express lube, they hired 17 express lube tech but no enough job to go around, maybe 16 now that i dont work there no more

85gtsblackman
04-07-2010, 05:29 AM
if you need new calipers, just get remans from your local parts store and a set of pins, or semi loaded calipers since u have new pads, i reccomend thios cause they will come ith brakets which u dont need but the brackets have the slider pins and come with the hardware kit, see my writeup in the brakes section.

celica9303
05-06-2010, 04:52 AM
i recently changed my brakes also and on my ds rotor ther is now a groove all the way around the exact center of the rotor surface, could there be contaminted on the pad? ill post a pic hold on..
non of the other 3 are like this and im also gettnig som squeling noise but that is from the pass side not ds.

http://i290.photobucket.com/albums/ll269/twendt/utf-8BSU1HMDAwMDctMjAxMDA1MDUtMjM0N.jpg
grove in center of rotor, im gonna take it apart tomomorow and see what it mightbe

Terracar
05-13-2010, 06:50 PM
IMO looks like the clips that hold the pads in are either in backwards or possible the squeal piece, but that is just my opinion.

-Terracar

celica9303
05-14-2010, 04:04 AM
that kinda what im thinking, i will get them back apart soon to find out (myair compressor tipped over the day i was gonna do it and brokethe regulator and now i have to get a new one(so i can get my wheels off)) ill report back once i do it, it doesnt seem to be affecting my braking at all

KoreanJoey
05-18-2010, 04:51 AM
squeakers are on incorrectly.