PDA

View Full Version : Swapping Engine 2002 Celica GT



ECR_02
12-30-2009, 11:18 PM
Hey All,

My Son threw a rod in his 2002 Celica GT and I'm going to have to pull the engine and replace it. I have an AllData subscription (not sure that was the best investment) and I have found a rather poor quality FSM for the 2000 Celica. I have done numerous engine swaps/overhauls in my youger days but never on a FWD vehicle. I'm at the point of removing the drive axles but the ALLData manual suggests removing the lower ball joint from the lower supension arm. However, there seems to be quit a bit of tension on the supension arm even after I have the bolts/nuts off. Do I have to compress the coil spring before disconnecting this? It doesn't appear that way but I certainly don't want to release a rocket by prying the arm lose form the ball joint.

All instructions/data will be helpful.

I also posted this in the Ask A 7th Generation Questoin Thread but Thought it might be better here.

donteatbugs
12-30-2009, 11:40 PM
remove the lower ball joint and remove one side of the swaybar endlink and it should move down. i just remove my struts all together from the top and spindle. you might need an alignment after this method though. pulling this engine is one of the easiest ever. takes me about 3 hours

Smaay
01-01-2010, 07:33 PM
you dont have to take the suspension apart. just the 2 bolts holding the strut to the hub. remove the AMS sensor if there is one. then just pull the axle out.

Luni
01-09-2010, 12:31 AM
Thats what I say. Remove the ABS sensor, pull it up above and tuck it behind the shock, and then loosen the 30mm outer axle nut, and hit the nut with a socket on it with a hammer to loosen it up a little bit, then remove remove the 2 bolts holding the strut to the hub and swing the whole thing out and away and remove the axle.

donteatbugs
01-09-2010, 02:06 AM
either way works, doesnt take much time either. i leave the abs sensor in and remove the strut because i have a strut tower bar thats kinda in the way. its still the easiest fwd motor ive ever pulled

Luni
01-09-2010, 02:11 AM
Bugs, you disconnect the 2 bolts on the steering knuckle holding the LOWER strut to the knuckle. And you remove 1 bolt that holds the ABS sensor.

Its WAY easier than messing with balljoints.

donteatbugs
01-09-2010, 03:10 PM
i didnt do any ball joints, they straight suck (i know) i dont like taking my abs sensors in and out though because they get broken easily. my method only takes about 5 mins longer and its easier for me to put the strut bar back on that way.

you guys need strut tower bars and you would know. i know they dont give any huge perfornace advantage but the 7th gen chasis has a lot of flex in it, im trying to take out as much as possible since i autox my car (dont wanna end up likes joeys!)

ECR_02
02-02-2010, 06:54 PM
OK, I've found an engine that seems decent and should be ready to install it this weekend. I pulled the engine and transmission out together through the top of the car. I'm going to attempt to install it the same way, through the top, engine and tansmission aready bolted together. Should I leave the side mounts attached and try to align them when lowering the engine or should I remove the side mounts and re-install them after I have the front and rear mounts attached?

It was a tight squeeze coming out so I'm not sure of the best way to go back with it.

ECR_02
02-02-2010, 09:52 PM
Another Question; Is an 04 1ZZFE a direct bolt in for the 02 GT? I've gotten mixed views on this question. Some say there is no difference and some say that I will need the 04 wiring harness because the electricals changed slightly on the 03-05 engine. Any truth to this?

donteatbugs
02-02-2010, 10:27 PM
im not as sure about the 1zz but in 03 the 2zz changed a little. they received different exhuast manifolds and drive by wire throttle body. if i were you i would see if these things are different and if they are i would use your accecories and manifolds and harness. this will be much easier than using the 04 harness.

ECR_02
02-19-2010, 04:26 PM
Still preping the engine for install. Almost ready to go back in with it. Any tips on the best way to install the engine/trans combo going in through the top?

Luni
02-19-2010, 07:36 PM
You gotta tilt it transmission down a bit get it down below the clearance point on the driver side of the car, and then level it out and grab the mount points. Set your rear mount first, then the 2 side ones, then the front one.

ECR_02
02-20-2010, 06:40 AM
Thanks Luni. Engine and transmission back in the car. Now the fun of putting everything back on and plugging it up. I will be taking my time but I hope to have it fired up by tomorrow or Sunday at the latest.

Smaay
02-22-2010, 03:16 PM
use your engine harness, for the most part i believe the 1ZZ are the same

ECR_02
02-27-2010, 06:49 PM
Success! All buckled up and running like a spotted a$$ed ape! Just made a quick 650 mile trip to the big city of Elkhart Texas and she made the trip without issue. Will make the trip back to Nashville tomorrow.

donteatbugs
02-27-2010, 09:50 PM
awesome, glad to hear it

ECR_02
03-01-2010, 10:51 PM
OK latest developement; Throwing P0171 code. I've ruled out Vacum Leaks and Misfire condition. Engine seems to run fine at speed. However, after extended driving, the engine will idle rough and die while car is at a stand still. This condition only seems to happen after the car has been driven for extended periods although I am able to reproduce the P0171 code consistently. Help!

Just so you know, I live in Davidson County TN and the car must past MARTA inspection prior to getting registration (which means the ECU cannot throw any codes), unfortunately, its time for registration renewal.

MCcelica
03-02-2010, 01:06 AM
Clean your MAF sensor. Brake cleaner will work. Just don't break it, and make sure its dry before you put it back in.

donteatbugs
03-02-2010, 01:52 AM
i wouldnt recomend brake cleaner, they make a maf cleaner and sell it at the parts store

cbarett251
03-02-2010, 03:02 PM
i wouldnt recomend brake cleaner, they make a maf cleaner and sell it at the parts store

yeah it costs more than brake cleaner, but it's hella cheaper than having to replace MAF sensor.

ECR_02
03-02-2010, 05:54 PM
OK the MAF is clean but still getting the P0171 code...anymore suggestions?

Luni
03-02-2010, 07:00 PM
Ive cleaned my MAF twice with Non Chlorinated brake cleaner twice so far. It helped clear the code the first time I did it, and last time I cleaned it, I did it cause the maf was out and I was just installing my intake.

But, you also have to either just keep driving around on the code after cleaning the maf, and the ECU will automatically clear itself after a certain amount of time, or you need to go to a parts house and borrow their OBD2 scanner and clear the code yourself.

donteatbugs
03-02-2010, 10:47 PM
my gt-s has never thrown that code, even with a cai on it. the only time it threw one was when my crank pully broke.

ECR_02
03-09-2010, 12:46 AM
O.K., I'm not sure what actually cleared the code but after I cleaned the MAF and both oxygen sensors and reseated the exhaust manifold donut, I cleared the code and so far the light is staying off. The engine was sitting out on a salvage yard so I'm guessing just alot of crap built up that needed to be burnt/cleaned out before she would settle down and fly right.

I just go back from MARTA...PASS, PASS, PASS! Damn I fell good. I guess I've still got it.

Car runs great...now if I can just convince my Son to check the damn oil...

Thanks for all the advice guys...So now that I've done an engine swap successfully, does my n00b status get updated? ;-)

Luni
03-09-2010, 01:24 AM
n00b status goes up as you post :)

Just keep postin.

donteatbugs
03-09-2010, 01:36 AM
im still a noob sometimes

Smaay
09-13-2010, 07:53 PM
if you put a 04 1ZZ in there you should have oil issues, but always check oil