PDA

View Full Version : Need Help Please!!!!



lcabral
08-27-2009, 04:54 AM
okay so i just took out my dash to paint it and today i was reinstalling it and now i try to start the car and there is no sound at all when i turn the key. my radio wont work when key is in on position. i dont know what happened (could it be a fuse??). when i dont have the key in at all there is a clicking sound and it sounds sort of like when you have your turn signal on. please help me

caneman
08-27-2009, 05:11 AM
okay so i just took out my dash to paint it and today i was reinstalling it and now i try to start the car and there is no sound at all when i turn the key. my radio wont work when key is in on position. i dont know what happened (could it be a fuse??). when i dont have the key in at all there is a clicking sound and it sounds sort of like when you have your turn signal on. please help meIt's probably the loose nut behind the steering wheel. Just kidding and it's an old joke.

Seriously, though, you've probably pulled apart or loosened a molex plug connection. Or blown a fuse. Look for the obvious things first, or as I term it, "eyeball it."

Try moving the wire connections around with your hand until (what sounds like a chattering relay) it stops clicking, or have someone turn the key to start while you manipulate the wires to see if, all of a sudden, the starter cranks.

Did you have instructions for the removal and re-installation of the dash? Or can you document your step-by-step instructions? I'd like to see them. I want to repaint my dash as well.

lcabral
08-27-2009, 05:52 AM
actually i think its a dead battery from leaving my doors open for so long cuz all the light are really dim.... so i will charge it tomorrow and see i guess
But actually for removing the dash i didnt use instructions i just took all the bolts and screws out and made sure i labeled every one so i didnt forget where they went.... so id say make sure you label!!!!! but i did find this after i was done http://www.celicatech.com/93rmsour/1993/93celica/bo/instrume.pdf
and also here are some directions on what to do (i used dupli-color vinyl and fabric spray for the dash and trim and carpet) http://www.celicatech.com/forums/showthread.php?t=43153&highlight=paint+dash

caneman
08-27-2009, 06:02 AM
I ass-u-me-d that you had checked the obvious stuff first before asking for help. My bad.

lcabral
08-27-2009, 06:19 AM
well the lights were working so i assumes it wasnt the battery... and just the sound the it was making is really odd and i just didnt think that if the battery was dead it would be making this sound, i wouldnt normally associate these two things but whatever