PDA

View Full Version : Cabriolet Hood (roof) folding problem



Beano
08-20-2009, 04:00 PM
My 1995 cabriolet has just snapped a cast alloy piece of the window frame. The canopy (what do you Americans call the 'ragtop' if not a hood) was lifting slightly askew, one side leading the other, when there was a loud 'crack!' and the whole thing sagged. I managed to heave it closed manually and secure it.
The the RHSide rear (rearmost of 3 pieces) alloy section that forms part of the window frame when the 'hood' is closed is snapped clean in two. I assume twisting stress caused this.
I can get this TIG welded locally, but I need to know why it snapped. There is obviously a drive motor in the bodywork at each side - is one leading the other - clutch slipping? Drive pin broken? How do I access the motors to check them - can you direct me to an on-line manual? Is there a God in Heaven? Help - I'm due on holiday in it at end of next week, my wife will give me very black looks if the sun comes out and we can't lower the hood (roof - ragtop - whatever)
Roger (UK)

The Captain
08-20-2009, 05:01 PM
Sounds like one cable was broken and the other was doing all the work. I think you have to take out the interior in the back to get to the motors. No online BGB's that I know of for a 6th gen vert. Maybe you could disconnect both cables and use the top manually. I dunno, just an idea.

njccmd2002
08-21-2009, 04:33 AM
either one of the motors not working or cable snapped. o the motors usually the pin breaks. 6gc,net has a sticky on how to fix.

Beano
08-21-2009, 08:46 AM
Thanks for speedy response, but who or what is 6gc,net and what is a 'sticky'?
Regards,
Roger

Murgatroy
08-21-2009, 06:25 PM
6GC.net is a 6th Gen Celica (94-99) specific site. A sticky is a forum thread that has been 'stuck' because of it's usefulness.

Beano
08-24-2009, 08:44 AM
Hi and thanks - I've found and joined 6GC but I can't find the Sticky relating to the hood.
I've removed the snapped cast alloy lifter strut and had it Tig welded back together. On investigation the drive pins on the motor on the opposite side were sheared. A pal says he may have suitable pins at work - meanwhile - the drive pins are tiny, and don't go right through the motor shaft which is only 6mm thick - the two drive pins go in from each side and only penetrate the shaft by 2mm! When you consider the weight they are coping with they are ridiculously fragile?
Advive on how to locate the exact stick will be appreciated.
Roger

Galcobar
08-24-2009, 10:42 AM
http://www.6gc.net/forums/index.php?showtopic=39973

Fuelish
08-24-2009, 09:25 PM
Personally, since you got the piece welded back together, I would just opt for manually opening and closing the roof when wanted - obviously it's not as convenient as pushing a button, but.....it works and costs nothing. I did this a couple of times on my '92 just to make sure it wasn't a big deal if and when a motor or some related part fails. So far, I have no roof problems, other than some dryrotting threads with a couple inches of seam separation (no leaks yet, though ;) )

Beano
09-15-2009, 03:13 PM
Well, I repaired it all. In spite of warnings that Tigging wouldn't work because the strut would be twisted out of true, everything lined up afterwards and all bolts went in a treat. The repair on the left side drive motor worked a treat - ONCE! Back to the drawing board, I intend grinding a flat on the shaft and a groove in the pinion and driving a tiny piece of allen (hex) key down the gap with a dose of Loctite. Fingers crossed.
BTW can anyone tell me what the little red rectangular button just ahead of the auto-shift lever is for on Japanese home market models (mine) it has Japanese characters on it. No it isn't for the hazard warning flashers. It doesn't appear to do anything.