PDA

View Full Version : another celica update!



celicaGT90_05
11-26-2008, 09:16 PM
This is what the trip to Pennsylvania was for, and I love it!

http://i49.photobucket.com/albums/f296/rangerxlt91_05/My%20Celica/000_0346.jpg

http://i49.photobucket.com/albums/f296/rangerxlt91_05/My%20Celica/000_0347.jpg

http://i49.photobucket.com/albums/f296/rangerxlt91_05/My%20Celica/000_0348.jpg

http://i49.photobucket.com/albums/f296/rangerxlt91_05/My%20Celica/000_0349.jpg

http://i49.photobucket.com/albums/f296/rangerxlt91_05/My%20Celica/000_0350.jpg

I also bought a trunk cover that had 6x9 cut outs in it before I ran to PA. I found a plug in the back I beleive was meant for system 10 that made hooking these up a ton easier.

http://i49.photobucket.com/albums/f296/rangerxlt91_05/My%20Celica/000_0351.jpg

I also bought an HID kit off my friend, but need to make a small fix in it (just a wire issue) before I can install it. I will of course have pics as soon as it goes in!

vip09
11-26-2008, 09:25 PM
Sweet hood! Looks familiar.... ;)

tuner4life
11-26-2008, 09:34 PM
Lookin better and better with every addition. I'm assuming you are going to paint it eventually? If so what color?

celicaGT90_05
11-26-2008, 09:49 PM
yeah I'm going to paint it after I finish getting the rest of the body things I want. Im going to have it repainted black

burnyd
11-26-2008, 10:06 PM
you need to make a road trip to the auto body store!

celicaGT90_05
11-26-2008, 10:07 PM
burny if you feel like paying for my paint job, I'll let you ;)

Besides, can you really complain when it use to look like this?

http://memimage.cardomain.com/ride_images/3/474/4781/26184890023_large.jpg

eatdirt40
11-26-2008, 10:12 PM
You really need to line up the front bumper with the fender....real eyesore

zmile06
11-26-2008, 10:20 PM
You really need to line up the front bumper with the fender....real eyesore
The bumper is primer black, i'm sure he doesn't care that much.

vip09
11-26-2008, 10:21 PM
You really need to line up the front bumper with the fender....real eyesore

+1.

It's the first thing I always notice when I look at your sig.

burnyd
11-26-2008, 10:41 PM
burny if you feel like paying for my paint job, I'll let you ;)

Besides, can you really complain when it use to look like this?

http://memimage.cardomain.com/ride_images/3/474/4781/26184890023_large.jpg

oh dear, looks like grumpy54 came over and got so hungry he ate the bottom half of your car, definitely a huge upgrade!!

celicaGT90_05
11-26-2008, 10:42 PM
burny what the hell are you ranting about now? lol like I said, pay for my paint job

as for the bumper, the fenders are a little messed up. Calm down guys its not finished yet!

Ads28
11-26-2008, 11:49 PM
loooks goood man, keep up the good work wish i could get ma hands on a hood

Shadowlife25
11-27-2008, 05:59 AM
I'm really curious as to which system10 plug you used...

celicaGT90_05
11-27-2008, 06:04 AM
^ for me, if you were to pop off the rear strut tower cover, there was a plug on the left, a little lower on the right. I also traced it up to the back 6.5 inch speaker, the signal came in, went to a plug mounted to the speaker box, then went back into the box while the other end of the plug ran up to that strut tower plug. Sorry I know thats a little confusing but thats how it runs. I also tested it before I hooked up the speakers, had deffinate signal on both terminals

Murgatroy
11-27-2008, 06:04 AM
It has come a long way.

It is always good to see one saved.

UndaGrwnD
11-27-2008, 08:02 AM
nice update...will look nice when its done and painted :) !

Galcobar
11-27-2008, 08:11 AM
Those plugs (there's one at both strut towers) are for the rear tweeters in a System 10.

celicaGT90_05
11-27-2008, 08:15 AM
yeah I figured it had to be for system 10, the 6x9's and 6.5s are low powered speakers though, have good highs but pathetic bass so its all good lol

UndaGrwnD
11-27-2008, 08:54 AM
LOL, i got the same plug cables in both of the towers!

ciento44
11-27-2008, 07:03 PM
yeah I figured it had to be for system 10, the 6x9's and 6.5s are low powered speakers though, have good highs but pathetic bass so its all good lol


You have pathetic bass for a couple reasons:

1) The 6x9s were never meant to go there, have no enclosure to speak of to make them respond properly. To make matters worse, you have a hatch.

2) You aren't putting any power to speak of to any of these speakers. The 6.5s in the back will put out some pretty serious fat sound if you amp them, being that they're in a true bandpass box.

3) Those 6x9s are mounted at a 90 degree angle contrary to where they should be for "correct" sound, which won't come from your back anyways.

But hey.... if you like it, who am i to judge? :D

celicaGT90_05
11-28-2008, 12:47 AM
^ I forgot to mention, the 6x9s were in boxes and tested. They have small magnets, and they arent rated for much power. I tested them on my bookshelf system, beleive me, they are not bass speakers by any means. I agree with what you're saying, and took it into consideration, but when I remembered they arent much for bass I figured why should it matter? Just adds a little more treble sound and gives a nice appearance

nyana107
11-28-2008, 01:12 AM
nice pick up. welcome to the club.
when showing off your ride, expect to get flamed. it's mandatory on C-tech. :)

Lonestag
11-28-2008, 08:09 AM
Thats sweet,
I need to to get one of those someday.