PDA

View Full Version : irritated...odd idle and air bag light on



celicaGT90_05
11-17-2008, 03:04 AM
well, I just did an interior swap on the celica which is much nicer, but now I have a problem with items that I didnt even touch. For one, the air bag light is on, Im guessing I accidently knocked a connection loose. And 2, now when I start it up, it surges the idle for about 10 seconds and then stables out at around 1600 RPM's, and when I rev it, it goes up, then coming back down it bogs a little down and then goes back up to that high RPM.

So question is, does the air bag circuitry run only on the steering column? And how in the heck would any of this cause the motor to act up? I checked loose sensors and didnt find anything, didnt see loose vacuum lines. I also let it run to make sure the battery was charged and still does the same thing. I'm rather irritated, maybe it'll just drive out and be fine, but any suggestions? Im too beat right now to even consider looking at it

92VertGT
11-17-2008, 03:47 AM
I heard this air bag light comes on all the time when someone removes their dash in 5th gens....I don't know exactly what you need to do to get it to go away though.

Not sure about the idle either.

celicaGT90_05
11-17-2008, 03:58 AM
well thats a relief that it wasnt something that just got knocked loose in the process and I have no way of knowing what, but if someone knows the cure that would be great.

The idle I am hoping solves itself tomorrow, I am going to see if it uses any more gas than usual or if it works itself out after my long trip. I did have the battery disconnected for most of the work, so that may have something to do with it.

celica91gts
11-17-2008, 05:05 AM
everytime i disconnect and reconnect my battery my car runs and idles like crap for 2-3 days. i think it's because we reset our ecu when we do that but i dont understand why it gets better after 2-3 days of driving.

Simonhla
11-17-2008, 05:05 AM
A toyota mechanic once told me that it can take up to 8 days for the ECU on these cars to relearn the settings once they have been reset/disconnected. Don't know how true that is but it falls in line with a lot of my experiences.

celicaGT90_05
11-17-2008, 05:30 AM
well thanks guys, I figure thats most likely what it is, but after doing that work I was frustrated and just wanting input lol

celicaGT90_05
11-17-2008, 03:56 PM
alright runnin perfectly fine now, but is there any fix for the air bag light? Not a big deal to me, but still would be nice

ciento44
11-17-2008, 04:25 PM
Take the light out. The chances of your air bag even funtioning correctly on a car this old is pretty slim.

celicaGT90_05
11-17-2008, 05:09 PM
well it deffinately isnt going to work now lol I was thinkin of going with a bagless steering wheel some time, but hey if there's an easy fix someone knows about it wouldnt hurt

joe's gt
11-18-2008, 05:10 AM
heres what I found, haven't tried it tho, same thing happened to me and I just took my light out :)

To clear the dtc#41 do the following:
Connect the two wires to terminals Tc and Ab (check connector on driver's side)
Turn the ignition switch to on and wait at least six seconds
Starting with the tc terminal, apply body ground alternately to tc and ab twice each in cycles of about one second
Finally keep applying body ground to tc
after a few seconds the air bag light will start to blink and cancellation of the codes is complete.
( so ground tc for a sec, wait a sec, ground ab for a sec, wait a sec, ground tc for a sec, wait a sec, ground ab for a sec, wait a sec, then hold tc on ground for a little bit and the light should go off)

airbag ecu is separate from engine ecu so disconnecting the battery won't reset any codes like it does with the engine.

celicaGT90_05
11-18-2008, 05:28 AM
thanks joe, gonna give that a try and report back

Shadowlife25
11-18-2008, 05:30 AM
http://www.toyotacelicaonline.com/airbagtool.htm

Problem solved.

celicaGT90_05
11-23-2008, 04:51 AM
well Joe I tried your trick, and it made my cruise control light flash, and my air bag light flickered in an odd pattern. Still, didnt work, the light never stayed off and it came right back on when the wires were disconnected.

joe's gt
11-24-2008, 04:09 AM
Sorry bout that. Basically that link mario gave you does exactly what I told you to do except it looks like AB is grounded 3 times instead of 2 like in the previous post I made. I would try to do the same thing I told you but make sure AB is grounded 3 times instead of 2, because I followed that tool and where the wires go and it is doing exactly what you have already done, except 3 times instead of 2. But if u want to make the tool, thats cool too.

zmile06
11-24-2008, 11:36 AM
Any time u remove the cluster gauge the air bag light might come on only way to fix it is to reset it with a home bad tool or go to the toyota dealership where they charge you like 80 90 bucks.