PDA

View Full Version : Help me dear god somebody please help me



Simonhla
08-05-2008, 10:38 PM
Ok so a a quick synopsis:

Car was stalling a lot and idle roughly. Tried many things to fix it and it nothing worked. Then discovered the head was cracked. Ended up doing a rebuild. Sent block to a machine shop and had new head put on it.

Came back and it was still doing the same thing. Low rough idle and stalling. Sometimes, the idle would surge too. Took it to the stealership (reluctantly) and ended up replacing the TPS but that only worked very briefly. Problem returned almost immediately. tested it again and ended up replacing the IACV. (all OEM parts).

The problem still persists. I am desperately low on funds and my current mechanic is out of ideas. It's very frustrating. Diagnostic is not picking up any problems but yet the idle is still all over the place and I am still intermittently stalling at stop lights etc. What the hell is going on and how can I fix it?

My thought has been a vacuum issue somewhere.
I am fairly certain it is not around the inatke manifold gasket because that is all new could it be in the hoses etc? Is getting those replaced costly and is it something that i could feasibly do myself (not an experienced mechanic at all) providing I had instructions? Any help at this point would be LIFE SAVING. I am due to move to Chicago (from LA) at the end of this month and I need to get this running. I have just dropped $3K into the new motor and random parts, only for it to not still work. This is rapidly becoming a nightmare.

EDIT: A toyota specialist told me to check the valve adjustments with a feeler guage. He said he often has problems with this when things come back from a machine shop. But i had this problem before the rebuild (providing it is the identical problem). Does this sound feasible?

VikingJZ
08-05-2008, 10:53 PM
Start fixing all that cheap shit.

Spend $20 on correct size rubber vacuum hoses. Buy a new intake manifold gasket, throttle body gasket, etc. Run to a junk yard and get an ECU to test that out as well. Fuses?

Honestly if you spent three grand on that thing you have more love than I do. How attached to that thing are you? First car? I'd go ahead and get something different ASAP before you move unless you can't afford it.

Then again, you might not be able to afford NOT buying something different if you can't get this running.

If you move to Chicago, PM me your suburb name and I can probably help you get some parts here and ship them up or drive them up on occasion. Find me some SC300 body parts in LA and I'll take care of you with some fifth gen parts here.

Simonhla
08-05-2008, 11:07 PM
Well I definitely can't afford a new car now, not after what i just spent on this one. The thinking was that after this ran so well for 16 years and 175K miles, a rebuild would give it another 10 years no problems. Obviously it will become a second car sometime in the next couple fo years and I will get a newer daily driver. The move means I am out of work until I arrive and scour the local job market. I do love this car and aside from what I think must be a small problem somwhere, this car is in tip top shape. No rust as it's been in LA and Arizona it's entire life!

The intake manifold gasket is new, as that was all done with the rebuild (so they tell me). I'll get some new vacuum hoses....any idea what exactly I need to buy, where to buy them and how hard they are to fit? How many in total?

ciento44
08-05-2008, 11:13 PM
Well I definitely can't afford a new car now, not after what i just spent on this one. The thinking was that after this ran so well for 16 years and 175K miles, a rebuild would give it another 10 years no problems. Obviously it will become a second car sometime in the next couple fo years and I will get a newer daily driver. The move means I am out of work until I arrive and scour the local job market. I do love this car and aside from what I think must be a small problem somwhere, this car is in tip top shape. No rust as it's been in LA and Arizona it's entire life!

The intake manifold gasket is new, as that was all done with the rebuild (so they tell me). I'll get some new vacuum hoses....any idea what exactly I need to buy, where to buy them and how hard they are to fit? How many in total?


You'll just get a roll of it at your local autozone or whatever, cut it to the size you need. I want to say the size you need is 3/16th, but i won't know for sure until i get home, so you'd have to wait to hear back from me tomorrow morning. By which point, someone will probably confirm for me.

And it's cheap.

rkmolina
08-14-2008, 10:57 PM
i had a similair problem last year, replaced coil .distributor ,cap, rotor, wires, plugs, intake gaskets oxy sensor, fixed a bunch of wires, turned out my ended up it was the engine control unit (the computer) put the replacement , rebuilt that i found online for 250$ 18,000 miles later not a hiccup.

Luni
08-14-2008, 11:02 PM
Your issue sounds like a sensor for sure.

It sounds like the iacv, the engine temp sensor, or even an issue with the MAP sensor. Like these guys recommended already, check vacuum leaks.

Get a can of ether (starting fluid) and spray it around all the lines. If you find one that is leaking it will make the idle go up. If you just use carb cleaner, it will make the idle go down. Either way you can find vacuum leaks that way.

Ryan
08-15-2008, 12:24 AM
^+1. try spraying starting fluid or carb cleaner around vacuum lines and intake/throttle body gasket areas and if it idles down even lower or dies you will know that is your problem

The Captain
08-15-2008, 01:13 PM
My folks 5SFE did the same thing. Turned out to be the "gas filter" that screws into the manifold. The vacuum line that goes to the MAP sensor connects to it. The damn thing was clogged. Try another vacuum source to your MAP sensor, you may have a fitting that's capped.

Simonhla
08-16-2008, 08:10 AM
Well I think I have it fixed. There was a faulty EGR valve and a bunch of the vacuum lines going to it were clogged up with carbon. Had the valve replaced and the lines unclogged.

Also discovered my distributor coil was cracked so tghat got replaced too. Picking it up tomorrow so fingers crossed it is sorted.