PDA

View Full Version : Problems with fuel pump



quark
05-24-2008, 03:16 PM
Hi there..

You might remember the burned Carlos Sainz. I have finished it, and it runs good. First i tried with the Carlos ECU, but that ECU didnīt work at all, the engine would run, but ran way to rich, and had problems starting. I rewired everything to make it run of the 88 Alltrac ECU I had. That car starts, but dies after 2-5 sec. If found out that if I put 12v to the pump in the check connector everything worked as it should. Great.... But why, I cant find anything that i have done wrong. Problem seems to be that the pump get power doing cranking, and then it stops. I look the wiring diagram over and over again to find a difference in wiring of the fuel pump, but I cant find it.

Anybody got an idea?

alltracman78
05-24-2008, 07:16 PM
The ST185 has a FP relay attached to the ECU on a bracket.
I don't know off the top of my head how the ST165 is set up, I'll try to look tonite.

Shadowlife25
05-24-2008, 10:54 PM
Off topic, but why does the Sainz ecu not work? Switching to the AT ecu you will lose a noticeable amount of power. Has your ecu temp sensor been replaced recently?

quark
05-25-2008, 07:33 AM
I went for the Temp problem with the Carlos ECU. Both cold start switch and ECU temp. Changed both of them, didnīt help. Also check them with a Ohm meter everything was fine, had the cold start injector out for leak inspection, also fine. I think the fire has burned the ECU also. The turbo pressure in the dash was on max all them time also, so I am pretty sure that itīs f.....

Sorry alltrac man, Iīam getting old, its a 91 celica, the other one. Both the Alltrac and the Carlos have the relay as far as I can see. Iīam pretty sure that itīs a "FC" problem, the Alltrac, have 2 FC connection, and the Carlos only one. But on the diagram both of them run to the same wire. I have an idea that Iīam loosing one of these connections in the wires, and that one of the 2 FC pins outs only have 12 volt duing crancking. Today i will try to connect the 2 FC together at the ECU, to se if that helps.

quark
05-25-2008, 01:16 PM
Fixed it today. Put a wire from FC to the other FC, now it works :-D Now I just need 10.000 Dollars for tax on the car.

quark
06-01-2008, 04:05 PM
http://www.celicatech.com/gallery/files/7/1/5/3/01062008032.jpg

http://www.celicatech.com/gallery/files/7/1/5/3/01062008030.jpg

http://www.celicatech.com/gallery/files/7/1/5/3/01062008029.jpg

Very burned.. But found me a free FCD :-D