PDA

View Full Version : Heater - A/C problems



Muddytazz
05-20-2008, 11:17 PM
Just bought this 1988 Celica GT. Apparently it WAS a factory a/c car. The previous owner replaced the motor but removed all aspects of the a/c system from unter the hood. All the controls and stuff are still in the dash tho from what I can tell. The problem I am having is...

1 - No matter what climate setting I have it on (hot or cold) it blows nothing but cold air.

2 - No matter what buttons you push on the dash (obviously its a push button heat-a/c car) there is a tick-tick-tick etc noice coming from under the dash/behind the console.

Any ideas?

*Edit* I think I found the tick-tick-tick deal. When I slide the cold/hot selector to the VERY far right (hot)(and almost past where it will go), the ticking stops.

Muddytazz
05-21-2008, 12:34 AM
Updated my above post

jgcox6
06-11-2008, 10:17 PM
sounds like you have a vacuum leak in your a/c heat control system to me. That is what is going to control the doors for you heat or cool. If you select different position like defrost, feet, vent does it change air flow? Does the air blow out of one position and not any others...if so....sounds like a vacuum leak..listen under the hood for a hissing sound..and also close to the control panel. Just a place to start..

CriScO
06-12-2008, 06:17 AM
Make sure the air mix control cable under the heater core is still attached. If you peel back the carpet a little bit on the passenger side you can get to it without removing the center console/center dash trim.

Rick89GTS
06-15-2008, 07:59 AM
Sounds like it's the classic intermittent no-heat problem common to 4th Gens. The solution is to resolder the connections on the rear of the heater control panel.

Here's the link:
http://toyotacelicaonline.com/board/viewtopic.php?t=1516&highlight=