PDA

View Full Version : Need help! I messed up and now engine won't start



6strngs
05-18-2008, 07:26 PM
So, I got my first alltrac 2 days ago, but it had a check engine light when I got it. So, today I was trying to figure out what that was today. I owned a 94 celica before this car, so I already knew to jump the TE1 and E1 terminals, but there is no lid for the diagnostics box in this car (it's broken off it looks like) so I didn't know which terminals were which. I figured they would be in the same place as on my other car so i did that and the light never flashed (yes I had the engine off and key to the ON position) so I tried a bunch of other combinations of terminals and still nothing. so then I started the car, because I know that on my other car, if I jumped the terminals with the engine running, the RPM would change, so I started jumping more random terminals together and one jump caused a spark, and the engine to die. now, the car doesn't start. I checked my fuses and my 15A EFI fuse was blown. also, inside the car, the CEL does not come on even with the key ON, engine off. I replaced the blown 15A fuse and checked all my other fuses including the ones in the left kick panel, specifically the engine and ECU fuses, and they were all still good. but, even with the new EFI fuse the engine still doesn't start nor does the CEL come on inside the car. I used a test light to check for power on both sides of the new EFI fuse and there is power on both sides (with the fuse in) I don't know what else could've broken besides the fuses.

If you are standing on the driver's side of the car, looking down at the diagnostics box, I think the two terminals I jumped were the top left corner and bottom left corner. but I can't find any wiring diagrams on the diagnostics box.

The car is an 88 ST165 if that helps. Please help!

6strngs
05-18-2008, 08:31 PM
oops, nevermind, I somehow missed that the 7.5A IGN fuse was also blown. it runs now