PDA

View Full Version : cruise control



celica91gts
04-30-2008, 06:05 AM
ever since my clutch and flywheel installation my cruise control does not work anymore. there is power steering fluid in the reservoir and when i push the cruise button the light in the dash lights up so it cant be a fuse can it? i checked around the engine bay and all the wires are connected up. any ideas?

Mr. Babb
04-30-2008, 06:13 AM
who needs cruise? j/k make sure the wires are hooked up on the cruise box outside

davmac
04-30-2008, 08:23 PM
My guess is that the speed sensor remains unconnected after reinstalling the tranny. The speed sensor is at the back of the tranny above and left (driver side) of the rear engine mount and against the firewall. Your speedo cable is threaded at the top and there should be an electrical connector hanging loose. If not unconnected your the speed sensor may coincidentally be bad.

Shadowlife25
05-01-2008, 03:05 AM
It is most probably the cruise control speed sensor itself. If that cable you're referring to was not connected the speedometer would not work either ;)

Try using the BGB to troubleshoot more if necessary.

juggernaut
05-01-2008, 03:22 AM
i have a similar problem except mine just stopped working one day what should i check first?

Shadowlife25
05-01-2008, 03:25 AM
Most times it is just that the cruise control speed sensor gear is worn. I don't know the P/N off hand, but it is about $80us from TOYOTA. Very rarely do the actual electronics go bad.

alltracman78
05-01-2008, 04:13 AM
See if you have any codes.
Jump Tc and E1 in the diag box. The cruise light [and several others] will flash.
Works just like the MIL, only different code #s [obviously].


It is most probably the cruise control speed sensor itself. If that cable you're referring to was not connected the speedometer would not work either ;)

Try using the BGB to troubleshoot more if necessary.

He's talking about the electronic speed sensor, not the cable.
Reread what he posted. :)

davmac
05-01-2008, 11:26 PM
alltracman: thanks for the clarification. I was referring to the electronic speed sensor.

You're also correct to advise the OP to try to pull codes. I will add that when my cc flaked out the codes are reset once you turn the ignition off. So if the cc stops operating and flashes 5 times or does not operate then you need to stop the car and leave the key in the ON position, connect the jumper on the diagnostic box and watch for the cc dash light to flash out the code.
http://www.celicatech.com/gallery/files/4/0/6/6/CC_Codes_Jumper.jpg
Codes and troubleshooting is here (http://www.celicatech.com/93rmsour/1993/93celica/be/cruiseco.pdf).

Shadowlife25
05-02-2008, 11:39 PM
:hehe: my bad... Thanks Jeremy.

Luni
05-03-2008, 12:03 AM
I will add, if there is an issue with the cruise control actuator or ECU, your cruise light would flash. If the cruise light doesnt flash and your speedo works, theres usually an issue in the circuit that gives a spd signal to the cruise control ECU/main ECU.

Shadowlife25
05-03-2008, 07:24 AM
Well, if the speed control box is bad, I have a spare. (the one located behind the center dash area, usually blue in color)

alltracman78
05-03-2008, 05:01 PM
CC ECU is actually the black retangular box.
The smaller square blue box is the door lock ECU.
:)

Shadowlife25
05-03-2008, 11:17 PM
Black schmack.... :rolleyes: :D:D

It's in my storage, so I'm going from foggy old man memory :hehe:

Either way, I know I have a spare cruise ecu.