PDA

View Full Version : Wipers don't work right on my gf's 5th gen



filonin_2
02-24-2008, 09:30 PM
So like the title says, they don't work correclty. The intermittant doesn't work at all. The regular and fast modes work, but if I switch from them to intermittant instead of switching to off, the wipers will not retract. Is there some sort of wiper contol box? If there is one, where is it? Is it just in the switch in the column? Thanks for the help.

celicaGT90_05
02-24-2008, 09:51 PM
my celica has this issue as well, and the reason why there is no retract is because the circuit is not designed for wiper park. Plus, there is also an open in the circuit. A while back I heard of something to check but forgot what it was. I havent gotten around to inspecting the circuit, but if I get the chance to before someone can field this question, I'll try to tell you what I find

filonin_2
02-26-2008, 04:54 AM
bump?

filonin_2
02-29-2008, 06:01 AM
Nobody on here knows why the wipers wouldn't work correctly or if there is some sort of module for them?

celicaGT90_05
02-29-2008, 06:14 AM
the only thing I can tell you right now is the circuit has an open in it, and as I said the only reason they wont go back down is because they arent a park circuit. Once I am able to inspect my system, I'll make sure I tell you something if I find anything out

alltracman78
03-01-2008, 02:53 AM
The switch controls everything, there's no ECU.

If it doesn't work on intermittent, it's most likely the switch.