PDA

View Full Version : why are my door locks acting up?



Maleek
02-17-2008, 07:35 PM
I just realized this as of late, but when i have my car on, and the drivers door open, and press unlock to unlock the pass. side door, I can hear the lock going off constantly as if i were pressing it over and over, but as soon as i close the door it stops. Any explanation to this, or were all celica's made this way? Thanks guys

Maleek
02-18-2008, 04:32 PM
bump, nobody knows?

alltracman78
02-18-2008, 04:55 PM
Something is sticking.
Door lock switch, lock solenoid, lock ECU, ect.

Trance4c
02-18-2008, 05:14 PM
Please explain the situation in a bit more detail..

You say that you have the drivers side door open, an as soon as you press unlock, you start hearing the locking mechanism in the door going on-off' rapidly? Does this only happen once after you hit the unlock button?

By nature, once a door is open, as soon as you hit the lock, it will self unlock as it is aware there is a door open. I would suspect that it is not wiring, as the locking mechanisms are working. I would also find it hard to fault the door lock ECU, those things just don't go back for the sake of going bad. Though, we can't rule that out.

More information, detailed on how an when it goes off is needed.

Maleek
02-18-2008, 05:33 PM
You pretty much got it. It only happens once i press unlock. Then the mechanism makes that unlocking noise constantly until i shut the door. Im not sure if it does the same with the pass. side door, because ive never tried it.

And im pretty sure it only does it when the car is on, i've never noticed it while the car was off.

Maleek
02-24-2008, 08:17 PM
bump

alltracman78
02-25-2008, 04:40 AM
You have already been told what it could be, now you need to figure out which it is. Or you can take it to a shop.
No one on here can tell you exactly what it is when the car isn't in front of them.

VikingJZ
02-25-2008, 04:49 AM
You live in Canada so sometimes these things happen in the cold.

Last winter when I still had my 1990 GT, I turned the car off and took the key out, but it was still running! I put the key back in and jiggled it to get it to stop


Check the actuator...I know they go bad on the SC's