PDA

View Full Version : 92 ST high pitch whine when accelerating



jgcox6
12-29-2007, 11:25 PM
92 St has a high pitch whine when I accelerate. It does it in neutral also...if I raise the hood and rev the motor with the accelerator cable...I can hear it whine..which actually sounds like it is coming from the back...maybe exhaust leak? The belts seem fine and if I lean over and listen by them I don't hear it coming from them...seems further back...I have checked for vacuum leak and seems like it is tight..any suggestions.

PLapping12
12-30-2007, 01:52 AM
I cant help you but im sure if you have a vid up it might help people conclude what exactly is amiss

The Captain
12-30-2007, 02:00 AM
power steering pump?

jgcox6
12-30-2007, 02:07 PM
it only happens when I race the engine..not dependent on turning the steering wheel...nor does it sound like it is coming from there..thanks though..

KoreanJoey
12-30-2007, 02:45 PM
Do you have a cone filter?

tuner4life
12-31-2007, 04:40 AM
Yeah... my 1990 Prizm has a 4afe, and it makes that same kind of noise described above, it started doing it when I installed a short ram cone filter.

Frenchy
12-31-2007, 05:13 AM
Sounds turbocharged?

Sort of?

It's the filter, if you have a cone filter...

5gen91st
12-31-2007, 06:17 AM
well my 91 st makes a really high pitch winning when i accelerate also and i found out that its comming from my air intake there was a hole in the rubber part and when i put my finger over it and rev my engine it stops so yeah check that out

geebes
12-31-2007, 06:18 AM
Maybe you have a supercharger, and dont know it! :p

Frenchy
12-31-2007, 06:42 AM
Idk, my buddy has a WRX, and says my car sounds more turboed than his does...

Not sure if there is a leak anywhere, but even if there is, I'm in no mood to fix it, it sounds baaaaaaad ass...

jgcox6
12-31-2007, 02:12 PM
Do you have a cone filter?

I do not have a cone filter...however I do have a K&N box filter...I would think I should be able to hear it when I lean over the engine....I will double check again...thanks..will let you guys know..

jgcox6
01-02-2008, 04:20 PM
I can't find this freaking squealing...open for more suggestions...

5gen91st
01-02-2008, 06:43 PM
did you check the rubber in the air intake tubing? if there is a whole in it then thats the cause mine does the same thing

KoreanJoey
01-02-2008, 09:15 PM
You probably won't be able to hear it unless the engine is under load.

VikingJZ
01-03-2008, 09:26 PM
If it is stock, you may have a crack in your intake pipe. You can duct tape it if you have no money, buy special intake tube tape, or just buy a short ram for like 30 bucks.

jgcox6
03-11-2008, 02:39 PM
I have replaced the intake tubing (rubber hose part) checked the trim around the air filter box...still can't find the noise. It almost sounds like it is coming from the exhaust under the car. If it was an exhaust problem wouldn't it be loud like a bad muffler sounds?

Sean
03-11-2008, 03:12 PM
Have you checked the passenger seat?

Luda
03-11-2008, 03:13 PM
ive got the same basic thing, im gonna try to get a video of it, although it doesnt seem to really pick up on my vid cam.

i know ive got a leak in my front pipes, im guessing its that or somewhere in my intake system. ill be checking it out some more today hopefully.

ciento44
03-11-2008, 03:40 PM
I get some gear whine or something in my car if accelerating gently through 2nd or 3rd gear only.

I can only hear it if my stereo is off, and my exhaust is fixed.

I can remember this particular car doing it since 1995.