View Full Version : Zap

08-17-2007, 05:59 PM
1972 Celica ST (18RC)

I was reconnecting my battery today...and everything sparked.

The ground wire is exposed for a good foot or so in certain spots.

I didn't realize it, but the battery wires were crossed and touching when I tried to put the battery back on.

I un-crossed them, and now the terminals don't spark when you attach the cable.

However, now the car won't start or allow any electronics to work.

What could be the problem?

FYI smoke came out from everywhere.

08-17-2007, 06:03 PM
Have you checked the battery and all the fuses?

08-17-2007, 10:44 PM
Blown fuses are a deffinate answer. And hopefully the fuses blew and not something like the starter.

08-18-2007, 05:26 AM
The wiring was fried and charbroiled all the way back to where the connection to the volt meter and OPG are on the dash.

As it seems, the wiring harness is now in two pieces awaiting their removal and rewiring.

08-18-2007, 05:46 AM
when reconnecting a battery you should get a mild spark since everything is firing back up and they are taking a higher amount of amperage than usual. Did you test to make sure the battery is still puttin out?

08-18-2007, 08:57 AM
^But it might not if the entire wiring harness is actually severed cause you would simply be extending the post without grounding it out anywhere to cause a spark... maybe. I'm just talking out my ass here.

08-20-2007, 05:51 AM
Naw...I got the guage cluster out and its fried all the way to the volt meter/oil pressure guage.

I decided to rewire the whole car from the main harness because of this problem and for the fact that the headlights only work when you turn the brights on.

I mean...this was on my agenda of things to do while restoring this car anyway, just not this soon.

Oh well....should run like a top when the summer calls its final days.

08-20-2007, 05:52 AM
Didn't realize i told you about the dash stuff.

Battery is good. Most of the wiring on this car is old as fuck and needs to be replaced anyway.